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1
mwCVS Overview and Setup

This chapter is an overview of the CodeWarrior™ Concurrent Versions System (mwCVS) 
plug-in and its setup. Use mwCVS together with the CodeWarrior™ IDE to perform CVS 
operations. 

This chapter has these topics:

• “Differences Between GNU CVS and mwCVS” on page 5

• “System Requirements” on page 6

• “Learning More About CVS” on page 6

• “mwCVS Installation” on page 7

• “Turning On mwCVS” on page 9

• “Turning Off mwCVS” on page 11

The mwCVS plug-in adds some GNU is Not UNIX (GNU) CVS commands to the 
CodeWarrior IDE. This plug-in implements a command-line wrapper for common CVS 
commands. You can use mwCVS in addition to using a separate CVS application to issue 
those commands.

Differences Between GNU CVS and mwCVS
Most of the mwCVS implementation of CVS commands closely follows the GNU CVS 
implementation. The mwCVS implementation of the remove command, however, differs 
from the GNU CVS implementation:

• mwCVS remove deletes the file on disk (local file) as part of executing the 
command (remove -f). This behavior differs from the default GNU CVS 
implementation, which does not remove the local file as part of executing the 
command (remove).

• mwCVS remove commits the file deletion as part of executing the command. This 
behavior differs from the default GNU CVS implementation, where you must 
explicitly commit removed files. mwCVS automatically commits the file removal.
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System Requirements
Your computer system must meet these minimum requirements before you can use the 
mwCVS plug-in with the IDE:

• CodeWarrior IDE version 5.0 or higher

• On a Windows host: Microsoft® Windows® XP, Windows® 2000, Windows NT®, 

or Windows® 98 operating system

• On a Macintosh host: Apple® Mac® OS X 10.1.3 or higher operating system

Using mwCVS with the IDE involves adding files to your CodeWarrior installation. See 
“mwCVS Installation” on page 7 for more information.

NOTE Some versions of the CodeWarrior IDE ship with the mwCVS plug-in and its 
support files pre-installed.

Learning More About CVS
This mwCVS Plug-in User Guide explains how to use the mwCVS plug-in with the 
CodeWarrior IDE. If you are not familiar with general CVS concepts, consult the web 
sites listed in this section to learn more about CVS.

For information about frequently asked questions, documentation, and graphical user-
interface (GUI) tools for CVS, see this site:

http://cvsgui.sourceforge.net/
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mwCVS Installation
This section explains how to install the mwCVS plug-in and its support files into a 
CodeWarrior installation. Table 1.1 lists these files by host.

NOTE Some versions of the CodeWarrior IDE ship with the mwCVS plug-in and its 
support files. If you upgrade mwCVS, however, follow the instructions in this 
section to ensure that you upgrade all files correctly.

Installing mwCVS on a Windows Host

Follow these steps to install mwCVS and its support files:

NOTE These directions apply to version 1.3 of the mwCVS plug-in.

1. Find the path to your CodeWarrior directory. Subsequent steps refer to this path as the 
CodeWarriorDirPath.

TIP On most Windows hosts, this is the default path to the CodeWarrior directory:
C:\Program Files\Freescale\CodeWarrior\

2. Place the file mwcvs.dll in:
CodeWarriorDirPath\Bin\Plugins\version control\

3. Place the file pMWCVS.dll in:
CodeWarriorDirPath\Bin\Plugins\Preference Panel\

4. Place the file cvs.exe in:
CodeWarriorDirPath\(Helper Apps)\

Table 1.1  mwCVS files

Host mwCVS Files

Windows • mwCVS.dll

• pMWCVS.dll

• cvs.exe

• cwspawn.exe

Macintosh • mwCVS

• mwCVS Panel

• CVSAdapter.bundle
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5. Place the file cwspawn.exe in:
CodeWarriorDir\(Helper Apps)\

Installing mwCVS on a Macintosh Host

NOTE Unlike the Windows version, the Mac OS X version of mwCVS does not 
include its own version of the cvs executable file. Instead, mwCVS for
Mac OS X uses the default CVS shell application /usr/bin/cvs.

Follow these steps to install mwCVS and its support files:

1. Find the path to your CodeWarrior folder. Subsequent steps refer to this path as the 
CodeWarriorFldrPath.

NOTE On Macintosh hosts, this is the default path to the CodeWarrior folder, where 
StartupDiskName is the name of your startup disk, and VersionNumber is the 
version number of your CodeWarrior product: 
StartupDiskName:Applications:Freescale CodeWarrior
VersionNumber:Freescale CodeWarrior:.

2. Place the file mwCVS in:
CodeWarriorFldrPath:CodeWarrior Plugins:Version Control:

3. Place the file mwcvs Panel in:
CodeWarriorFldrPath:CodeWarrior Plugins:Preference Panels:

4. Place the file CVSAdapter.bundle in your CodeWarrior directory, at the same 
level as the CodeWarrior IDE application.
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Turning On mwCVS
You can turn on mwCVS in the IDE for different scopes of operation. Table 1.2 explains 
these scopes.

Turning On mwCVS in the Global Scope

Follow these steps to turn on mwCVS in the global scope:

1. Close all open projects in the IDE.

After you close all projects, you can modify mwCVS settings in the global scope.

2. Choose Edit > Version Control Settings.

The VCS Settings window appears.

3. Select VCS Setup in the VCS Settings Panels list.

The VCS Setup panel appears.

NOTE Only three options in the VCS Setup panel apply to mwCVS operation:
Use Version Control, Method, and Use global settings as default.

4. Select the Use Version Control option.

5. Select mwCVS from the Method list box.

The mwCVS item appears in the VCS Settings Panels list.

NOTE If you want projects to inherit their VCS settings from the global settings that 
you specify, check the Use global settings as default checkbox.

Table 1.2  mwCVS Scopes

Scope Explanation

Global To turn on this scope, first close all projects in the IDE. Configuring 
mwCVS in the global scope allows individual projects to inherit 
their VCS settings from the global settings that you specify (when 
you check the Use global settings as default checkbox).

Project To turn on this scope, first bring forward a project. Configuring 
mwCVS in the project scope allows each project to have different 
VCS settings. These project-level VCS settings override the global 
settings that you specify.
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6. Click Apply or Save to confirm your changes.

7. Close the VCS Settings window.

Enabling mwCVS causes the VCS menu to appear in the menu bar. You use this menu to 
issue CVS commands from the CodeWarrior IDE.

This icon represents the VCS menu on a Macintosh host.

Turning On mwCVS in the Project Scope

Follow these steps to turn on mwCVS in the project scope:

1. Bring forward the project for which you want to turn on mwCVS.

The mwCVS settings you specify apply to this project only.

2. Choose Edit > Version Control Settings.

The VCS Settings window appears.

3. Select VCS Setup in the VCS Settings Panels list.

The VCS Setup panel appears.

NOTE Only two options in the VCS Setup panel apply to mwCVS operation:
Use Version Control and Method.

4. Select the Use Version Control option.

5. Select mwCVS from the Method list box.

The mwCVS item appears in the VCS Settings Panels list.

6. Click Apply or Save to confirm your changes.

7. Close the VCS Settings window.

Enabling mwCVS causes the VCS menu to appear in the menu bar. You use this menu to 
issue CVS commands from the CodeWarrior IDE.

This icon represents the VCS menu on a Macintosh host.
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Turning Off mwCVS
You can turn off mwCVS in the IDE for different scopes of operation. Table 1.3 explains 
these scopes.

Turning Off mwCVS in the Global Scope

Follow these steps to turn off mwCVS in the global scope:

1. Close all open projects in the IDE.

After you close all projects, you can modify mwCVS settings in the global scope.

2. Choose Edit > Version Control Settings.

The VCS Settings window appears.

3. Select VCS Setup in the VCS Settings Panels list.

The VCS Setup panel appears.

4. Select None from the Method list box.

The mwCVS item disappears from the VCS Settings Panels list.

5. Clear the Use Version Control option.

6. Click Apply or Save to confirm your changes.

7. Close the VCS Settings window.

Disabling mwCVS causes the VCS menu to disappear from the menu bar.

Table 1.3  mwCVS Scopes

Scope Explanation

Global To turn off this scope, first close all projects in the IDE. Turning off 
mwCVS in the global scope prevents individual projects from 
inheriting global VCS settings.

Project To turn off this scope, first bring forward a project. Turning off 
mwCVS for one project does not affect the mwCVS state of
other projects.

You can turn on mwCVS globally, but turn it off for individual 
projects. This configuration is useful when you want to keep the 
global VCS settings you specified, but disable them in an
individual project.
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Turning Off mwCVS in the Project Scope

Follow these steps to turn off mwCVS in the project scope:

NOTE If you checked the Use global settings as default checkbox in the global 
scope, you can keep mwCVS turned on globally, but turn it off for a given 
project. This way, other projects can still inherit the global settings, while the 
project for which you turn off mwCVS does not inherit the global settings.

1. Bring forward the project for which you want to turn off mwCVS.

The mwCVS settings you specify apply to this project only.

2. Choose Edit > Version Control Settings.

The VCS Settings window appears.

3. Select VCS Setup in the VCS Settings Panels list.

The VCS Setup panel appears.

4. Select None from the Method list box.

The mwCVS item disappears from the VCS Settings Panels list.

5. Clear the Use Version Control option.

6. Click Apply or Save to confirm your changes.

7. Close the VCS Settings window.

Disabling mwCVS causes the VCS menu to disappear from the menu bar.
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2
Configuring mwCVS

This chapter explains how to configure the options in the mwCVS panel. The options 
correspond to GNU CVS command-line switches. These options determine how mwCVS 
operates with the CodeWarrior™ IDE. Also, this chapter explains how to configure 
mwCVS to work together with a secure shell (ssh).

This chapter has these topics: 

• “mwCVS Panel” on page 13

• “mwCVS Panel Options” on page 15

• “Integrating mwCVS with ssh” on page 16

NOTE The VCS Setup panel in the VCS Settings window has two options for 
configuring mwCVS: Use Version Control and Method. See “Turning On 
mwCVS” on page 9 for more information about these options. The other 
options in the VCS Setup panel do not apply to configuring mwCVS.

mwCVS Panel
Use the mwCVS panel, shown in Figure 2.1, to configure default mwCVS options. This 
panel appears in the VCS Settings window after you turn on mwCVS in the
VCS Setup panel. Table 2.1 on page 14 briefly explains the panel options.
See “mwCVS Panel Options” on page 15 for more detailed explanations.

NOTE You do not specify the local path in the mwCVS panel. Instead, mwCVS uses 
the local path of each and every project file.
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Figure 2.1  mwCVS panel

Table 2.1  mwCVS panel options

Option Explanation

Make new working files read-only (-r) Select to prevent changes to new working 
files that you check out from the CVS 
repository.

Use gZip level 9 compression (-z) Select to use gZip level 9 (high 
compression) for files transmitted between 
the IDE and the CVS repository.

Command Output Select the level of information that you 
want mwCVS to output for CVS 
operations.

Compatible with WinCVS 1.2 Select to prevent Daylight Saving Time 
issues from affecting CVS operations with 
WinCVS 1.2.
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mwCVS Panel Options
This section explains mwCVS panel options in detail. These options configure the default 
settings for various CVS operations.

Make new working files read-only
Select this option to make the file read-only on the disk after issuing the CVS command. 
Clear this option to make the file read/write.

Selecting this option is equivalent to using the GNU CVS command-line switch -r. The 
option also overrides the CVSREAD environment variable.

Use this option to manage changes to source code that you retrieve from the CVS 
repository. For example, select this option to preserve the files that you retrieve from the 
repository so that you cannot easily change them.

Use gZip level 9 compression
Select this option to compress files using gZip level 9 during transmission between the 
IDE and the CVS repository. Clear this option to transmit files without using compression.

Selecting this option is equivalent to using the command-line switch -z.

Use this option to manage network and bandwidth issues when transmitting data between 
your computer and the CVS repository. For example, select this option to reduce file size 
and shorten transmission time.

Command Output
Select from this list box the level of information that you want mwCVS to output during 
CVS operations. The output appears in an editor window.

Output choices include:

• Default—Select this option to output informational messages.

• Quiet—Select this option to output non-informational messages. This option is 
equivalent to the command-line switch -q.

• Very Quiet—Select this option to output only messages for serious errors. This 
option is equivalent to the command-line switch -Q.
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Compatible with WinCVS 1.2
Select this option to prevent Daylight Saving Time issues from affecting CVS operations 
with WinCVS version 1.2.

NOTE If you use WinCVS version 1.3 beta, or a newer version, clear
this option.

Integrating mwCVS with ssh
This section explains how to set up mwCVS to work together with a secure shell to access 
a CVS repository on a Linux-based computer. To follow the steps in this section, you 
should be familiar with ssh and its use of public- and private-key encryption.

Integrating mwCVS with ssh on a Linux Host

Follow these steps to integrate mwCVS with ssh:

1. Generate an ssh public and private key pair by entering this command line in a 
terminal window, where the -t flag specifies the key type and the -C flag specifies a 
key comment (such as your user name and host name):

ssh-keygen -t dsa -C user@host

2. Press the Enter key at the prompt Enter file in which to save the key.

3. Press the Enter key at the prompt Enter passphrase.

The public key id_dsa.pub and the private key id_dsa appear in ~/.ssh.

NOTE For security, set the permissions on ~/.ssh to 0600 (readable and writable by 
you only).

4. Add the content of your public key (id_dsa.pub) to the authorized_keys file 
on the computer that hosts the CVS repository. The content of your public key is the 
line that begins with the text ssh-dss.

NOTE If the CVS repository uses SSH2, add the content of your public key to the 
authorized_keys2 file instead of the authorized_keys file.

The content of your public key should become a new line at the end of cvsowner/
.ssh/authorized_keys or cvsowner/.ssh/authorized_keys2 on the 
CVS repository host, where cvsowner is the name of the user account that owns 
CVSROOT.
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NOTE Never share your private key (id_dsa).

5. Try accessing the CVS repository by entering this command line in a terminal 
window, where pathtokey is the local path to your private key, cvsowner is the 
name of the user account on the CVS repository host that owns CVSROOT, and 
serveraddr is the address of the CVS repository host:

ssh -i pathtokey -l cvsowner serveraddr

After you successfully use ssh to access the CVS repository, continue with the 
remainder of this procedure.

6. Configure local CVS environment variables to have mwCVS use ssh. Add these lines 
to your ~/.bashrc file, where user is your CVS login name, serveraddr is the 
address of the CVS repository host, and pathtocvsroot is the path to the 
CVSROOT of the CVS repository host:

CVS_RSH="ssh"

CVSROOT=":ext:user@serveraddr:/pathtocvsroot"

export CVS_RSH CVSROOT

7. Try checking out a module from the CVS repository by entering this command line in 
a terminal window, where module is the path to the module that you want to
check out:

cvs -d $CVSROOT checkout module

After you successfully check out a module in the last step, you have completed integrating 
mwCVS with ssh. See “mwCVS Overview and Setup” on page 5 for more information on 
turning mwCVS on and off.

Integrating mwCVS with ssh on a Windows Host

Follow these steps to integrate mwCVS with ssh:

1. Install OpenSSH for Windows. The installer is available at this URL:

http://sshwindows.sourceforge.net/download/

NOTE If you do not plan to use ssh to log into your Windows computer from another 
computer, you can ignore the installation message regarding the passwd file.

2. Select Start > Programs > Accessories > Command Prompt.

A terminal window appears.
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3. Generate an ssh public and private key pair by entering this command line in the 
terminal window, where the -t flag specifies the key type and the -C flag specifies a 
key comment (such as your user name and host name):

ssh-keygen -t dsa -C user@host

4. Press the Enter key at the prompt Enter file in which to save the key.

5. Press the Enter key at the prompt Enter passphrase.

The public key id_dsa.pub and the private key id_dsa appear in this directory, 
where loginname is the name you use to log in to your Windows computer:

C:\Documents and Settings\loginname\.ssh

NOTE For security, set the permissions on the .ssh directory so that only you can 
read and write to it.

6. Add the content of your public key (id_dsa.pub) to the authorized_keys file 
on the computer that hosts the CVS repository. The content of your public key is the 
line that begins with the text ssh-dss.

NOTE If the CVS repository uses SSH2, add the content of your public key to the 
authorized_keys2 file instead of the authorized_keys file.

The content of your public key should become a new line at the end of cvsowner/
.ssh/authorized_keys or cvsowner/.ssh/authorized_keys2 on the 
CVS repository host, where cvsowner is the name of the user account that owns 
CVSROOT.

NOTE Never share your private key (id_dsa).

7. Try accessing the CVS repository by entering this command line in a terminal 
window, where loginname is the name you use to log in to your Windows 
computer, cvsowner is the name of the user account on the CVS repository host that 
owns CVSROOT, and serveraddr is the address of the CVS repository host:

ssh -i /home/loginname/.ssh/id_dsa -l cvsowner serveraddr

After you successfully use ssh to access the CVS repository, continue with the 
remainder of this procedure.

8. Select Start > Settings > Control Panel.

9. Open the System control panel.

The System Properties window appears.

10. Click the Advanced tab of the System Properties window.
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11. Click the Environment Variables button.

The Environment Variables window appears.

12. In the System variables list, click the New button.

The New System Variable dialog box appears.

13. Enter CVS_RSH in the Variable name text box.

14. Enter ssh in the Variable value text box.

15. Click the OK button.

16. In the System variables list, click the New button again.

17. Enter CVSROOT in the Variable name text box.

18. In the Variable value text box, enter following text, where user is your CVS login 
name, serveraddr is the address of the CVS repository host, and 
pathtocvsroot is the path to the CVSROOT of the CVS repository host:

:ext:user@serveraddr:/pathtocvsroot

19. Click the OK button.

20. Click the OK button in the Environment Variables window.

21. Click the OK button in the System Properties window.

22. Try using the CodeWarrior IDE to check out a module from the CVS repository.

After you successfully check out a module in the last step, you have completed integrating 
mwCVS with ssh. See “mwCVS Overview and Setup” on page 5 for more information on 
turning mwCVS on and off.
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3
Using mwCVS

With the mwCVS plug-in installed, configured, and started, the CodeWarrior™ IDE’s 
version-control features use GNU CVS. This chapter explains how the IDE works with 
GNU CVS. 

This chapter has these topics:

• “Project Window” on page 21

• “Context Menus” on page 23

• “IDE Version Control System (VCS) Commands” on page 24

• “File Commands” on page 26

• “Project Commands” on page 44

• “Recursive Commands” on page 58

Project Window
The project window in the CodeWarrior IDE displays CVS status icons after you turn on 
mwCVS in the VCS Settings window. These icons indicate the status of each file in the 
project.

Figure 3.1 on page 23 shows a sample project window with CVS status icons. Table 3.1 on 
page 22 explains these icons.
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Table 3.1  CVS status icons
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Figure 3.1  CVS status icons in the project window

Context Menus
mwCVS adds CVS commands to the IDE context menu. The commands that appear in the 
context menu depend on the items that you select. Use these CVS context-menu 
commands as shortcuts for common commands in the VCS menu.

Figure 3.2 on page 24 shows a sample IDE context menu that has CVS commands.

CVS Status Icons



Using mwCVS
IDE Version Control System (VCS) Commands

24 Version Control Plug-in 1.3 for CVS

Figure 3.2  Sample CVS context menu in the project window

IDE Version Control System (VCS) 
Commands

This section explains the IDE commands for version-control systems.

Synchronize Status
Select VCS > Synchronize Status to refresh the CVS status icons that appear in the 
project window. After you select this command, mwCVS analyzes CVS information about 
each file in your project. It compares this information against the information stored in the 
CVS data folder that resides in your project folder. The IDE uses the results of these 
comparisons to update each status icon in the project window.

sample CVS con-
text menu com-
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After you select this command, a progress indicator shows synchronization progress.

See Table 3.1 on page 22 for more information about the CVS status icons that appear in 
the project window.

Synchronize Selection/Document
Select VCS > Synchronize Selection to refresh the CVS status icon of the selected items 
in the project window. If you select a group, the operation applies to all items in that 
group. Select VCS > Synchronize Document to refresh the CVS status icon of the active 
editor window. After you select this command, mwCVS analyzes CVS information about 
the selected items. It compares this information against the information stored in the CVS 
data folder that resides in your project folder. The IDE uses the results of this comparison 
to update the status icons that appear in the
project window.

After you select this command, a progress indicator shows synchronization progress.

See Table 3.1 on page 22 for more information about the CVS status icons that appear in 
the project window.

NOTE (Macintosh) Hold down the Shift key in order to select VCS > Synchronize 
Selection or VCS > Synchronize Document.
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File Commands
This section explains the mwCVS commands for files.

Update
Select a file in the project window, then select VCS > Update to display the Update dialog 
box. Figure 3.3 shows the Update dialog box for a file. Table 3.2 on page 27 explains the 
dialog-box options.

After you click Update, a progress indicator appears.

NOTE You can change the default settings for the Read-Only and Command Output 
options. Use the mwCVS panel in the VCS Settings window to configure the 
default settings. See “mwCVS Panel Options” on page 15 for more 
information.

Figure 3.3  Update dialog box (for files)
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Table 3.2  Update dialog box (for files)—options

Option Explanation

Overwrite locally modified file Select to replace a locally modified file with the version 
stored on the CVS repository. Clear to preserve the 
locally modified file.

Selecting this option is equivalent to using the GNU 
CVS command-line switch -C.

Reset sticky tags Select to remove any sticky tags associated with the 
selected file after the IDE completes the update 
operation. Clear to preserve existing sticky tags.

Selecting this option is equivalent to using the 
command-line switch -A.

Retrieve before date Select to enter in the corresponding field the date 
before which you want to retrieve a version of the file 
in the CVS repository. Clear to disregard date 
information.

Enter the date according to GNU CVS conventions. 
Sample dates are:

• 1 month ago

• last Monday

• 3/31/02 10:00:04 PST

Selecting this option is equivalent to using the 
command-line switch -D Date, where Date is the date 
to use for this operation.

Retrieve revision Select to enter in the corresponding field the revision 
tag of the file that you want to retrieve from the CVS 
repository. Clear to disregard revision-tag information.

Selecting this option is equivalent to using the 
command-line switch -r NumberOrTag, where 
NumberOrTag is the revision number or tag to use for 
this operation.
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Merge 
From 
Branch

Revision Select to enter in the corresponding field the revision 
tag or branch name of the file that you want to retrieve 
from the CVS repository. The IDE retrieves this file 
and merges its contents with the contents of your local 
file. Clear to preserve the contents of the local file.

Selecting this option is equivalent to using the 
command-line switch -j NumberOrTag.

and this 
Revision

Select to enter in the corresponding field a revision tag 
or branch name that, together with the Revision entry, 
specifies a version range over which to merge file 
contents. Clear to preserve the contents of the local 
file.

The IDE interprets the combination of Revision and 
this Revision differently from Revision alone. CVS 
merges into the local file any changes between the 
version specified by Revision and the version 
specified by and this Revision.

Selecting this option is equivalent to using the 
command-line switch -j NumberOrTag
-j NumberOrTag.

Read-Only Select to make the file read-only on the disk after 
issuing the Update command. Clear to make the file 
read/write.

This option supersedes the setting in the mwCVS 
panel of the VCS Settings window.

Selecting this option is equivalent to using the 
command-line switch -r. Clearing this option is 
equivalent to using the command-line switch -w.

Table 3.2  Update dialog box (for files)—options (continued)

Option Explanation
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Do not change any files Select to see the result of the update operation without 
modifying the CVS repository. Clear to modify the CVS 
repository to reflect the update operation.

Selecting this option is equivalent to using the 
command-line switch -n.

Command Output Select the level of information that you want mwCVS 
to output during CVS operations:

• Default—output informational messages

• Quiet—output non-informational messages 
(-q)

• Very Quiet—output only messages for 
serious errors (-Q)

This option supersedes the setting in the mwCVS 
panel of the VCS Settings window.

Table 3.2  Update dialog box (for files)—options (continued)

Option Explanation
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Commit
Select a file in the project window, then select VCS > Commit to open the Commit dialog 
box. Figure 3.4 shows the Commit dialog box for a file. Table 3.3 on page 31 explains the 
dialog-box options.

After you click Commit, a progress indicator shows commit progress.

NOTE You can change the default settings for the Read-Only and Command Output 
options. Use the mwCVS panel in the VCS Settings window to configure the 
default settings. See “mwCVS Panel Options” on page 15 for more 
information.

Figure 3.4  Commit dialog box (for files)
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Table 3.3  Commit dialog box (for files)—options

Option Explanation

Log message Enter a log message for the file that you will commit.

Entering a message in this field is equivalent to using the 
GNU CVS command-line switch -m Text, where Text is 
the log message to use for this operation.

Commit to revision Select to enter in the corresponding field a numeric or 
symbolic revision tag to which you want to commit the file. 
Clear to commit the file to the latest revision.

Selecting this option is equivalent to using the command-
line switch -r NumberOrTag, where NumberOrTag is the 
revision number or tag to use for this operation.

Read-Only Select to make the file read-only on the disk after issuing 
the Commit command. Clear to make the file read/write.

This option supersedes the setting in the mwCVS panel of 
the VCS Settings window.

Selecting this option is equivalent to using the command-
line switch -r. Clearing this option is equivalent to using 
the command-line switch -w.

Do not change any files Select to see the result of the commit operation without 
modifying the CVS repository. Clear to modify the CVS 
repository to reflect the commit operation.

Selecting this option is equivalent to using the command-
line switch -n.

Command Output Select the level of information that you want mwCVS to 
output during CVS operations:

• Default—output informational messages

• Quiet—output non-informational messages (-q)

• Very Quiet—output only messages for serious 
errors (-Q)

This option supersedes the setting in the mwCVS panel of 
the VCS Settings window.
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Status
Select a file in the project window, then select VCS > Status to open the Status dialog 
box. Figure 3.5 shows the Status dialog box for a file.

Select Include tag information to include in the status report information about tags 
applied to the file revisions. Clear the option to exclude the tag information from the status 
report. Selecting the option is equivalent to using the command-line switch -v.

Notice that the default mwCVS status behavior is to include tag information, which is 
equivalent to using the GNU CVS command line status -v.

After you click Status, a progress indicator appears. After the IDE completes the status 
operation, an editor window appears. This editor window shows the status information for 
the selected file.

Figure 3.5  Status dialog box (for files)
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Difference
Select a file in the project window, then select VCS > Difference to open the Diff dialog 
box. Figure 3.6 shows the Diff dialog box for a file. Table 3.4 explains the dialog-box 
options.

After you click Diff, a progress indicator shows difference progress. After the IDE 
completes the difference operation, either the File Compare Results window or an editor 
window appears, depending on your settings. These windows contain the difference 
information for the selected files.

Figure 3.6  Diff dialog box (for files)

Table 3.4  Diff dialog box (for files)—options

Option Explanation

CodeWarrior Diff Select to display difference results in a File Compare 
Results window. This window graphically depicts 
difference information.

If you select this option, you cannot select the GNU Diff 
option.

GNU Diff Select to display difference results in an editor window. 
The difference information appears in textual form in the 
editor window.

If you select this option, you cannot select the 
CodeWarrior Diff option. Selecting this option also turns 
on the Contextual and Universal options.
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Diff local file with same 
revision in CVS

Select to display difference results between the local 
working file and the corresponding revision of that file in 
the CVS repository.

If you select this option, you cannot select the Diff local 
file with a specific revision(s) or Diff two remote 
revisions options.

Diff local file with a 
specific revision(s)

Select to enter information to use for the difference 
operation. Select an item in the list box, then supply 
information for that item in the corresponding field:

• Revision/Tag—Enter a revision number or tag 
to use for the difference operation. This option is 
equivalent to using the command-line switch
-r NumberOrTag, where NumberOrTag is the 
revision number or tag to use for this operation.

• Date—Enter a date to use for the difference 
operation. This option is equivalent to using the 
command-line switch -D Date, where Date is 
the date to use for this operation.

The IDE displays difference results between the local 
working file and the specified revisions of that file in the 
CVS repository.

If you select this option, you cannot select the Diff local 
file with same revision in CVS or Diff two remote 
revisions options.

Table 3.4  Diff dialog box (for files)—options (continued)

Option Explanation
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Diff two remote revisions Select to enter information to use for the difference 
operation. In this case, you select two revisions of the file 
in the CVS repository.

Use the first pair of fields under the Diff local file with a 
specific revision(s) option to specify the first revision that 
you want to use in the difference operation. Use the 
second pair of fields under the Diff two remote revisions 
option to specify the second revision that you want to use 
in the difference operation.

The second pair of fields corresponds to the part of this 
command-line expression enclosed in braces:

[[-r NumberOrTag] | [-D Date]] 

{ [[-r NumberOrTag] | [-D Date]] }

The IDE displays difference results between the specified 
revisions of the file in the CVS repository.

If you select this option, you cannot select the Diff local 
file with same revision in CVS.

Contextual Select to generate a contextual-format difference for use 
with the UNIX patch command. Clear to generate a non-
contextual format.

Selecting this option is equivalent to using the command-
line switch -c.

Select the GNU Diff option to turn on the Contextual 
option.

Universal Select to generate a universal-format difference. Clear to 
generate a non-universal format.

Selecting this option is equivalent to using the command-
line switch -u.

Select the GNU Diff option to turn on the Universal 
option.

Table 3.4  Diff dialog box (for files)—options (continued)

Option Explanation
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Tag
Select a file in the project window, then select VCS > Tag to open the Tag dialog box. 
Figure 3.7 shows the Tag dialog box for a file. Table 3.5 explains the dialog-box options.

After you click Tag, a progress indicator shows tag progress.

NOTE You can change the default settings for the Read-Only and Command Output 
options. Use the mwCVS panel in the VCS Settings window to configure the 
default settings. See “mwCVS Panel Options” on page 15 for more 
information.

Figure 3.7  Tag dialog box (for files)

Table 3.5  Tag dialog box (for files)—options

Option Explanation

Tag name Enter the name of the tag.

Tag revision Select to enter in the corresponding field the file revision 
that you want to tag. Clear to apply the tag to the latest 
revision.

Selecting this option is equivalent to using the GNU CVS 
command-line switch -r NumberOrTag, where 
NumberOrTag is the revision number or tag to use for this 
operation.
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Tag as of date Select to enter in the corresponding field the date of the 
file revision that you want to tag. Clear to apply the tag to 
the latest revision date.

Selecting this option is equivalent to using the command-
line switch -D Date, where Date is the date to use for this 
operation.

Create branch Select to use the tag to denote a branch of the file revision 
in the CVS repository. Clear to use the tag to denote a 
label for a particular file revision.

Selecting this option is equivalent to using the command-
line switch -b.

If you select this option, you cannot select the Delete tag 
option.

Delete tag Select to permanently delete the specified tag from the 
CVS repository. Clear to add the tag to the specified file 
revision.

Selecting this option is equivalent to using the command-
line switch -d.

If you select this option, you cannot select the Create 
branch or Move tag if it exists options.

Move tag if it exists Select to have the IDE relocate existing tags with the same 
name as the tag you specify. Clear to have the IDE display 
an error message if it encounters an existing tag with the 
same name as the tag you specify.

Selecting this option is equivalent to using the command-
line switch -F.

If you select this option, you cannot select the Delete tag 
option.

Tag latest head revision if 
tag/date is not found

Select to have the IDE apply the tag to the latest file 
revision on the CVS repository if it does not encounter a 
revision with the specified tag or date. Clear to have CVS 
report an error if it fails to find a matching tag.

Selecting this option is equivalent to using the command-
line switch -f.

Table 3.5  Tag dialog box (for files)—options (continued)

Option Explanation
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Read-Only Select to make the file read-only on the disk after issuing 
the Tag command. Clear to make the file read/write.

This option supersedes the setting in the mwCVS panel of 
the VCS Settings window.

Selecting this option is equivalent to using the command-
line switch -r.

Do not change any files Select to see the result of the tag operation without 
modifying the CVS repository. Clear to modify the CVS 
repository to reflect the tag operation.

Selecting this option is equivalent to using the command-
line switch -n.

Command Output Select the level of information that you want mwCVS to 
output during CVS operations:

• Default—output informational messages

• Quiet—output non-informational messages (-q)

• Very Quiet—output only messages for serious 
errors (-Q)

This option supersedes the setting in the mwCVS panel of 
the VCS Settings window.

Table 3.5  Tag dialog box (for files)—options (continued)

Option Explanation
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Add
Select a file in the project window that does not currently reside in the CVS repository, 
then select VCS > Add to open the Add dialog box. Figure 3.8 shows the Add dialog box 
for a file. Table 3.6 explains the dialog-box options.

After you click Add, a progress indicator appears.

NOTE The current version of GNU CVS, when using the pserver connection 
method, ignores the Log Message of the Add command. This is a known bug 
in GNU CVS. For more information, refer to the file BUGS in the CVS source 
distribution.

Figure 3.8  Add dialog box (for files)

Table 3.6  Add dialog box (for files)—options

Option Explanation

Log message Enter in this field a message to log with the file that 
you will add.

This option is equivalent to using the GNU CVS 
command-line switch -m Text, where Text is the log 
message to use for this operation.

Text Select this file type if you are adding a text file to the 
CVS repository.

Binary Select this file type if you are adding a binary file (non-
text file) to the CVS repository.

Selecting this option is equivalent to using the 
command-line switch -kb.



Using mwCVS
File Commands

40 Version Control Plug-in 1.3 for CVS

Remove
Select a file in the project window, then select VCS > Remove to open the Remove dialog 
box.

mwCVS implements the remove command differently from GNU CVS. The default 
mwCVS behavior for a remove command is to delete the local file from disk and 
immediately commit that removal to the CVS repository. This behavior allows the IDE to 
commit the file removal even though the file no longer exists on your computer.

Figure 3.9 shows the Remove dialog box for a file. Table 3.7 explains the dialog-box 
options.

After you click Remove, a progress indicator shows remove progress.

Figure 3.9  Remove dialog box (for files)

Table 3.7  Remove dialog box (for files)—options

Option Explanation

Remove local file Select to delete the local file as part of the mwCVS 
remove operation. Clear to preserve the local file.

Selecting this option is equivalent to using the GNU 
CVS command-line switch -f.

Commit removal immediately Select to have the IDE immediately commit the file 
removal as part of the remove operation. Clear to 
use a separate CVS application to commit the file 
removal.

If you do not select the Remove local file option, 
you must use a separate CVS application to commit 
the file removal.



Using mwCVS
File Commands

41Version Control Plug-in 1.3 for CVS 

Log
Select a file in the project window, then select VCS > Log to open the Log dialog box. 
Figure 3.10 shows the Log dialog box for a file. Table 3.8 explains the dialog-box options.

After you click Log, a progress indicator appears. After the IDE completes the log 
operation, an editor window appears. This window shows the log information for the 
selected file.

Figure 3.10  Log dialog box (for files)

Table 3.8  Log dialog box (for files)—options

Option Explanation

Default branch revisions Select to list default branch revisions in the log. Clear 
to list all branch revisions.

Selecting this option is equivalent to using the GNU 
CVS command-line switch -b.

Headers Select to list header information in the log. Clear to 
exclude header information from the log.

Selecting this option is equivalent to using the 
command-line switch -h.

RCS file names Select to list file names that comply with Revision 
Control System (RCS) naming conventions. Clear to 
exclude RCS file names from the log.

Selecting this option is equivalent to using the 
command-line switch -R.
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Do not list tags Select to exclude tag information from the log. Clear to 
include the tag information.

Selecting this option is equivalent to using the 
command-line switch -N.

Revisions Select to enter in the corresponding field the file 
revisions for which you want to retrieve log 
information. Clear to retrieve log information for all file 
revisions.

Selecting this option is equivalent to using the 
command-line switch
-r NumberOrTag:NumberOrTag, where 
NumberOrTag is the revision number or tag to use for 
this operation.

Date Select to enter in the corresponding field the dates of 
file revisions for which you want to retrieve log 
information. Clear to retrieve log information for all file-
revision dates.

Selecting this option is equivalent to using the 
command-line switch -d Date, where Date is the 
date to use for this operation.

User(s) Select to enter in the corresponding field the users for 
whose file revisions you want to retrieve log 
information. Clear to retrieve log information for all 
users who revised the file.

Selecting this option is equivalent to using the 
command-line switch -w LoginName1, 
LoginName2,..., where LoginName is the login name 
to use for this operation.

State(s) Select to enter in the corresponding field the state 
information of files for which you want to retrieve log 
information. Clear to retrieve log information for all file 
states.

Selecting this option is equivalent to using the 
command-line switch -s.

Table 3.8  Log dialog box (for files)—options (continued)

Option Explanation
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Login
Select VCS > Login to open the Login dialog box. Figure 3.11 shows the Login dialog 
box. Table 3.9 explains the dialog-box options.

NOTE The Macintosh-hosted version of mwCVS does not support the Login dialog 
box. Instead, use a command-line utility, such as the Terminal application, to 
log into a repository by using the CVS login command. After you log in to 
the repository, you can use the IDE to issue CVS commands.

Figure 3.11  Login dialog box

Table 3.9  Login dialog box—options

Option Explanation

CVSRoot Enter in this field the root of the remote CVS repository. Use 
the general construction

:protocol:Login@RepstryAddr:RepstryRoot

where

• protocol is the protocol you use to access the 
repository (such as local or pserver).

• Login@RepstryAddr is your login name (Login), 
followed by @, followed by the Internet Protocol (IP) 
or Domain Name System (DNS) address of the 
remote repository (RepstryAddr) 

• RepstryRoot is the path to the root level of the 
remote repository

The default entry that appears in this field corresponds to the 
last used CVSRoot entry.

Password Enter the password that you use to log into the CVS 
repository.
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After you click Login, a progress indicator shows login progress. After the IDE completes 
the login operation, the VCS Messages window appears. This window notifies you of the 
login status. The message (Logging into server), where server is the name or 
address of the server, confirms successful login to the CVS repository.

Project Commands
This section explains the mwCVS commands for projects. Most of the project commands 
appear identical to the file commands, but project commands apply to the current project 
while the file commands apply to a selected file or group of files. The Difference 
command does not apply to projects.

Update
Bring forward a project window, then select VCS > Project > Update to open the Update 
dialog box. Figure 3.12 shows the Update dialog box for a project. Table 3.10 on page 45 
explains the dialog-box options.

After you click Update, a progress indicator appears.

Figure 3.12  Update dialog box (for projects)

NOTE You can change the default settings for the Read-Only and Command Output 
options. Use the mwCVS panel in the VCS Settings window to configure the 
default settings. See “mwCVS Panel Options” on page 15 for more 
information.
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Table 3.10  Update dialog box (for projects)—options

Option Explanation

Overwrite locally modified file Select to replace a locally modified project with the 
version stored on the CVS repository. Clear to 
preserve the locally modified project.

Selecting this option is equivalent to using the GNU 
CVS command-line switch -C.

Reset sticky tags Select to remove any sticky tags associated with the 
current project after the IDE completes the update 
operation. Clear to preserve existing sticky tags.

Selecting this option is equivalent to using the 
command-line switch -A.

Retrieve before date Select to enter in the corresponding field the date 
before which you want to retrieve a version of the 
project in the CVS repository. Clear to disregard date 
information.

Enter the date according to GNU CVS conventions. 
Sample dates are:

• 1 month ago

• last Monday

• 3/31/02 10:00:04 PST

Selecting this option is equivalent to using the 
command-line switch -D Date, where Date is the 
date to use for this operation.

Retrieve revision Select to enter in the corresponding field the revision 
tag of the project that you want to retrieve from the 
CVS repository. Clear to disregard revision-tag 
information.

Selecting this option is equivalent to using the 
command-line switch -r NumberOrTag., where 
NumberOrTag is the revision number or tag to use for 
this operation.
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Merge 
From 
Branch

Revision Select to enter in the corresponding field the revision 
tag or branch name of the project that you want to 
retrieve from the CVS repository. The IDE retrieves 
this project and merges its contents with the contents 
of your local project. Clear to preserve the contents of 
the local project.

Selecting this option is equivalent to using the 
command-line switch -j NumberOrTag.

and this 
Revision

Select to enter in the corresponding field a revision tag 
or branch name that, together with the Revision entry, 
specifies a version range over which to merge project 
contents. Clear to preserve the contents of the local 
project.

mwCVS interprets the combination of Revision and 
this Revision differently from Revision alone. CVS 
merges into the local project any changes between the 
version specified by Revision and the version 
specified by and this Revision.

Selecting this option is equivalent to using the 
command-line switch
-j NumberOrTag -j NumberOrTag.

Read-Only Select to make the file read-only on the disk after 
issuing the Update command. Clear to make the file 
read/write.

This option supersedes the setting in the mwCVS 
panel of the VCS Settings window.

Selecting this option is equivalent to using the 
command-line switch -r. Clearing this option is 
equivalent to using the command-line switch -w.

Table 3.10  Update dialog box (for projects)—options (continued)

Option Explanation



Using mwCVS
Project Commands

47Version Control Plug-in 1.3 for CVS 

Do not change any files Select to see the result of the update operation without 
modifying the CVS repository. Clear to modify the CVS 
repository to reflect the update operation.

Selecting this option is equivalent to using the 
command-line switch -n.

Command Output Select the level of information that you want mwCVS 
to output during CVS operations:

• Default—output informational messages

• Quiet—output non-informational messages 
(-q)

• Very Quiet—output only messages for 
serious errors (-Q)

This option supersedes the setting in the mwCVS 
panel of the VCS Settings window.

Table 3.10  Update dialog box (for projects)—options (continued)

Option Explanation
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Commit
Bring forward a project window, then select VCS > Project > Commit to open the 
Commit dialog box. Figure 3.13 shows the Commit dialog box for a project. Table 3.11 on 
page 49 explains the dialog-box options.

After you click Commit, a progress indicator shows commit progress.

NOTE You can change the default settings for the Read-Only and Command Output 
options. Use the mwCVS panel in the VCS Settings window to configure the 
default settings. See “mwCVS Panel Options” on page 15 for more 
information.

Figure 3.13  Commit dialog box (for projects)
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Table 3.11  Commit dialog box (for projects)—options

Option Explanation

Log message Enter a message to log with the project that you will 
commit.

Entering a message in this field is equivalent to using the 
GNU CVS command-line switch -m Text, where Text is 
the log message to use for this operation.

Commit to revision Select to enter in the corresponding field a numeric or 
symbolic revision tag to which you want to commit the 
project. Clear to commit the project to the latest revision.

Selecting this option is equivalent to using the command-
line switch -rNumberOrTag, where NumberOrTag is the 
revision number or tag to use for this operation.

Read-Only Select to make the file read-only on the disk after issuing 
the Commit command. Clear to make the file read/write.

This option supersedes the setting in the mwCVS panel of 
the VCS Settings window.

Selecting this option is equivalent to using the command-
line switch -r. Clearing this option is equivalent to using 
the command-line switch -w.

Do not change any files Select to see the result of the commit operation without 
modifying the CVS repository. Clear to modify the CVS 
repository to reflect the commit operation.

Selecting this option is equivalent to using the command-
line switch -n.

Command Output Select the level of information that you want mwCVS to 
output during CVS operations:

• Default—output informational messages

• Quiet—output non-informational messages (-q)

• Very Quiet—output only messages for serious 
errors (-Q)

This option supersedes the setting in the mwCVS panel of 
the VCS Settings window.
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Status
Bring forward a project window, then select VCS > Project > Status to open the Status 
dialog box.

Select Include tag information to include information about tags applied to the project 
revisions in the report. Clear the option to exclude the tag information from the report. 
Selecting the option is equivalent to using the command-line switch -v.

Notice that the default mwCVS status behavior is to include tag information, which is 
equivalent to using the GNU CVS command line status -v.

After you click Status, a progress indicator appears. After the IDE completes the status 
operation, an editor window appears. This editor window shows the status information for 
the current project.

Figure 3.14  Status dialog box (for projects)
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Tag
Bring forward a project window, then select VCS > Project > Tag to open the Tag dialog 
box. Figure 3.15 shows the Tag dialog box for a file. Table 3.12 explains the dialog-box 
options.

After you click Tag, a progress indicator appears.

NOTE You can change the default settings for the Read-Only and Command Output 
options. Use the mwCVS panel in the VCS Settings window to configure the 
default settings. See “mwCVS Panel Options” on page 15 for more 
information.

Figure 3.15  Tag dialog box (for projects)

Table 3.12  Tag dialog box (for projects)—options

Option Explanation

Tag name Enter in this field the name of the tag.

Tag revision Select to enter in the corresponding field the project 
revision that you want to tag. Clear to apply the tag to 
the latest revision.

Selecting this option is equivalent to using the GNU CVS 
command-line switch -r NumberOrTag, where 
NumberOrTag is the revision number or tag to use for 
this operation.
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Tag as of date Select to enter in the corresponding field the date of the 
project revision that you want to tag. Clear to apply the 
tag to the latest revision date.

Selecting this option is equivalent to using the 
command-line switch -D Date, where Date is the date 
to use for this operation.

Create branch Select to use the tag to denote a branch of the project 
revision in the CVS repository. Clear to use the tag to 
denote a label for a particular project revision.

Selecting this option is equivalent to using the 
command-line switch -b.

If you select this option, you cannot select the Delete 
tag option.

Delete tag Select to permanently delete the specified tag from the 
CVS repository. Clear to add the tag to the specified 
project revision.

Selecting this option is equivalent to using the 
command-line switch -d.

If you select this option, you cannot select the Create 
branch or Move tag if it exists options.

Move tag if it exists Select to have the IDE relocate existing tags with the 
same name as the tag you specify. Clear to have the 
IDE display an error message if it encounters an existing 
tag with the same name as the tag you specify.

Selecting this option is equivalent to using the 
command-line switch -F.

If you select this option, you cannot select the Delete 
tag option.

Tag latest head revision if 
tag/date is not found

Select to have the IDE apply the tag to the latest project 
revision on the CVS repository if it does not encounter a 
revision with the specified tag or date. Clear to have 
CVS report an error if it fails to find a matching tag.

Selecting this option is equivalent to using the 
command-line switch -f.

Table 3.12  Tag dialog box (for projects)—options (continued)

Option Explanation
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Read-Only Select to make the file read-only on the disk after issuing 
the Tag command. Clear to make the file read/write.

This option supersedes the setting in the mwCVS panel 
of the VCS Settings window.

Selecting this option is equivalent to using the 
command-line switch -r.

Do not change any files Select to see the result of the tag operation without 
modifying the CVS repository. Clear to modify the CVS 
repository to reflect the tag operation.

Selecting this option is equivalent to using the 
command-line switch -n.

Command Output Select the level of information that you want mwCVS to 
output during CVS operations:

• Default—output informational messages

• Quiet—output non-informational messages (-
q)

• Very Quiet—output only messages for 
serious errors (-Q)

This option supersedes the setting in the mwCVS panel 
of the VCS Settings window.

Table 3.12  Tag dialog box (for projects)—options (continued)

Option Explanation
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Add
Bring forward the project window of a project that does not currently reside in the CVS 
repository, then select VCS > Project > Add to open the Add dialog box. Figure 3.16 
shows the Add dialog box for a project. Table 3.13 explains the dialog-box options.

After you click Add, a progress indicator appears.

NOTE The current version of GNU CVS, when using the pserver connection 
method, ignores the Log Message of the Add command. This is a known bug 
in GNU CVS. For more information, refer to the file BUGS in the CVS source 
distribution.

Figure 3.16  Add dialog box (for projects)

Table 3.13  Add dialog box (for projects)—options

Option Explanation

Log message Enter in this field a message to log with the project that 
you will add.

This option is equivalent to using the GNU CVS 
command-line switch -m Text, where Text is the log 
message to use for this operation.

Text Select this file type if you are adding a text-formatted 
project to the CVS repository.

Binary Select this file type if you are adding a binary (non-text)-
formatted project to the CVS repository.

Selecting this option is equivalent to using the 
command-line switch -kb.
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Remove
Bring forward a project window, then select VCS > Project > Remove to open the 
Remove dialog box.

mwCVS implements the remove command differently from GNU CVS. The default 
mwCVS behavior for a remove command is to delete the local project from disk and 
immediately commit that removal to the CVS repository. This behavior allows the IDE to 
commit the project removal even though the project no longer exists on your computer.

Figure 3.17 shows the Remove dialog box for a project. Table 3.14 explains the dialog-
box options.

After you click Remove, a progress indicator appears.

Figure 3.17  Remove dialog box (for projects)

Table 3.14  Remove dialog box (for projects)—options

Option Explanation

Remove local file Select to delete the local project as part of the mwCVS 
remove operation. Clear to preserve the local project.

Selecting this option is equivalent to using the GNU CVS 
command-line switch -f.

Commit removal 
immediately

Select to have the IDE display the Commit dialog box 
immediately after the tag command. Use this dialog box 
to specify commit parameters or cancel the commit 
operation. Clear to use a separate CVS application to 
commit the project removal.

If you select the Remove local file option, you should 
select this option if you want to continue working within 
the IDE. Selecting this option lets you avoid switching to 
a separate CVS application to commit the project 
removal.
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Log
Bring forward a project window, then select VCS > Project > Log to open the Log dialog 
box. Figure 3.18 shows the Log dialog box for a file. Table 3.15 explains the dialog-box 
options.

After you click Log, a progress indicator appears. After the IDE completes the log 
operation, an editor window appears. This window shows the log information for the 
current project.

Figure 3.18  Log dialog box (for projects)

Table 3.15  Log dialog box (for projects)—options

Option Explanation

Default branch revisions Select to list default branch revisions in the log. Clear to 
list all branch revisions.

Selecting this option is equivalent to using the GNU CVS 
command-line switch -b.

Headers Select to list header information in the log. Clear to 
exclude header information from the log.

Selecting this option is equivalent to using the command-
line switch -h.

RCS file names Select to list project names that comply with Revision 
Control System (RCS) naming conventions. Clear to 
exclude RCS names from the log.

Selecting this option is equivalent to using the command-
line switch -R.
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Do not list tags Select to exclude tag information from the log. Clear to 
include the tag information.

Selecting this option is equivalent to using the command-
line switch -N.

Revisions Select to enter in the corresponding field the project 
revisions for which you want to retrieve log information. 
Clear to retrieve log information for all project revisions.

Selecting this option is equivalent to using the command-
line switch -rNumberOrTag:NumberOrTag, where 
NumberOrTag is the revision number or tag to use for
this operation.

Date Select to enter in the corresponding field the dates of 
project revisions for which you want to retrieve log 
information. Clear to retrieve log information for all project-
revision dates.

Selecting this option is equivalent to using the command-
line switch -d Date, where Date is the date to use for
this operation.

User(s) Select to enter in the corresponding field the users for 
whose project revisions you want to retrieve log 
information. Clear to retrieve log information for all users 
who revised
the project.

Selecting this option is equivalent to using the command-
line switch -w LoginName1, LoginName2,..., where 
LoginName is the login name to use for this operation.

State(s) Select to enter in the corresponding field the state 
information of projects for which you want to retrieve log 
information. Clear to retrieve log information for all
project states.

Selecting this option is equivalent to using the command-
line switch -s.

Table 3.15  Log dialog box (for projects)—options (continued)

Option Explanation
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Recursive Commands
This section explains the recursive mwCVS commands. These commands let you specify 
a directory (folder) as the argument to the CVS command. After you choose one of these 
recursive commands, a directory-selection dialog box like the one shown in Figure 3.19 
appears. Use this dialog box to select the directory to which you want to issue the CVS 
command.

Click Cancel in the directory-selection dialog box or in subsequent dialog boxes to close 
the dialog box without making any modifications. Cancelling the operation in the 
directory-selection dialog box also cancels the CVS command.

Figure 3.19  Directory-selection dialog box
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Update
Select VCS > Recursive > Update and select a directory in the directory-selection dialog 
box to open the Update dialog box. Figure 3.20 shows the Update dialog box for a 
directory. Table 3.16 explains the dialog-box options.

After you click Update, a progress indicator appears.

NOTE You can change the default settings for the Read-Only and Command Output 
options. Use the mwCVS panel in the VCS Settings window to configure the 
default settings. See “mwCVS Panel Options” on page 15 for more 
information.

Figure 3.20  Update dialog box (recursive)
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Table 3.16  Update dialog box (recursive)—options

Option Explanation

Update folder This field holds the path to the directory that you 
selected in the directory-selection dialog box. Click 
Select to choose a different directory. Alternatively, 
enter a full path directly into the field.

Recursive Select to update both the directory itself and any 
directories nested within it. Clear to update only the 
directory itself.

Overwrite locally modified file Select to replace a locally modified file with the version 
stored on the CVS repository. Clear to preserve the 
locally modified file.

Selecting this option is equivalent to using the GNU 
CVS command-line switch -C.

Reset sticky tags Select to remove any sticky tags associated with the 
selected file after the IDE completes the update 
operation. Clear to preserve existing sticky tags.

Selecting this option is equivalent to using the 
command-line switch -A.

Retrieve before date Select to enter in the corresponding field the date 
before which you want to retrieve a version of the file 
in the CVS repository. Clear to disregard date 
information.

Enter the date according to GNU CVS conventions. 
Sample dates are:

• 1 month ago

• last Monday

• 3/31/02 10:00:04 PST

Selecting this option is equivalent to using the 
command-line switch -D Date, where Date is the date 
to use for this operation.

Retrieve revision Select to enter in the corresponding field the revision 
tag of the file that you want to retrieve from the CVS 
repository. Clear to disregard revision-tag information.

Selecting this option is equivalent to using the 
command-line switch -r NumberOrTag, where 
NumberOrTag is the revision number or tag to use for 
this operation.
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Merge 
From 
Branch

Revision Select to enter in the corresponding field the revision 
tag or branch name of the file that you want to retrieve 
from the CVS repository. The IDE retrieves this file 
and merges its contents with the contents of your local 
file. Clear to preserve the contents of the local file.

Selecting this option is equivalent to using the 
command-line switch -j NumberOrTag.

and this 
Revision

Select to enter in the corresponding field a revision tag 
or branch name that, together with the Revision entry, 
specifies a version range over which to merge file 
contents. Clear to preserve the contents of the local 
file.

The IDE interprets the combination of Revision and 
this Revision differently from Revision alone. CVS 
merges into the local file any changes between the 
version specified by Revision and the version 
specified by and this Revision.

Selecting this option is equivalent to using the 

command-line switch -j NumberOrTag
-j NumberOrTag.

Read-Only Select to make the file read-only on the disk after 
issuing the Update command. Clear to make the file 
read/write.

This option supersedes the setting in the mwCVS 
panel of the VCS Settings window.

Selecting this option is equivalent to using the 
command-line switch -r. Clearing this option is 
equivalent to using the command-line switch -w.

Table 3.16  Update dialog box (recursive)—options (continued)

Option Explanation
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Do not change any files Select to see the result of the update operation without 
modifying the CVS repository. Clear to modify the CVS 
repository to reflect the update operation.

This option supersedes the setting in the mwCVS 
panel of the VCS Settings window.

Selecting this option is equivalent to using the 
command-line switch -n.

Command Output Select the level of information that you want mwCVS 
to output during CVS operations:

• Default—output informational messages

• Quiet—output non-informational messages 
(-q)

• Very Quiet—output only messages for 
serious errors (-Q)

This option supersedes the setting in the mwCVS 
panel of the VCS Settings window.

Table 3.16  Update dialog box (recursive)—options (continued)

Option Explanation
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Commit
Select VCS > Recursive > Commit and select a directory in the directory-selection dialog 
box to open the Commit dialog box. Figure 3.21 shows the Commit dialog box for a 
directory. Table 3.17 explains the dialog-box options.

After you click Commit, a progress indicator appears.

NOTE You can change the default settings for the Read-Only and Command Output 
options. Use the mwCVS panel in the VCS Settings window to configure the 
default settings. See “mwCVS Panel Options” on page 15 for more 
information.

Figure 3.21  Commit dialog box (recursive)
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Table 3.17  Commit dialog box (recursive)—options

Option Explanation

Commit folder This field holds the path to the directory that you selected 
in the directory-selection dialog box. Click Select to 
choose a different directory. Alternatively, enter a full path 
directly into the field.

Log message Enter in this field a message to log with the file that you
will commit.

Entering a message in this field is equivalent to using the 
GNU CVS command-line switch -m Text, where Text is 
the log message to use for this operation.

Recursive Select to commit both the directory itself and any 
directories nested within it. Clear to commit only the 
directory itself.

Commit to revision Select to enter in the corresponding field a numeric or 
symbolic revision tag to which you want to commit the file. 
Clear to commit the file to the latest revision.

Selecting this option is equivalent to using the command-
line switch -r NumberOrTag, where NumberOrTag is the 
revision number or tag to use for this operation.

Read-Only Select to make the file read-only on the disk after issuing 
the Commit command. Clear to make the file read/write.

This option supersedes the setting in the mwCVS panel of 
the VCS Settings window.

Selecting this option is equivalent to using the command-
line switch -r. Clearing this option is equivalent to using 
the command-line switch -w.
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Do not change any files Select to see the result of the commit operation without 
modifying the CVS repository. Clear to modify the CVS 
repository to reflect the commit operation.

This option supersedes the setting in the mwCVS panel of 
the VCS Settings window.

Selecting this option is equivalent to using the command-
line switch -n.

Command Output Select the level of information that you want mwCVS to 
output during CVS operations:

• Default—output informational messages

• Quiet—output non-informational messages (-q)

• Very Quiet—output only messages for serious 
errors (-Q)

This option supersedes the setting in the mwCVS panel of 
the VCS Settings window.

Table 3.17  Commit dialog box (recursive)—options (continued)

Option Explanation
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Checkout
Select VCS > Recursive > Checkout and select a directory in the directory-selection 
dialog box to open the Checkout dialog box. Figure 3.22 shows the Checkout dialog box 
for a directory. Table 3.18 explains the dialog-box options.

After you click Checkout, a progress indicator appears. After the progress indicator 
closes, the mwCVS Results window appears.

NOTE You can change the default settings for the Read-Only and Command 
5Output options. Use the mwCVS panel in the VCS Settings window to 
configure the default settings. See “mwCVS Panel Options” on page 15 for 
more information.

Figure 3.22  Checkout dialog box

Table 3.18  Checkout dialog box—options

Option Explanation

Checkout to This field holds the path to the directory that you 
selected in the directory-selection dialog box. Click 
Select to choose a different directory. Alternatively, 
enter a full path directly into the field.

Module Enter in this field the path to the module that you want to 
check out from the CVS repository.



Using mwCVS
Recursive Commands

67Version Control Plug-in 1.3 for CVS 

CVSRoot Enter in this field the root of the CVS repository. Use the 
general construction

:protocol:Login@RepstryAddr:RepstryRoot

where

• protocol is the protocol you use to access the 
repository (such as local or pserver).

• Login@RepstryAddr is your login name 
(Login), followed by @, followed by the Internet 
Protocol (IP) or Domain Name System (DNS) 
address of the remote repository 
(RepstryAddr) 

• RepstryRoot is the path to the root level of the 
remote repository

The default entry that appears in this field corresponds 
to the last used CVSRoot entry.

Use date Select to check out files with a sticky date. Clear to 
disregard date when checking out files.

Selecting this option is equivalent to using the GNU CVS 
command-line switch -D Date, where Date is the date 
to use for this operation.

Use revision Select to check out files with a sticky revision tag. Clear 
to disregard revision tag when checking out files.

Selecting this option is equivalent to using the 
command-line switch -r NumberOrTag, where 
NumberOrTag is the revision number or tag to use for 
this operation.

Recursive Select to check out both the directory itself and any 
directories nested within it. Clear to check out only the 
directory itself.

Clearing this option is equivalent to using the command-
line switch -l.

Prune empty directories Select to avoid checking out empty directories from the 
CVS repository. Clear to check out all directories, 
regardless of empty state.

Selecting this option is equivalent to using the 
command-line switch -P.

Table 3.18  Checkout dialog box—options (continued)

Option Explanation
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Reset sticky tags Select to remove any sticky tags associated with the 
selected file after the IDE completes the checkout 
operation. Clear to preserve existing sticky tags.

Selecting this option is equivalent to using the 
command-line switch -A.

Don’t run module program Select to see the result of the commit operation without 
modifying the CVS repository. Clear to modify the CVS 
repository to reflect the commit operation.

Selecting this option is equivalent to using the 
command-line switch -n.

Force head revision if date/
tag not found

Select to have the IDE force a head revision on files 
checked out from the CVS repository if it does not 
encounter a revision with the specified tag or date. Clear 
to have the IDE cancel the checkout operation if it does 
not encounter a revision with the specified tag or date.

Selecting this option is equivalent to using the 
command-line switch -f.

Read-Only Select to make the file read-only on the disk after issuing 
the Checkout command. Clear to make the file read/
write.

This option supersedes the setting in the mwCVS panel 
of the VCS Settings window.

Selecting this option is equivalent to using the 
command-line switch -r. Clearing this option is 
equivalent to using the command-line switch -w.

Table 3.18  Checkout dialog box—options (continued)

Option Explanation
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Do not change any files Select to see the result of the commit operation without 
modifying the CVS repository. Clear to modify the CVS 
repository to reflect the commit operation.

Selecting this option is equivalent to using the 
command-line switch -n.

Command 5Output Select the level of information that you want mwCVS to 
output during CVS operations:

• Default—output informational messages

• Quiet—output non-informational messages (-
q)

• Very Quiet—output only messages for 
serious errors (-Q)

This option supersedes the setting in the mwCVS panel 
of the VCS Settings window.

Table 3.18  Checkout dialog box—options (continued)

Option Explanation
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Status
Select VCS > Recursive > Status and select a directory in the directory-selection dialog 
box to open the Status dialog box. Figure 3.23 shows the Status dialog box for a directory. 
Table 3.19 explains the dialog-box options.

After you click Status, a progress indicator appears.

Figure 3.23  Status dialog box (recursive)

Table 3.19  Status dialog box (recursive)—options

Option Explanation

Status folder This field holds the path to the directory that you 
selected in the directory-selection dialog box. Click 
Select to choose a different directory. Alternatively, 
enter a full path directly into the field.

Include tag information Select to include in the status report information about 
tags applied to the file revisions. Clear to exclude the 
tag information from the status report.

Selecting this option is equivalent to using the GNU 
CVS command-line switch -v.

Recursive Selecting this option is equivalent to using the 
command-line switch -r. Clearing this option is 
equivalent to using the command-line switch -l.
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Tag
Select VCS > Recursive > Tag and select a directory in the directory-selection dialog box 
to open the Tag dialog box. Figure 3.24 shows the Tag dialog box for a directory. Table 
3.20 explains the dialog-box options.

After you click Tag, a progress indicator appears.

NOTE You can change the default settings for the Read-Only and Command Output 
options. Use the mwCVS panel in the VCS Settings window to configure the 
default settings. See “mwCVS Panel Options” on page 15 for more 
information.

Figure 3.24  Tag dialog box (recursive)

Table 3.20  Tag dialog box (recursive)—options

Option Explanation

Tag folder This field holds the path to the directory that you selected 
in the directory-selection dialog box. Click Select to 
choose a different directory. Alternatively, enter a full path 
directly into the field.

Tag name Enter in this field the name of the tag.
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Tag revision Select to enter in the corresponding field the file revision 
that you want to tag. Clear to apply the tag to the latest 
revision.

Selecting this option is equivalent to using the GNU CVS 
command-line switch -r NumberOrTag, where 
NumberOrTag is the revision number or tag to use for
this operation.

Tag as of date Select to enter in the corresponding field the date of the 
file revision that you want to tag. Clear to apply the tag to 
the latest revision date.

Selecting this option is equivalent to using the command-
line switch -D Date, where Date is the date to use for
this operation.

Create branch Select to use the tag to denote a branch of the file revision 
in the CVS repository. Clear to use the tag to denote a 
label for a particular file revision.

Selecting this option is equivalent to using the command-
line switch -b.

If you select this option, you cannot select the Delete tag 
option.

Delete tag Select to permanently delete the specified tag from the 
CVS repository. Clear to add the tag to the specified file 
revision.

Selecting this option is equivalent to using the command-
line switch -d.

If you select this option, you cannot select the Create 
branch or Move tag if it exists options.

Move tag if it exists Select to have the IDE relocate existing tags with the same 
name as the tag you specify. Clear to have the IDE display 
an error message if it encounters an existing tag with the 
same name as the tag you specify.

Selecting this option is equivalent to using the command-
line switch -F.

If you select this option, you cannot select the Delete tag 
option.

Table 3.20  Tag dialog box (recursive)—options (continued)

Option Explanation
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Recursive Select to apply the tag to both the directory itself and any 
directories nested within it. Clear to apply the tag to only 
the directory itself.

Tag latest head revision if 
tag/date is not found

Select to have the IDE apply the tag to the latest file 
revision on the CVS repository if it does not encounter a 
revision with the specified tag or date. Clear to have CVS 
report an error if it fails to find a matching tag.

Selecting this option is equivalent to using the command-
line switch -f.

Read-Only Select to make the file read-only on the disk after issuing 
the Tag command. Clear to make the file read/write.

This option supersedes the setting in the mwCVS panel of 
the VCS Settings window.

Selecting this option is equivalent to using the command-
line switch -r.

Do not change any files Select to see the result of the tag operation without 
modifying the CVS repository. Clear to modify the CVS 
repository to reflect the tag operation.

Selecting this option is equivalent to using the command-
line switch -n.

Command Output Select the level of information that you want mwCVS to 
output during CVS operations:

• Default—output informational messages

• Quiet—output non-informational messages (-q)

• Very Quiet—output only messages for serious 
errors (-Q)

This option supersedes the setting in the mwCVS panel of 
the VCS Settings window.

Table 3.20  Tag dialog box (recursive)—options (continued)

Option Explanation
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Log
Select VCS > Recursive > Log and select a directory in the directory-selection dialog box 
to open the Log dialog box. Figure 3.25 shows the Log dialog box for a directory. Table 
3.21 explains the dialog-box options.

After you click Log, a progress indicator appears. After the IDE completes the log 
operation, an editor window appears. This window shows the log information for the 
selected file.

Figure 3.25  Log dialog box (recursive)

Table 3.21  Log dialog box (recursive)—options

Option Explanation

Log folder This field holds the path to the directory that you 
selected in the directory-selection dialog box. Click 
Select to choose a different directory. Alternatively, 
enter a full path directly into the field.

Default branch revisions Select to list default branch revisions in the log. Clear to 
list all branch revisions.

Selecting this option is equivalent to using the GNU CVS 
command-line switch -b.

Headers Select to list header information in the log. Clear to 
exclude header information from the log.

Selecting this option is equivalent to using the 
command-line switch -h.
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RCS file names Select to list file names that comply with Revision 
Control System (RCS) naming conventions. Clear to 
exclude RCS file names from the log.

Selecting this option is equivalent to using the 
command-line switch -R.

Recursive Select to retrieve log information for both the directory 
itself and any directories nested within it. Clear to 
retrieve log information for only the directory itself.

Clearing this box is equivalent to using the command-
line switch -l.

Do not list tags Select to exclude tag information from the log. Clear to 
include the tag information.

Selecting this option is equivalent to using the 
command-line switch -N.

Revisions Select to enter in the corresponding field the file 
revisions for which you want to retrieve log information. 
Clear to retrieve log information for all file revisions.

Selecting this option is equivalent to using the 
command-line switch -
r NumberOrTag:NumberOrTag, where NumberOrTag 
is the revision number or tag to use for this operation.

Date Select to enter in the corresponding field the dates of file 
revisions for which you want to retrieve log information. 
Clear to retrieve log information for all file-revision dates.

Selecting this option is equivalent to using the 
command-line switch -d Date, where Date is the date 
to use for this operation.

Table 3.21  Log dialog box (recursive)—options (continued)

Option Explanation
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User(s) Select to enter in the corresponding field the users for 
whose file revisions you want to retrieve log information. 
Clear to retrieve log information for all users who revised 
the file.

Selecting this option is equivalent to using the 
command-line switch -w LoginName1, LoginName2,..., 
where LoginName is the login name to use for
this operation.

State(s) Select to enter in the corresponding field the state 
information of files for which you want to retrieve log 
information. Clear to retrieve log information for all
file states.

Selecting this option is equivalent to using the 
command-line switch -s.

Table 3.21  Log dialog box (recursive)—options (continued)

Option Explanation
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4
mwCVS Tutorial

The tutorial in this chapter is a general example of using mwCVS with the CodeWarrior™ 
IDE to interact with a CVS repository. 

The goal of this tutorial is to help you become familiar with basic use of mwCVS. After 
completing the tutorial, you will understand how to use mwCVS to

• check out a module from a CVS repository

• modify a source-code file, and

• commit your source-code changes to the CVS repository.

Because there are many ways to set up and use a CVS repository, this tutorial uses a trivial 
example to help clarify your understanding of mwCVS.

Assume these facts:

• You are familiar with basic CVS use, but you want to better understand how to use 
mwCVS.

• You created a CVS repository on a UNIX system.

• You previously initialized the repository, configured a pserver, and imported 
source-code files into the repository.

• The root level of the CVS repository is /VersionControl/Repository.

• The Repository subdirectory has a module called cvstest.

• The cvstest module has a CodeWarrior project called cvs_test.mcp and the 
associated files for that project.

• All files in the cvs_test.mcp project are under version control.

This chapter has these topics:

• “Part One: Turning on mwCVS” on page 78

• “Part Two: Accessing the Repository” on page 78

• “Part Three: Checking out a Module” on page 81

• “Part Four: Modifying a File” on page 84

• “Part Five: Committing the Modified File” on page 87
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Part One: Turning on mwCVS
This part explains how to turn on mwCVS so that you can use the IDE to issue CVS 
commands.

1. Launch the CodeWarrior IDE.

2. Select Edit > Version Control Settings.

The VCS Settings window appears.

3. Select VCS Setup in the VCS Settings Panels list.

The VCS Setup panel appears.

4. Select the Use Version Control option.

5. Select mwCVS from the Method list box.

The mwCVS item appears in the VCS Settings Panels list.

6. Click Apply or Save to confirm your changes.

7. Close the VCS Settings window.

Enabling mwCVS causes the VCS menu to appear in the menu bar. You use this menu to 
issue CVS commands from the CodeWarrior IDE.

This icon represents the VCS menu on the Macintosh-hosted IDE.

Part Two: Accessing the Repository
This part explains how to use mwCVS to log in, such as through a password server 
(pserver), to access the contents of a CVS repository.

Windows
Follow the instructions in this section if you use mwCVS with the Windows-hosted IDE. 
See “Macintosh” on page 80 if you use mwCVS with the Macintosh-hosted IDE.

1. Select VCS > Login.

The Login window appears. Use this window, shown in Figure 4.1 on page 79, to enter 
CVS root information and your password to access the repository.
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Figure 4.1  Login window

2. Enter in the CVSRoot field the path to the repository root.

mwCVS requires specific syntax for the contents of this field. The general form is

:protocol:Login@RepositoryAddress:RepositoryRoot

where protocol is the protocol you use to access the repository, Login is your 
login name for the repository, RepositoryAddress is the Internet Protocol 
(IP) or Domain Name System (DNS) address of the repository, and 
RepositoryRoot is the path to the root level of the repository.

For example, in this tutorial you use a password server to access the repository on a 
UNIX host, so you would enter the information shown in Figure 4.1 into the CVSRoot 
field.

3. Enter in the Password field the password associated with the login name that you 
specified in the CVSRoot field.

This password is the password that Login uses to access the repository.

4. Click Login.

The Login window closes and a progress indicator appears. mwCVS logs in to the 
repository with your account information. The progress indicator closes after the login 
operation completes.

5. View login information in the VCS Messages window that appears.

This window shows whether mwCVS successfully logged you into the repository. 
Figure 4.2 shows the successful login to the repository.

Figure 4.2  VCS Messages window - login



mwCVS Tutorial
Part Two: Accessing the Repository

80 Version Control Plug-in 1.3 for CVS

Macintosh
Follow the instructions in this section if you use mwCVS with the Macintosh-hosted IDE. 
See “Windows” on page 78 if you use mwCVS with the Windows-hosted IDE.

1. Launch a command-line utility.

For example, launch the Terminal application in Mac OS X. (Figure 4.3 shows 
Terminal after you use it to successfully log in to a CVS repository.)

2. At the prompt, enter the command line

cvs -d :protocol:Login@RepositoryAddr:RepositoryRoot login

where protocol is the protocol you use to access the repository, Login is your 
login name for the repository, RepositoryAddr is the Internet Protocol (IP) or 
Domain Name System (DNS) address of the repository, and RepositoryRoot 
is the path to the root level of the repository.

For example, in this tutorial you use a password server to access the repository on a 
UNIX host, so you would enter the command line shown in Figure 4.3.

Figure 4.3  Using the Terminal application to log in to a CVS repository

3. Press Return to execute the command line.

CVS prompts you to enter your password.

4. Enter the password associated with the Login that you specified in the first 
command line.

This password is the password that Login uses to access the repository.
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5. Press Return to execute the command line.

After you successfully log in to the repository, a new prompt appears in the command-
line utility (as shown in Figure 4.3 on page 80). Otherwise, error messages appear in 
the command-line utility.

6. After you log in to the repository, return to the CodeWarrior IDE.

You can now use mwCVS to interact with the repository.

Part Three: Checking out a Module
This part explains how to check out a module from the CVS repository. In this tutorial, 
you check out a sample module named cvstest into a working directory named 
cvswork.

1. Select VCS > Recursive > Checkout.

A directory-selection dialog box like the one shown in Figure 4.4 on page 82 appears.

2. Use the directory-selection dialog box to select a working directory.

Figure 4.4 on page 82 shows cvswork as the selected directory. This directory 
becomes the working directory for the checkout command.
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Figure 4.4  Directory-selection dialog box

3. Enter repository and module information in the Checkout window that appears.

Use the Checkout window, shown in Figure 4.5 on page 83, to enter information about 
the repository and the modules that you want to check out. Figure 4.5 on page 83 also 
shows that mwCVS automatically placed the path to the working directory 
(cvswork) in the Checkout to field.
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Figure 4.5  Checkout window

4. Enter in the Module field the module that you want to check out.

In this tutorial, the module is cvstest.

5. Enter in the CVSRoot field the CVSROOT setting.

mwCVS requires specific syntax for the contents of this field. The general form is

:protocol:Login@RepositoryAddress:RepositoryRoot

where protocol is the protocol you use to access the repository, Login is your 
login name for the repository, RepositoryAddress is the Internet Protocol 
(IP) or Domain Name System (DNS) address of the repository, and 
RepositoryRoot is the path to the root level of the repository.

For example, in this tutorial you use a password server to access the repository on a 
UNIX host, so you would enter the information shown in Figure 4.5 into the CVSRoot 
field.

6. Click Checkout.

The Checkout window closes and a progress indicator appears. mwCVS places a copy 
of the module in your working directory. The progress indicator closes after this 
operation completes.

7. View checkout information in the mwCVS Results window that appears.

This window shows the result of the checkout operation. In this tutorial, Figure 4.6 on 
page 84 shows that mwCVS successfully checked out a collection of files for the 
cvstest module.
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Figure 4.6  mwCVS Results window - checkout

8. mwCVS checks out the module to the working directory.

In this tutorial, the checkout operation created a new folder, cvstest, inside the 
cvswork folder. The cvstest folder has the files checked out from the 
repository.

Part Four: Modifying a File
This part explains how to modify a file in a module checked out from the CVS repository. 
In this tutorial, you modify a file named Beta.h that you checked out from a module 
named cvstest. The Beta.h file is part of a CodeWarrior project named 
cvs_test.mcp.

1. Open the project in the checked-out module.

Select File > Open to display an Open dialog box. Use this dialog box to open the 
project. In this tutorial, navigate to the cvstest folder and open the 
cvs_test.mcp project inside the folder, as shown in Figure 4.7 on page 85.
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Figure 4.7  Opening the project in the checked-out module

2. View the project and its files in the project window that appears.

Figure 4.8 on page 86 shows the project window for cvs_test.mcp. Notice the 
VCS status icon  that appears next to the header file Beta.h in the Source group of 
the project window.

NOTE Table 3.1 on page 22 explains the VCS status icons.
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Figure 4.8  Project window

3. Open the file that you want to modify.

In this tutorial, open the file named Beta.h that appears in the Source group of the 
project window. This header file appears in an editor window, shown in Figure 4.9 on 
page 87.
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Figure 4.9  Header file

4. Modify the file.

5. Save your changes.

6. Close the editor window.

In the project window, notice that the VCS status icon next to Beta.h changes to , 
indicating that your local copy of that file differs from the version stored in the 
repository.

NOTE Table 3.1 on page 22 explains the VCS status icons.

Part Five: Committing the Modified File
This part explains how to commit the changes that you made to a file. In this tutorial, you 
commit the Beta.h file that you modified earlier.

1. Bring forward the project window that has the edited file.

In this tutorial, bring forward the cvs_test.mcp project window.

2. Select the edited file in the project window.

In this tutorial, select the Beta.h header file.
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3. Select VCS > Commit.

Enter a log message in the Commit window that appears, as shown in Figure 4.10.

Figure 4.10  Commit window

4. Click Commit.

The Commit window closes and a progress indicator appears. The progress indicator 
closes after the commit operation completes.

5. View commit information in another mwCVS Results window that appears.

This window shows the result of the commit operation. In this tutorial, Figure 4.11 
shows that mwCVS successfully committed the Beta.h file.

Figure 4.11  mwCVS Results window - commit
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Congratulations! You successfully completed these tasks with mwCVS, the IDE, and a 
CVS repository:

• turned on mwCVS

• accessed the repository

• checked out a module from the repository

• modified a file in the checked-out module

• committed the file modifications to the repository
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