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Chapter 1
Library

1.1 Introduction

1.1.1 Overview

This user's guide describes the General Digital Filters Library (GDFLIB) for the family of ARM Cortex M33F core-based
microcontrollers. This library contains optimized functions.

1.1.2 Data types

GDFLIB supports several data types: (un)signed integer, fractional , and accumulator, and floating point. The integer data types
are useful for general-purpose computation; they are familiar to the MPU and MCU programmers. The fractional data types enable
powerful numeric and digital-signal-processing algorithms to be implemented. The accumulator data type is a combination of
both; that means it has the integer and fractional portions. The floating-point data types are capable of storing real numbers in
wide dynamic ranges. The type is represented by binary digits and an exponent. The exponent allows scaling the numbers from
extremely small to extremely big numbers. Because the exponent takes part of the type, the overall resolution of the number is
reduced when compared to the fixed-point type of the same size.

The following list shows the integer types defined in the libraries:

* Unsigned 16-bit integer—<0 ; 65535> with the minimum resolution of 1

» Signed 16-bit integer—<-32768 ; 32767> with the minimum resolution of 1

* Unsigned 32-bit integer—<0 ; 4294967295> with the minimum resolution of 1

» Signed 32-bit integer—<-2147483648 ; 2147483647> with the minimum resolution of 1
The following list shows the fractional types defined in the libraries:

+ Fixed-point 16-bit fractional—<-1 ; 1 - 2-15> with the minimum resolution of 2-15

+ Fixed-point 32-bit fractional—<-1 : 1 - 231> with the minimum resolution of 2-31
The following list shows the accumulator types defined in the libraries:

+ Fixed-point 16-bit accumulator—<-256.0 ; 256.0 - 27> with the minimum resolution of 2-7

« Fixed-point 32-bit accumulator—<-65536.0 ; 65536.0 - 2-15> with the minimum resolution of 2-15
The following list shows the floating-point types defined in the libraries:

+ Floating point 32-bit single precision—<-3.40282 - 1038 ; 3.40282 - 103> with the minimum resolution of 2-23

1.1.3 API definition

GDFLIB uses the types mentioned in the previous section. To enable simple usage of the algorithms, their names use set prefixes
and postfixes to distinguish the functions' versions. See the following example:

f32Result = MLIB Mac F321ss(f32Accum, flé6Multl, fl6Mult2);

where the function is compiled from four parts:
* MLIB—this is the library prefix

* Mac—the function name—Multiply-Accumulate

* F32—the function output type
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» Iss—the types of the function inputs; if all the inputs have the same type as the output, the inputs are
not marked

The input and output types are described in the following table:

Table 1. Input/output types

Type Output Input
frac16_t F16 s
frac32_t F32 |
acc32_t A32 a

float_t FLT f

1.1.4 Supported compilers

GDFLIB for the ARM Cortex M33F core is written in C language or assembly language with C-callable interface depending on the
specific function. The library is built and tested using the following compilers:

* MCUXpresso IDE
* IAR Embedded Workbench
» Keil yVision
For the MCUXpresso IDE, the library is delivered in the gdfiib.afile.
For the Kinetis Design Studio, the library is delivered in the gdfiib.a file.
For the IAR Embedded Workbench, the library is delivered in the gdfiib.afile.
For the Keil pVision, the library is delivered in the gdfiib./ib file.

The interfaces to the algorithms included in this library are combined into a single public interface include file, gdflib.A. This is done
to lower the number of files required to be included in your application.

1.1.5 Library configuration

GDFLIB for the ARM Cortex M33F core is written in C language or assembly language with C-callable interface depending on the
specific function. Some functions from this library are inline type, which are compiled together with project using this library. The
optimization level for inline function is usually defined by the specific compiler setting. It can cause an issue especially when high
optimization level is set. Therefore the optimization level for all inline assembly written functions is defined by compiler pragmas
using macros. The configuration header file RTCESL_cfg.his located in: specific library folderlMLIBlInclude. The optimization
level can be changed by modifying the macro value for specific compiler. In case of any change the library functionality is

not guaranteed.

Similarly as optimization level the PowerQuad DSP Coprocessor and Accelerator support can be disable or enable if it has
not been done by defined symbol RTCESL_PQ_ON or RTCESL_PQ_OFF in project setting described in the PowerQuad DSP
Coprocessor and Accelerator support cheaper for specific compiler.

1.1.6 Special issues

1. The equations describing the algorithms are symbolic. If there is positive 1, the number is the closest number to 1 that
the resolution of the used fractional type allows. If there are maximum or minimum values mentioned, check the range
allowed by the type of the particular function version.

2. The library functions that round the result (the API contains Rnd) round to nearest (half up).
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3. This RTCESL requires the DSP extension for some saturation functions. If the core does not support the DSP extension
feature the assembler code of the RTCESL will not be buildable. For example the core1 of the LPC55s69 has no DSP

extension.

1.2 Library integration into project (MCUXpresso IDE)

This section provides a step-by-step guide on how to quickly and easily include GDFLIB into any MCUXpresso SDK example or
new SDK project using MCUXpresso IDE. The SDK based project uses RTCESL from SDK package.

PowerQuad DSP Coprocessor and Accelerator support

Some LPC platforms (LPC55S6x) contain a hardware accelerator dedicated to common calculations in DSP applications. This
section shows how to turn the PowerQuad (PQ) support for a function on and off.

1.

4.
5.

In the MCUXpresso SDK project name node or in the left-hand part, click Properties or select Project > Properties from the

menu. A project propert

ies dialog appears.

Expand the C/C++ Build node and select Settings. See Figure 1.

On the right-hand side, under the MCU C Compiler node, click the Preprocessor node. See Figure 1.

Run/Debug Settings (& Optimization
(% Debugging
(2 Wamings
(5 Miscellaneous
(2 Architecture
4 I MCU Assembler
(& General
(5 Architecture & Headers
4 B MCU Linker
(& General
(& Libraries
( Miscellaneous
(% Shared Library Settings
(2 Architecture
(2 Managed Linker Script
(& Multicore

- N
[ Properties for twrkv31f120m_demo_apps_hello_world (o o ]
type filter text Settings = - -

, Resource
Builders o
4 C/Cos Build Configuration: Debug [ Active ] ~| [Manage Configurations..
Build Variables
Environment
Logging & Tool Settings | & Build steps | " Build Artifact | [ Binary Parsers [ @ Error Parsers|
MCU settings
Settings 4 T MCU C Compiler [] Do not search system directories (-nostdine)
Toal Chain Editor (3 Dialect [T Preprocess only (-E}
» C/C++ General (B Preprocessor _
Defined symbols (-0} & a8 & E
Praject References 5 Includes ' 24888 H) |-

DEBUG
PRINTF_FLOAT_ENABLE=0
SCANF_FLOAT_ENABLE=0
PRINTF_ADVANCED_ENABLE=0
SCANF_ADVANCED_ENABLE=0
TWR_KV31F120M

TOWER
SDK_DEBUGCONSOLE=0

_ MCUXPRESSO

__USE_CMSIS
CPU_MKV3IFS12VLL12
CPU_MKV31FSL2VLL12_emd
_REDLIB_

Undefined symbals (-U) &

——

. b

Figure 1. Defined symbols

In the dialog that appears (see Figure 2), type the following:

* RTCESL_PQ_ON—to turn the PowerQuad support on

* RTCESL_PQ_OFF—to turn the PowerQuad support off

GDFLIB User's Guide, Rev. 5, 01 November 2021

In the right-hand part of the dialog, click the Add... icon located next to the Defined symbols (-D) title.

If neither of these two defines is defined, the hardware division and square root support is turned off by default.
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Defined symbols (-D)

RTCESL PQ_ON

[ ok ][ Cconcel ]

Figure 2. Symbol definition

6. Click OK in the dialog.
7. Click OK in the main dialog.

Ensure the PowerQuad moduel to be clocked by calling function RTCESL_PQ_Init(); prior to the first function using PQ
module calling.

See the device reference manual to verify whether the device contains the PowerQuad DSP Coprocessor and
Accelerator support.

Adding RTCESL component to project

The MCUXpresso SDK package is necessary to add any example or new project and RTCESL component. In case the

package has not been downloaded go to mcuxpresso.nxp.com, build the final MCUXpresso SDK package for required board and
download it.

After package is dowloaded, open the MCUXpresso IDE and drag&drop the SDK package in zip format to the Installed SDK

window of the MCUXpresso IDE. After SDK package is dropped the mesage accepting window appears as can be show in
following figure.

B MCUX workspace - MCUXpresso IDE - o x
File Edit MNavigate Search Project Configlools Run RIOS Analysis Window Help
i 2 | &~ &~ L2 TR R R AT RS = N T O I Y
U NP A FRURE R AT REERORAN . | Q im|lK
[ Project Ex... 51 4 Registers %% Fauls &, Periphera.. = O =g

BlEvY 8% B3

There are no projects in your warkspace.

To add a project:

B8 Creote o new MCUXpresso IDE C/C++ project.

B8 Import examples from SDK. X MCUXpresso IDE SDK import u} X

% Create 3 project...

i Import projects.. Py

@) Areyou sureyou want to import the following SDK in the
&Y' commen ‘meuxpresso’ folder?

D:ASDK_2_10_0_HVP-KV31F120Mzzip
@ inst.. 2 [ Prop.. [2 Py ]
(=]
@ Installed SDKs
() Quickstart Panel 52 (x)=Variables ®g Breakpoints = O Teinstallan SDK, simply drag and lpres:
X A [Installed SDKs . Availeble Board
MCUXpresso IDE - Quickstart Panel N
1 ] No project selected ame
~ Create or import a project
J— B New project...
B import SDK excemelets).. []Do not sk for confirmation on SDK Drag and Drop install
® Import project(s) from file system...
B’
v LR 4 >
o { ) MCUX workspace L

Figure 3. MCUXpresso IDE - imporing the SDK package to MCUXpresso IDE
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Click OK to confirm the SDK package import. Find the Quickstart panel in left bottom part of the MCUXpresso IDE and click New
project... item or Import SDK example(s)... to add rtcesl component to the project.

Library

8 MCUX workspace - MCU¥presso IDE

File Edit Mavigate Search Project ConfigTools Run

RTOS Analysis Window Help
|®- %~

H[mif &2 e RO Ui
S@e i iB-Flro eI

[ Project Ex.. 5 4! Registers 45 Faults &, Periphera.. = O
28lv|i#% B8

There are no projects in your workspace.

To add a project:
B8 Create a new MCUXpresso IDE C/C++ project.
B Import examples from SDK.
9 Create a project..

i Import projects...

@ inst. 52 [OProp.. [2 Probl.. B Cons.. @

() Installed SDKs
(1) Quickstart Panel 57 (%)= Variables ©g Breakpoints = To install an SDK, simply drag and drop an SOK (zip file/fo

- () x

no

1o kSR khER DR
Q K

= 8

Tem... [gIma.. EiDebu.. B Offin. = O

®o D

Ider) into the ‘Installed SDKs' view. [Common 'mcuxpres

~
MCUXpresso IDE - Quickstart Panel
No project selected

\DE

Installed SDKs “. Available Boards| Available Devices |
Name

SDK Versien

HHHSDK 2. HVP-KV31F120M 2100
~ Create or import a project

Manifest Version  Location

380 &

Invoke the new SDK project wizard

~ Build your project

@

\SDK_2_10_0_HVP-KY

() MCUX workspace

Figure 4. MCUXpresso IDE - create new project or Import SDK example(s)

Then select your board, and clik Next button.

3 50K Wizard

(@) Creating project for device: MKV31F512ccx 12 using board: HVP-KV31F120M

. Board and/or Device selection page

~ SDK MCUs . Available boards

MCUs from installed SDKs. Please click

above or visit mcuxpresso.mxp.com to

Please select an available board for your project.
obtain additional SDKs.

[ Supported boards for device: MKV3TFS120012

NP MKV3TF512300x12

v KV3x
MKV3TF512xxx12

hvpkv31£120m

~ Preinstalled MCUs
MCUs from preinstalled LPC and
generic Cortex-M part support
NXP PN7462AU-C3-00 "
PN7462AU-C2-00
PN7462AU-C3-00
Generic-MD
Generic-Moplus
Generic-M23
Generic-M3
Generic-M33
Generic-M4
Generie-M7

v

Selected Device: MKV31F512300¢12 using board: HVP-KV31F120M
Target Core: emd
Description:

SDKs for selected MCU

Name
Kinetis KV3x-100-120 MHz, Advanced 3ph FOC / Sensorless Motor Control MCUs

SDK Version  Mani
based on ARM Cortex-M4

5 SDK_2x_HVP-KV3TF120M 2,100 (494 20 3.8.0

@

ifest Ve... Location

JE <Common>\SDK_2_10_0_HVP-KV:

<Back

Finish Cancel

Figure 5. MCUXpresso IDE - selecting the board
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Find the Middleware tab in the Components part of the window and click on the checkbox to be the rtcesl component ticked. Last
step is to click the Finish button and wait for project creating with all RTCESL libraries and include paths.

3 soK Wizard u] X
i, The source from the SDK will be copied into the workspace. If you want to use linked files, please unzip the 'SDK_2x_HVP-KV31F120M' SDK. VA &
. Configure the project

Project neme: | MKV31F31212_FirstProject] * | Project name suffix:

Use default location

C:\MCUX_workspace\MKV31F51212_FirstProject Browse..
Device Packages Board Project Type Project Options
® MKV3IFS12VLLIZ ® Defaut board files @CProject (O Cr+ Project SDK Debug Console (3 Semihost @) UART
O MKVEIFSIZVLHT2 O Empty bosrd files [ cmsis-Core

(O Cstatic Library () C++ Static Library Copy sources

[ Import other files

Components [F] Components selection summary B
Add or remove SDK software components

[typetofitter |

Operating Systems Drivers [ CMSIS Drivers  Utilities [Middleware . Board Components| Abstraction Layer | Software C:

Neme Description  Ver.. Info

Micdieware BRIBE | | & oen
[typetofitter ] £ Middleware
£ Operating Systems
Name Description Version Info £ Software Component
[ £ FreeMASTER = Utilties
£ Memon
[] = Motar Cantrol
Real Time Control Embedded Software Library for CM... 110" | Real Time Control Embedded Software Library for CMAF core
@ < Back Mext » Cancel

Figure 6. MCUXpresso IDE - selecting rtcesl component

Type the #include syntax into the code where you want to call the library functions. In the left-hand dialog, open the required .c
file. After the file opens, include the following lines into the #include section:

#include "mlib FP.h"
#include "gdflib FP.h"

When you click the Build icon (hammer), the project is compiled without errors.

1.3 Library integration into project (Keil pVision)

This section provides a step-by-step guide on how to quickly and easily include GDFLIB into an empty project or any
MCUXpresso SDK example or demo application projects using Keil pVision. This example uses the default installation path
(C:ANXP\RTCESL\CM33F_RTCESL_4.7_KEIL). If you have a different installation path, use that path instead. If any MCUXpresso
SDK project is intended to use (for example hello_world project) go to Linking the files into the project chapter otherwise read
next chapter.

NXP pack installation for new project (without MCUXpresso SDK)

This example uses the NXP LPC55s69 part, and the default installation path (C:\NXP\RTCESL\CM33F_RTCESL_4.7_KEIL) is
supposed. If the compiler has never been used to create any NXP MCU-based projects before, check whether the NXP MCU pack
for the particular device is installed. Follow these steps:

1. Launch Keil yVision.

2. In the main menu, go to Project > Manage > Pack Installer....

3. In the left-hand dialog (under the Devices tab), expand the All Devices > Freescale (NXP) node.
4

. Look for a line called "KVxx Series" and click it.

GDFLIB User's Guide, Rev. 5, 01 November 2021
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In the right-hand dialog (under the Packs tab), expand the Device Specific node.

When installed, the button has the "Up to date" title. Now close the Pack Installer.

Library

Look for a node called "Keil::Kinetis_KVxx_DFP." If there are the Install or Update options, click the button to install/
update the package. See Figure 7.

{6 Pack Installer - Ci\Keil uS\ARM\PACK - ==& = ]
File Packs Window Help
> ‘ Device: Freescale - Kvox Series
4 Devices | Boards | | |la] " Packs | Examples | |
‘ Search: - X Pack Description
Iff 2evice /| summary 171 Device Specific
@ Atmel 257 Devices ||| KeaKinetis Ko DFP Freescale Kinetis Ko Series Device Support
@ Freescale 234 Devices El-Generic
% K Series 1 Device ARMECMSIS CMSIS (Cortex Microcontraller Software Interface Standard)
%2 K00 Series. 2 Devices Keil:zARM_Compiler Keil ARM Compiler extensions
%2 K10 Series. 23 Devices Keil:lansson Jansson is a C library for encoding, decoding and manipula
42 K20 Series. #1 Devices Keil:zMDK-Middleware Keil MDK-ARM Professional Middleware for ARM Cartex-M
%2 K30 Series. 6 Devices Keil:zMDK-Network_D! Keil MDK-ARM Professional Middleware Dual-Stack IPv4/IP
% K40 Series. 6 Devices WPz wIP IWIP is 2 light-weight implementation of the TCP/IP protoc
%2 K50 Series. 11 Devices Micrium:RTOS Micrium software components
%2 K60 Series. 18 Devices Ory Package (CycloneTCP, CycloneSSL and Cyclon
%2 K70 Series. 3 Devices WoIfSSL:CyaSSL Light weight SSL/TLS and Crypt Library for Embedded Syste
%2 K80 Series. 2 Devices 1 YOGITECH:fRSTL_AR... |& YOGITECH fRSTL Functional Safety EVAL Software Pack for
. KEAvo Series 6 Devices
Kb Series 11 Devices
Kl Series 54 Devices
A Koo Series 14 Devices
A Kiioc Series 26 Devices
. Koo Series 8 Devices
% WPRISI6 Series |1 Device
&t i )l i
Output 3 x
Refresh Pack descriptions
Update available for Keil:MDK-Middleware (installed: 6.4.0, available: 7.0.0-beta)
Ready [ [onume

Figure 7. Pack Installer

New project (without MCUXpresso SDK)

To start working on an application, create a new project. If the project already exists and is opened, skip to the next section. Follow
these steps to create a new project:

1.
2.

N o o &

Launch Keil pVision.

In the main menu, select Project > New pVision Project..., and the Create New Project dialog appears.

Navigate to the folder where you want to create the project, for example C:\KeilProjects\MyProject01. Type the name of the
project, for example MyProject01. Click Save. See Figure 8.

Create New Project

* Browse Folders

Figure 8. Create New Project dialog

File name:  MyProject0l

Save as type: |Project Files (“uvproj: ".uvprojs)

Expand the node.
Click the LPC55s69 node, and then click OK. See Figure 9.

GDFLIB User's Guide, Rev. 5, 01 November 2021
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-
Device |Targe¢| Ol.rlputl Listing I User | C/CH-I Asm I Linkerl Debug I Uhl'rtiesl I
ISoﬂware Packs ;I
Vendor: NXP Software Pack
Device: LPC55563JBD100:cm33 cored Pack: [NXP.LPC35569_DFP.12.11
Toolset: ARM URL:  http://mcuxpresso nxp com/cmsis_pack/frepe
Search:
¥ ARM 4 || |The LPCESx/LPC555xx is an ARM Cortex M33 based micro-
@ NP controller for embedded applications. These devices include up to
El 320 KB of on-chip SRAM, up to 640 KB on-chip flash, high-speed
2 K32L2A41A and full-speed USB host and device interface with crystaldess
\)[g . operation for full-speed, five general-purpose timers, one
KExx Series SCTimer/PWM, one RTC/alam timer, one 24-bit Mutti-Rate Timer
2% LPC55560 (MRT), a Windowed Watchdog Timer (WWDT), eight flexible senal
communication peripherals {each of which can be a USART, SPI,
=] ‘%3 LPC55569 12C. or 125 interface), one 16-bit 1.0 Msamples/eec ADC, temperature
B4 LPC555691BD100 sensor.
&3 LPC55569/BD100
€3 LPC53569/BD100
4 I b I r T
QK I Cancel Help
Figure 9. Select Device dialog

8. In the next dialog, expand the Device node, and tick the box next to the Startup node. See Figure 10.

9. Expand the CMSIS node, and tick the box next to the CORE node.

Figure 10. Manage Run-Time Environment dialog

10. Click OK, and a new project is created. The new project is now visible in the left-hand part of Keil yVision. See Figure 11.

ChKeilProj %) __'_El:l:ﬂl My Projectl. Jx - ‘lul"_'
E! \KeilProjects\MyProj MWy Praoj uvprojx - pVisicn I

File Edit WView Project Flash Debug Peripherals Tool

NE @ & i | Bal:
LR B o2 L ££|Target1 Eﬁ&|

Project n 3
=55 device j
| L] fsl_device_registers.h

L] LPC55569_cm33_corel.h

L] LPC55569_cm33_corel_features.h

L] system_LPC55569_cm33_corel.c

L] system_LPC55568_cm33_corellh
=L startup

] startup_LPC55569_cm33_corel.S

Figure 11. Project

11. In the main menu, go to Project > Options for Target 'Target1'..., and a dialog appears.
12. Select the Target tab.

13. Select Use Single Precision in the Floating Point Hardware option. See Figure 11.
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—Code Generation

[~ Use Cross-Module Optimization

ARM Compiler: ILlse default compiler version

[ Use MicroLIB [T BigEndian

Floating Point Hardware: Usze Single Precision [

=

Figure 12. FPU

PowerQuad DSP Coprocessor and Accelerator support

Some LPC platforms (LPC55S6x) contain a hardware accelerator dedicated to common calculations in DSP applications. This

section shows how to turn the PowerQuad (PQ) support for a function on and off.

1. In the main menu, go to Project > Options for Target 'Target1'..., and a dialog appears.

2. Select the C/C++ tab. See Figure 13.

3. In the Include Preprocessor Symbols text box, type the following:

+ RTCESL_PQ_ON—to turn the hardware division and square root support on.

* RTCESL_PQ_OFF—to turn the hardware division and square root support off.

If neither of these two defines is defined, the hardware division and square root support is turned off by default.

B

|

De\ricel Tanget | Outputl Listingl User C/Cs++ |km I Linkerl Debug | Lkilties |

— Prep Symbaols

Define: IF{TCESL_F'Q_ON

Undefine: I

 Language / Code Generation

™ Execute-only Code [~ Strict ANSIC

Optimization: lm I Enum Container always int

I~ Optimize for Time [~ Plain Charis Signed

I~ Split Load and Store Muliple ™ Read-Only Position Independent
I~ One ELF Section per Function [~ Bead-Write Postion Independert

Wamings

All Wamings -
T Thumb Mode

™ No Auto Includes
[~ C99 Mode

Include I
Paths

Misc I
Cortrols

Compiler |- —cpu Cortex-M4fp -D__EVAL -g 00 —apcs=interwork
control |- C:\KeilProjects \MyProject01W\RTE
string

Defaults

Figure 13. Preprocessor symbols

4. Click OK in the main dialog.

5. Ensure the PowerQuad moduel to be clocked by calling function RTCESL_PQ_Init(); prior to the first function using PQ

module calling.

See the device reference manual to verify whether the device contains the PowerQuad DSP Coprocessor and

Accelerator support.
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Linking the files into the project

GDFLIB requires MLIB to be included too. The following steps show how to include all dependent modules.

To include the library files in the project, create groups and add them.

Library

1. Right-click the Target 1 node in the left-hand part of the Project tree, and select Add Group... from the menu. A new group

with the name New Group is added.

2. Click the newly created group, and press F2 to rename it to RTCESL.

3. Right-click the RTCESL node, and select Add Existing Files to Group 'RTCESL'... from the menu.

4. Navigate into the library installation folder C:\NXP\RTCESL\CM33F_RTCESL_4.7_KEIL\MLIB\Include, and select the

miib_FP.hfile. If the file does not appear, set the Files of type filter to Text file. Click Add. See Figure 14.

Look in: | | Include

Mame

[ MLIB_Div1Q_F32

[ mlib_FP

[ MLIB_Log2_U16

[2f MLIB_Mac_A32

[ MLIB_Mac_F16_Asmi
[ MLIB_Mac_F32

[&f MLIB_Mac_F32_Asmi
[ MLIB_Mac_FLT

[2f MLIB_Mac4_F32

[ MLIB_Macd_F32_Asmi

[ am1o Rt T T

i | mn

~| & & cf B

Date modified i

6,/20/2016 9:49 AM
7/22/20161:15 PM

6,/20/2016 9:49 AM K

6/20/2016 9:49 AM
7/25/2016 8:27 AM
6,/20/2016 9:49 AM
7/25/2016 8:27 AM
6,/20/2016 9:49 AM
6/20/2016 9:49 AM
7/25/2016 8:27 AM

AN E OLAn ARA
k

File name: |n1|ib_FF‘

Files of type: |Taxt file (“td:; *h; “inc)

Figure 14. Adding .h files dialog

j Close

5. Navigate to the parent folder C:ANXP\RTCESL\CM33F_RTCESL_4.7_KEIL\MLIB, and select the mlib./ibfile. If the file does
not appear, set the Files of type filter to Library file. Click Add. See Figure 15.
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Look in: |}, MLIB ~| & & et E-

MName . Date modified Ty
! Include 2010.2014 15:37 Fi

|| MLIB.lib 16.10.2014 9:19 L

1| m

2
Filename:  [MLIBib Add |
Files of type: | Library file (" lib) | Close |

Figure 15. Adding .lib files dialog

6. Navigate into the library installation folder C:ANXP\ARTCESL\CM33F_RTCESL_4.7_KEIL\GDFLIB\Include, and select the
gdflib_FP.hfile. If the file does not appear, set the Files of type filter to Text file. Click Add.

7. Navigate to the parent folder C:\NXP\RTCESL\CM33F_RTCESL_4.7_KEIL\GDFLIB, and select the gdfiib./ibfile. If the file
does not appear, set the Files of type filter to Library file. Click Add.

8. Now, all necessary files are in the project tree; see Figure 16. Click Close.

| Project 1 &
=% Project: MyProjectll
! =g Targetl
L Seource Group 1
=% RTCESL
1 mlib_FP.h
] MLEB.lib
_] gdflib_FP.h
_] GDFLIB.lib
& cmsis
EI“’ Device

Figure 16. Project workspace

Library path setup

The following steps show the inclusion of all dependent modules.
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1. In the main menu, go to Project > Options for Target 'Target1'..., and a dialog appears.
2. Select the C/C++ tab. See Figure 17.

3. Inthe Include Paths text box, type the following paths (if there are more paths, they must be separated by ';') or add them
by clicking the ... button next to the text box:

* "C:\NXP\RTCESL\CM33F_RTCESL_4.7_KEIL\MLIB\Include"

+ "C:\NXP\RTCESL\CM33F_RTCESL_4.7_KEIL\GDFLIB\Include"
4. Click OK.
5. Click OK in the main dialog.

Devicel Target | Oulpull Listingl User C/Ce+ |.&'sm I Linkerl Debug | Ltilities |

P Symbals
Define: I
Undefine: I
— Language / Code Generation
I Sirict ANSIC e
Optimization: |Level 0 (00) ~ I™ Enum Container abways int All Wamings <
I Optimize for Time ™ Plain Char is Signed [T Thumb Mode
™ Spli Load and Store Multiple [~ Read-Cnly Position Independent [~ No Auto Includes
[ One ELF Section per Function ™ Read-Wite Posttion Independert [~ €39 Mode
Include
Paths Il J
Misc I
Controls
Compiler | —cpu Cortex-M0+ -D__EVAL -g -00 -apcs=interwork .
control [ C:\KeilProjects \MyProject01\RTE
string -
0K I Cancel Defaults Help I

Figure 17. Library path addition

Type the #include syntax into the code. Include the library into a source file. In the new project, it is necessary to create a
source file:

1. Right-click the Source Group 1 node, and Add New ltem to Group 'Source Group 1'... from the menu.

2. Select the C File (.c) option, and type a name of the file into the Name box, for example 'main.c. See Figure 18.
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-

Add New Item to Group "Source Group 1

Create a new C source file and add it to the projec
C |CFils{c)

@ C++ File  cpp)
\ﬂ Asm File (s)

\ﬂ Header File (h)
é Text File ()
jg\ Image File ()

mf

1@ |Jser Code Template
Type:
Mame: | main. ¢
Location: | C:KeiProjects\MyProjectd1
Add Close
S

Figure 18. Adding new source file dialog

3. Click Add, and a new source file is created and opened up.
4. In the opened source file, include the following lines into the #include section, and create a main function:

#include "mlib FP.h"
#include "gdflib FP.h"

int main (void)
{

while (1) ;
}

When you click the Build (F7) icon, the project will be compiled without errors.

1.4 Library integration into project (IAR Embedded Workbench)

This section provides a step-by-step guide on how to quickly and easily include the GDFLIB into an empty project or any
MCUXpresso SDK example or demo application projects using IAR Embedded Workbench. This example uses the default
installation path (C:\NXP\RTCESL\CM33F_RTCESL_4.7_IAR). If you have a different installation path, use that path instead. If
any MCUXpresso SDK project is intended to use (for example hello_world project) go to Linking the files into the project chapter
otherwise read next chapter.

New project (without MCUXpresso SDK)

This example uses the NXP LPC55S69 part, and the default installation path (C:\NXP\RTCESL\CM33F_RTCESL_4.7_IAR) is
supposed. To start working on an application, create a new project. If the project already exists and is opened, skip to the next
section. Perform these steps to create a new project:

1. Launch IAR Embedded Workbench.

2. In the main menu, select Project > Create New Project... so that the "Create New Project" dialog appears. See Figure 19.
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Tool chain: | AFiM
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DLIB [C. Extended Embedded C++]
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Description:

C project uzing default tool settings inchuding an emply main.c file.

Figure 19. Create New Project dialog

3. Expand the C node in the tree, and select the "main" node. Click OK.

4. Navigate to the folder where you want to create the project, for example, C:\IARProjects\MyProject01. Type the name of the
project, for example, MyProject01. Click Save, and a new project is created. The new project is now visible in the left-hand
part of IAR Embedded Workbench. See Figure 20.

Figure 20. New project

& 1AR Embedded Workbench IDE

File Edit View Project Simulator Tools Window Help
DeWdd & fBRw o - 4
Workspace x main.cl
[Debug v]
Files 2 O e
=f&]MyProjectdl -Deb... [« | | return 0
main.c o |
L@ 3 Output

5. In the main menu, go to Project > Options..., and a dialog appears.

6. Inthe Target tab, select the Device option, and click the button next to the dialog to select the MCU. In this example, select
NXP > LPC55S69 > NXP LPC55S69_core0. Select VFPV5 single precision in the FPU option.The DSP instructions group
is required please check the DSP Extensions checkbox if not checked. Click OK. See Figure 21.
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Figure 21. Options dialog

-
Options for node "MyProject01"

. =]

Category:
Static Analysis Library Options 2 MISRA-C:2004 MISRA-C:1398
Rg;;zi EZ;?IZ? Target Qutput Library Configuration Library Options 1
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) Mod ~
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PowerQuad DSP Coprocessor and Accelerator support

Some LPC platforms (LPC55S6x) contain a hardware accelerator dedicated to common calculations in DSP applications. Only
functions runing faster through the PowerQuad module than the core itself are supported and targeted to be calculated by the

PowerQuad module. This section shows how to turn the PowerQuad (PQ) support for a function on and off.

1. In the main menu, go to Project > Options..., and a dialog appears.

2. In the left-hand column, select C/C++ Compiler.

3. Inthe right-hand part of the dialog, click the Preprocessor tab (it can be hidden in the right-hand side; use the arrow icons

for navigation).

4. In the text box (at the Defined symbols: (one per line)), type the following (See Figure 22):
+ RTCESL_PQ_ON—to turn the PowerQuad support on.

* RTCESL_PQ_OFF—to turn the PowerQuad support off.

If neither of these two defines is defined, the hardware division and square root support is turned off by default.
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Options for node "MyProject01”

Cateqary:
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Figure 22. Defined symbols

5. Click OK in the main dialog.

6. Ensure the PowerQuad moduel to be clocked by calling function RTCESL_PQ_Init(); prior to the first function using PQ

module calling.

See the device reference manual to verify whether the device contains the PowerQuad DSP Coprocessor and
Accelerator support.

Library path variable

To make the library integration easier, create a variable that will hold the information about the library path.

1. In the main menu, go to Tools > Configure Custom Argument Variables..., and a dialog appears.

2. Click the New Group button, and another dialog appears. In this dialog, type the name of the group PATH, and click OK.

See Figure 23.

GDFLIB User's Guide, Rev. 5, 01 November 2021

User Guide

19/61



NXP Semiconductors

Library

.
i ' Configure Custom Argument Variables |i|
Workspace | Global
Enable Group
| |“Eoup. -
MNew Group i »
Fiable...
M : E
ame PATH Ebie....
lete
oK l [ Cancel -
prt...
Expand/Collapse All
[ Hide disabled groups
oK l l Cancel
- e - ’.

Figure 23. New Group

Click on the newly created group, and click the Add Variable button. A dialog appears.
Type this name: RTCESL_LOC

To set up the value, look for the library by clicking the '..." button, or just type the installation path into the box:
C:\NXP\RTCESL\CM33F_RTCESL_4.7_IAR. Click OK.

In the main dialog, click OK. See Figure 24.

# ' Configure Custom Argument Variables [ = |
Workspace | Global
[ pATH Disable Group
,
Add Variable ==
Name: |RTCESL_LOC |
Value: |C:\NXP\,RTCESL_CM33F_RTCESL_X.X_IAR | 0O |[ B
[ OK. J[ Cancel ]
2|

Figure 24. New variable

Linking the files into the project

GDFLIB requires MLIB to be included too. The following steps show the inclusion of all dependent modules.

To include the library files into the project, create groups and add them.

1.

Go to the main menu Project > Add Group...

2. Type RTCESL, and click OK.

3. Click on the newly created node RTCESL, go to Project > Add Group..., and create a MLIB subgroup.

4.

5. Navigate into the library installation folder C:\NXP\RTCESL\CM33F_RTCESL_4.7_IAR\MLIB\Include, and select the m/ib.h

Click on the newly created node MLIB, and go to the main menu Project > Add Files... See Figure 26.

file. (If the file does not appear, set the file-type filter to Source Files.) Click Open. See Figure 25.
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6. Navigate into the library installation folder C:\NXP\RTCESL\CM33F_RTCESL_4.7_IAR\MLIB, and select the m/ib.afile. If
the file does not appear, set the file-type filter to Library / Object files. Click Open.

. |
» System (C:) » NXP » RTCESL » CM33RTCESLXXIAR » MLUE » Include

i MName Date modified Type
. mlib.h 16.10.20159:38 H File
| MLIB_Abs_F16.h 16.10.20159:38 H File

Figure 25. Add Files dialog

7. Click on the RTCESL node, go to Project > Add Group..., and create a GDFLIB subgroup.
8. Click on the newly created node GDFLIB, and go to the main menu Project > Add Files....

9. Navigate into the library installation folder C:\NXP\RTCESL\CM33F_RTCESL_4.7_IAR\GDFLIB\Include, and select the
gdflib.hfile. (If the file does not appear, set the file-type filter to Source Files.) Click Open.

10. Navigate into the library installation folder C:\NXP\RTCESL\CM33F_RTCESL_4.7_IAR\GDFLIB, and select the gdfiib.a
file. If the file does not appear, set the file-type filter to Library / Object files. Click Open.

11. Now you will see the files added in the workspace. See Figure 26.

‘Workspace x
lDebug -
Files i By
= (J MyProjectd! - Debug * v
FHE CIRTCESL
Fa CIMUE
| —DOwLBa
| LY— & mlib_FPh
gelmlGoFLE | [
— [ GDFLEB.A
L— [ gelflib_FP.h
main.c x
= (] Output
Figure 26. Project workspace

Library path setup

The following steps show the inclusion of all dependent modules:
1. In the main menu, go to Project > Options..., and a dialog appears.
2. In the left-hand column, select C/C++ Compiler.

3. In the right-hand part of the dialog, click on the Preprocessor tab (it can be hidden in the right; use the arrow icons
for navigation).

4. In the text box (at the Additional include directories title), type the following folder (using the created variable):
+ $RTCESL_LOCS$\MLIB\Include
+ $RTCESL_LOC$\GDFLIB\Include

5. Click OK in the main dialog. See Figure 27.
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Figure 27. Library path adition

ak. ] [ Cahicel

Type the #include syntax into the code. Include the library included into the main.cfile. In the workspace tree, double-click the
main.cfile. After the main.c file opens up, include the following lines into the #include section:

#include "mlib FP.h"
#include "gdflib FP.h"

When you click the Make icon, the project will be compiled without errors.
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Chapter 2
Algorithms in detall

2.1 GDFLIB_FilterExp

The GDFLIB_FilterExp function calculates the exponential smoothing. The exponential filter is the simplest filter with only one
tuning parameter, requiring to store only one variable - the filter output (it is used in the next step). For a proper use, it is
recommended that the algorithm is initialized by the GDFLIB_FilterExplnit function, before using the GDFLIB_FilterExp function.

The filter calculation consists of the following equation:

y(k)=y(k-1)+A4- (x(k)-(k-1))
Figure 28.

where:
» x(k) is the actual value of the input signal
* y(k) is the actual filter output
« Ais the filter constant (0 ; 1) (it defines the smoothness of the exponential filter)

The exponential filter tuning is based on these rules: for a small value of the filter constant there is a strong filtering effect (if A= 0
then the output equals the new input). For a high value of the filtering constant, there is a weak filtering effect (if A = 1 then the new
inputis ignored). The filter constant defines the ratio between the filter inputs and the last step output, used for the next calculation.

2.1.1 Available versions
This function is available in the following versions:

» Fractional output - the output is the fractional portion of the result; the result is within the range <-1 ; 1). The parameter uses
the fraction type.

 Floating-point output - the output is the floating-point result within the type's full range. The parameter is of a floating-point
range as well.

The available versions of the GDFLIB_FilterExplnit function are shown in the following table:

Table 2. Init function versions

Function name Input Parameters Result Description
type type
GDFLIB_FilterExplnit_F1 |frac16_t | GDFLIB_FILTER_EXP_T_F32* |void The input argument is a 16-bit fractional
6 value that represents the initial value of

the filter at the current step. The input is
within the range <-1 ; 1). The parameters'
structure is pointed to by a pointer.

GDFLIB_FilterExplnit_FL |float_t GDFLIB_FILTER_EXP_T_FLT* | void The input argument is a 32-bit

T single precision floating-point value that
represents the initial value of the filter at
the current step. The input is within the full
range. The parameters' structure is pointed
to by a pointer.

The available versions of the GDFLIB_FilterExp function are shown in the following table:
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Table 3. Function versions

Function name

Input Parameters Result Description
type type

6

GDFLIB_FilterExp_F1

frac16_t | GDFLIB_FILTER_EXP_T_F32 | frac16_t | The input argument is a 16-bit fractional value of

* the input signal to be filtered within the range <-1 ;
1). The parameters' structure is pointed to by a
pointer. The function returns a 16-bit fractional
value within the range <-1; 1).

T

GDFLIB_FilterExp_FL

float_t |GDFLIB_FILTER_EXP_T_FL |float_.t |The inputargumentis a 32-bit single precision
T floating-point value of the input signal to be filtered
within the full range. The parameters' structure
is pointed to by a pointer. The function returns a
32-bit single precision floating-point value within

the full range.

2.1.2 GDFLIB_FILTER_EXP_T_F32

Variable Input Description
name type
f32A frac32_t | Filter constant value (filter parameter). It defines the smoothness of the exponential filter (high value
= small filtering effect, low value = strong filtering effect). It is usually defined as:
A=1- exp—%
Where T is the sample time and 1 is the filter time constant. The parameter is a 32-bit fractional
value within the range <-0 ; 1). Set by the user.
f32AccK_1 | frac32_t | Filter accumulator (last step output) value. The parameter is a 32-bit accumulator type within the

range <-1.0 ; 1.0). Controlled by the algorithm.

2.1.3 GDFLIB_FILTER_EXP_T_FLT

Variable Input Description
name type
fItA float_t Filter constant value (filter parameter). It defines the smoothness of the exponential filter (high value
= small filtering effect, low value = strong filtering effect). It is ussually defined as:
A=1- exp%
Where Ty is the sample time and 7 is the filter time constant. The parameter is a 32-bit single
precision floating-point type within the range (0 ; 1.0>. Set by the user.
fltAccK_1 | float_t Filter accumulator (last step output) value. The parameter is a 32-bit accumulator type within the

32-bit single precision floating-point range. Controlled by the algorithm.

2.1.4 Declaration

The available GDFLIB_FilterExplInit functions have the following declarations:

void GDFLIB FilterExpInit F16(fracl6é t fl6InitVal, GDFLIB FILTER EXP T F32 *psParam)
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void GDFLIB FilterExpInit FLT (float t fltInitVal, GDFLIB FILTER EXP T FLT *psParam)

The available GDFLIB_FilterExp functions have the following declarations:

fracl6_t GDFLIB_FilterExp F16(fracl6_t f16InX, GDFLIB_FILTER EXP T F32 *psParam)

float t GDFLIB FilterExp FLT (float t fltInX, GDFLIB FILTER EXP T FLT *psParam)

2.1.5 Function use
The use of the GDFLIB_FilterExplnit and GDFLIB_FilterExp functions is shown in the following examples:

Fixed-point version:
#include "gdflib.h"
static fracl6é t fl6Result;
static fraclé t fl16Initval, f16InX;
static GDFLIB FILTER EXP T F32 sFilterParam;
void Isr (void);
void main (void)
{

f16InitVal = FRAC16(0.0); /* fl6Initval = 0.0 */

/* Filter constant = 0.05 */
sFilterParam.f32A = FRAC32(0.05);

GDFLIB FilterExpInit F16(f16InitVal, &sFilterParam);
f16InX = FRAC16(0.5);
/* periodically called function */

void Isr (void)

{
fl6Result = GDFLIB FilterExp F16(£f16InX, &sFilterParam);

Floating-point version:
#include "gdflib.h"
static float t fltResult;
static float_t fltInitval, fltInX;
static GDFLIB FILTER EXP T FLT sFilterParam;
void Isr (void) ;
void main (void)

{
fltInitval = 0.0F; /* fltInitVal = 0.0 */
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/* Filter constant = 0.05 */
sFilterParam.fltA = 0.05F;

GDFLIB FilterExpInit FLT (fltInitVal, &sFilterParam);

f1tInX = 0.5F;
}

/* periodically called function */
void Isr (void)
{
fltResult = GDFLIB FilterExp FLT(fl1tInX, &sFilterParam);

2.2 GDFLIB_FilterlIR1

This function calculates the first-order direct form 1 IR filter.

For a proper use, it is recommended that the algorithm is initialized by the GDFLIB_FilterlIR1Init function, before using the
GDFLIB_FilterlIR1 function. The GDFLIB_FilterlIR1Init function initializes the buffer and coefficients of the first-order IIR filter.

The GDFLIB_FilterlIR1 function calculates the first-order infinite impulse response (lIR) filter. The IIR filters are also called
recursive filters, because both the input and the previously calculated output values are used for calculation. This form of feedback
enables the transfer of energy from the output to the input, which leads to an infinitely long impulse response (lIR). A general form
of the IIR filter, expressed as a transfer function in the Z-domain, is described as follows:

H(z) = B@ _ botbiz byz 2+ . +byz N
=1 Va7 ayz 2+ rayz N

Figure 29.

where N denotes the filter order. The first-order IIR filter in the Z-domain is expressed as follows:

Bz) bytbiz!

HE=%G) = TFaeg T

Figure 30.

which is transformed into a time-domain difference equation as follows:

k)= byx(k)+ bk — D)-apk — 1)
Figure 31.

The filter difference equation is implemented in the digital signal controller directly, as given in Equation 3; this equation represents
a direct-form 1 first-order IIR filter, as shown in Figure 32.
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x(k) y(k)
>

Figure 32. Direct form 1 first-order IIR filter

The coefficients of the filter shown in Figure 3-1 can be designed to meet the requirements for the first-order low-pass filter (LPF)
or high-pass filter (HPF). The coefficient quantization error is not important in the case of a first-order filter due to a finite precision
arithmetic. A higher-order LPF or HPF can be obtained by connecting a number of first-order filters in series. The number of
connections gives the order of the resulting filter.

The filter coefficients must be defined before calling this function. As some coefficients can be greater than 1 (and lesser than 2),
the coefficients are scaled down (divided) by 2.0 for the fractional version of the algorithm. For faster calculation, the A coefficient
is sign-inverted. The function returns the filtered value of the input in the step k, and stores the input and the output values in the
step k into the filter buffer.
2.2.1 Available versions
This function is available in the following versions:

» Fractional output - the output is the fractional portion of the result; the result is within the range <-1; 1).

 Floating-point output - the output is a floating-point result within the type's full range.

The available versions of the GDFLIB_FilterlIR1Init function are shown in the following table:

Table 4. Init function versions

Function name Parameters Result Description
type

GDFLIB_FilterlIR1Init_F16 | GDFLIB_FILTER_IIR1_T_F32* |void Filter initialization (reset) function. The parameters'
structure is pointed to by a pointer.

GDFLIB_FilterlIR1Init_FLT | GDFLIB_FILTER_IIR1_T_FLT* |void Filter initialization (reset) function. The parameters'
structure is pointed to by a pointer.

The available versions of the GDFLIB_FilterlIR1 function are shown in the following table:

Table 5. Function versions

Function name Input Parameters Result Description
type type

GDFLIB_FilterllR1_F16 |frac16_t | GDFLIB_FILTER_IIR1_T_F32* |frac16_t |The input argument is a 16-bit fractional
value of the input signal to be filtered
within the range <-1 ; 1). The parameters'
structure is pointed to by a pointer. The
function returns a 16-bit fractional value
within the range <-1; 1).

GDFLIB_FilterlIR1_FLT |float_t GDFLIB_FILTER_IIR1_T_FLT* |float_t The input argument is a 32-bit single
precision floating-point value of the

Table continues on the next page...
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Function name Input Parameters Result Description
type type
input signal within the full range. The
parameters' structure is pointed to by a
pointer. The function returns a 32-bit single
precision floating-point value within the
full range.
2.2.2 GDFLIB_FILTER_IIR1_T_F32
Variable name Input type Description

sFltCoeff GDFLIB_FILTER_IIR1_COEFF_T_F32* Substructure containing filter coefficients.
f32FItBfrY[1] frac32_t Internal buffer of y-history. Controlled by the algorithm.
f16FItBfrX[1] frac16_t Internal buffer of x-history. Controlled by the algorithm.

2.2.3 GDFLIB_FILTER_IIR1_COEFF_T_F32

(negative two).

Variable name Type Description
f32B0 frac32_t | BO coefficient of the IIR1 filter. Set by the user, and must be divided by 2.
f32B1 frac32_t | B1 coefficient of the IIR1 filter. Set by the user, and must be divided by 2.
f32A1 frac32_t | A1 (sign-inverted) coefficient of the IIR1 filter. Set by the user, and must be divided by -2

2.24 GDFLIB_FILTER_IIR1_T_FLT

Variable name

Input type

Description

sFltCoeff GDFLIB_FILTER_IIR1_COEFF_T_FLT* Substructure containing filter coefficients.
fItFItBfrY[1] float_t Internal buffer of y-history. Controlled by the algorithm.
fItFItBfrX[1] float_t Internal buffer of x-history. Controlled by the algorithm.

2.2.5 GDFLIB_FILTER_IIR1_COEFF_T_FLT

Variable name Type Description
fltBO float_t BO coefficient of the IIR1 filter. Set by the user.
fltB1 float_t B1 coefficient of the IIR1 filter. Set by the user.
fltA1 float_t A1 (sign-inverted) coefficient of the [IR1 filter. Set by the user.
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2.2.6 Declaration

The available GDFLIB_FilterlIR1Init functions have the following declarations:

void GDFLIB FilterIIR1Init F16(GDFLIB FILTER IIR1 T F32 *psParam)
void GDFLIB FilterIIR1Init FLT (GDFLIB FILTER IIR1 T FLT *psParam)

The available GDFLIB_FilterlIR1 functions have the following declarations:

fraclé_t GDFLIB FilterIIR1 Fl6(fraclé t f16InX, GDFLIB FILTER IIR1 T F32 *psParam)
float t GDFLIB FilterIIR1l FLT (float t fltInX, GDFLIB FILTER IIR1 T FLT *psParam)

2.2.7 Calculation of filter coefficients

There are plenty of methods for calculating the coefficients. The following example shows the use of Matlab to set up a low-pass
filter with the 500 Hz sampling frequency, and 240 Hz stopped frequency with a 20 dB attenutation. Maximum passband ripple is
3 dB at the cut-off frequency of 50 Hz.

% sampling frequency 500 Hz, low pass
Ts = 1 / 500

% cut-off frequency 50 Hz
Fc = 50

% max. passband ripple 3 dB

% stopped frequency 240Hz

Fs = 240

% attenuation 20 dB
Rs = 20

oe

checking order of the filter
= buttord(2 * Ts * Fc, 2 * Ts * Fs, Rp, Rs)
n =1, i.e. the filter is achievable with the 1st order

=)

o

% getting the filter coefficients
[b, al] = butter(n, 2 * Ts * Fc, 'low');

the coefs are:
b0 = 0.245237275252786, bl = 0.245237275252786
a0 = 1.0000, al = -0.509525449494429

o° oo oo

0
0

The filter response is shown in Figure 33.
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Figure 32. Filter response

2.2.8 Function use

The use of the GDFLIB_FilterlIR1Init and GDFLIB_FilterlIR1 functions is shown in the following examples. The filter uses the
above-calculated coefficients:

Fixed-point version:
#include "gdflib.h"

static fracl6é t fl6Result;
static fraclé6 t f16InX;
static GDFLIB FILTER IIR1 T F32 sFilterParam;

void Isr (void) ;

void main (void)

{
sFilterParam.sFltCoeff.f32B0 FRAC32(0.245237275252786 / 2.0) ;
sFilterParam.sFltCoeff.f32B1 FRAC32(0.245237275252786 / 2.0);
sFilterParam.sFltCoeff.f32A1 = FRAC32(-0.509525449494429 / -2.0);

GDFLIB FilterIIR1Init F16 (&sFilterParam);
f16InX = FRAC16(0.1);
/* periodically called function */

void Isr (void)

{
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fl6Result = GDFLIB FilterIIRl F16(f16InX, &sFilterParam);

Floating-point version:
#include "gdflib.h"

static float t fltResult;
static float t fltInX;
static GDFLIB_FILTER IIR1 T FLT sFilterParam;

void Isr (void) ;

void main (void)

{
sFilterParam.sFltCoeff.f1tBO 0.245237275252786f;
sFilterParam.sFltCoeff.f1ltBl 0.245237275252786f;
sFilterParam.sFltCoeff.f1tAl = -0.509525449494429¢f;

GDFLIB FilterIIR1Init FLT (&sFilterParam);

fltInX = 0.1F;

/* periodically called function */
void Isr (void)
{
fltResult = GDFLIB FilterIIR1l FLT (f1tInX, &sFilterParam);

2.3 GDFLIB_FilterlIR2

This function calculates the second-order direct-form 1 IIR filter.

For a proper use, it is recommended that the algorithm is initialized by the GDFLIB_FilterlIR2Init function, before using the
GDFLIB_FilterlIR2 function. The GDFLIB_FilterlIR2Init function initializes the buffer and coefficients of the second-order IIR filter.

The GDFLIB_FilterlIR2 function calculates the second-order infinite impulse response (lIR) filter. The IIR filters are also called
recursive filters, because both the input and the previously calculated output values are used for calculation. This form of feedback
enables the transfer of energy from the output to the input, which leads to an infinitely long impulse response (IIR). A general form
of the IIR filter, expressed as a transfer function in the Z-domain, is described as follows:

_ Bl _ botbiz Whyz 2. 4byz N
H(z)= Alz) — MazMayz 2. ayz N

Figure 33.

where N denotes the filter order. The second-order IIR filter in the Z-domain is expressed as follows:

B(z) by+biz1+bz2

MO~ a0 T TrazT

Figure 34.

which is transformed into a time-domain difference equation as follows:
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(k)= bx(k) + bk — 1)+ box(k — 2)-aptk — )-ayy(k — 2)

Figure 35.

The filter difference equation is implemented in the digital signal controller directly, as given in Equation 3; this equation represents
a direct-form 1 second-order IIR filter, as depicted in Figure 36.

bO

x(k) R y(k) .
v v
Z1 Z1
—’ ‘—
h 4 h 4
7-1 7-1

Figure 36. Direct-form 1 second-order IIR filter

The coefficients of the filter depicted in Figure 3-1 can be designed to meet the requirements for the second-order low-pass filter
(LPF), high-pass filter (HPF), band-pass filter (BPF) or band-stop filter (BSF). The coefficient quantization error can be neglected
in the case of a second-order filter due to a finite precision arithmetic. A higher-order LPF or HPF can be obtained by connecting
a number of second-order filters in series. The number of connections gives the order of the resulting filter.

The filter coefficients must be defined before calling this function. As some coefficients can be greater than 1 (and lesser than 2),
the coefficients are scaled down (divided) by 2.0 for the fractional version of the algorithm. For faster calculation, the A coefficients
are sign-inverted. The function returns the filtered value of the input in the step k, and stores the input and output values in the
step k into the filter buffer.

2.3.1 Available versions
This function is available in the following versions:
» Fractional output - the output is the fractional portion of the result; the result is within the range <-1; 1).

* Floating-point output - the output is the floating-point result within the type's full range.

The available versions of the GDFLIB_FilterlIR2Init function are shown in the following table:

Table 6. Init function versions

Function name Parameters Result Description
type
GDFLIB_FilterlIR2Init_F16 GDFLIB_FILTER_IIR2_T_F32* | void Filter initialization (reset) function. The parameters'

structure is pointed to by a pointer.

If PowerQuad based function used the Init function
must be called prior to FilterlIR2_F16 function to
transfer 1IR2 parameters from fraction to float,
without the Init function required parameters will
not be used for the 1IR2 calculations.

GDFLIB_FilterlIR2Init_FLT | GDFLIB_FILTER_IIR2_T_FLT* |void Filter initialization (reset) function. The parameters'
structure is pointed to by a pointer.
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The available versions of the GDFLIB_FilterlIR2 function are shown in the following table:

Table 7. Function versions

Function name Input Parameters Result Description
type type

GDFLIB_FilterlIR2_F16 |frac16_t | GDFLIB_FILTER_IIR2_T_F32* |frac16_t |Input argumentis a 16-bit fractional value
of the input signal to be filtered within the
range <-1; 1). The parameters' structure
is pointed to by a pointer. The function
returns a 16-bit fractional value within the
range <-1; 1).

If PowerQuad based function used the
Init function must be called prior to
FilterllR2_F16 function to transfer 1IR2
parameters from fraction to float, without
the Init function required parameters will
not be used for the IIR2 calculations.

GDFLIB_FilterllR2_FLT | float_t GDFLIB_FILTER_IIR2_T_FLT* |float_t Input argument is a 32-bit single precision
floating-point value of the input signal
within the full range. The parameters'
structure is pointed to by a pointer. The
function returns a 32-bit single precision
floating-point value within the full range.

2.3.2 GDFLIB_FILTER_IIR2_T_F32

Variable name Input type Description
sFltCoeff GDFLIB_FILTER_IIR2_COEFF_T_F32* Substructure containing filter coefficients.
f32FItBfrY[2] frac32_t Internal buffer of y-history. Controlled by the algorithm.
f16FItBfrX[2] frac16_t Internal buffer of x-history. Controlled by the algorithm.

2.3.3 GDFLIB_FILTER_IIR2_COEFF_T_F32

Variable name Type Description

f32B0 frac32_t | BO coefficient of the IIR2 filter. Set by the user, and must be divided by 2.

f32B1 frac32_t | B1 coefficient of the IIR2 filter. Set by the user, and must be divided by 2.

f32B2 frac32_t | B2 coefficient of the IIR2 filter. Set by the user, and must be divided by 2.

f32A1 frac32_t | A1 (sign-inverted) coefficient of the IIR2 filter. Set by the user, and must be divided by -2
(negative two).

f32A2 frac32_t | A2 (sign-inverted) coefficient of the IIR2 filter. Set by the user, and must be divided by -2
(negative two).
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Variable name

Input type

Description

sFltCoeff GDFLIB_FILTER_IIR2_COEFF_T_FLT* Substructure containing filter coefficients.
fItFItBfrY[2] float_t Internal buffer of y-history. Controlled by the algorithm.
fItFItBfrX[2] float_t Internal buffer of x-history. Controlled by the algorithm.

2.3.5 GDFLIB_FILTER_IIR2_COEFF_T_FLT

Variable name Type Description
fltBO float_t BO coefficient of the 1IR2 filter. Set by the user.
fltB1 float_t B1 coefficient of the IIR2 filter. Set by the user.
fltB2 float_t B2 coefficient of the IIR2 filter. Set by the user.
fltA1 float_t A1 (sign-inverted) coefficient of the IIR2 filter. Set by the user.
fltA2 float_t A2 (sign-inverted) coefficient of the IIR2 filter. Set by the user.

2.3.6 Declaration

The available GDFLIB_FilterlIR2Init functions have the following declarations:

void GDFLIB FilterIIR2Init F16(GDFLIB_FILTER _IIR2 T_F32 *psParam)
void GDFLIB FilterIIR2Init FLT (GDFLIB FILTER IIR2 T FLT *psParam)

The available GDFLIB_FilterlIR2 functions have the following declarations:

fracl6 t GDFLIB FilterIIR2 F16(fracl6 t f16InX, GDFLIB FILTER IIR2 T F32 *psParam)
float t GDFLIB FilterIIR2 FLT (float t f1ltInX, GDFLIB FILTER IIR2 T FLT *psParam)

2.3.7 Calculation of filter coefficients

There are plenty of methods for calculating the coefficients. The following example shows the use of Matlab to set up a stopband
filter with the 1000 Hz sampling frequency, 100 Hz stop frequency with 10 dB attenuation, and 30 Hz bandwidth. Maximum
passband ripple is 3 dB.

% sampling frequency 1000 Hz, stop band
Ts = 1 / 1000

% center stop frequency 100 Hz
Fc = 50

% attenuation 10 dB
Rs = 10

% bandwidth 30 Hz
Fbw = 30

% max. passband ripple 3 dB
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o°

checking order of the filter
= buttord(2 * Ts * [Fc - Fbw /2 Fc + Fbw / 2], 2 * Ts * [Fc - Fbw Fc + Fbw], Rp, Rs)
n =2, i.e. the filter is achievable with the 2nd order

B

oe

% getting the filter coefficients
[b, al] = butter(n / 2, 2 * Ts * [Fc - Fbw /2 Fc + Fbw / 2], 'stop')

the coefs are:
= 0.913635972986238, bl = -1.745585863109291, b2 = 0.913635972986238
= 1.0000, al = -1.745585863109291, a2 = 0.827271945972476

d° oo oe
o O
o o

The filter response is shown in Figure 37.
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Figure 36. Filter response

2.3.8 Function use

The use of the GDFLIB_FilterlIR2Init and GDFLIB_FilterlIR2 functions is shown in the following examples. The filter uses the
above-calculated coefficients:

Fixed-point version:
#include "gdflib.h"

static fracl6 t fl6Result;
static fraclé t f£16InX;
static GDFLIB_FILTER IIR2 T F32 sFilterParam;

void Isr (void) ;

void main (void)

{
sFilterParam.sFltCoeff.f32RBR0 FRAC32(0.913635972986238 / 2.0);
sFilterParam.sFltCoeff.f32B1 = FRAC32(-1.745585863109291 / 2.0);
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sFilterParam.sFltCoeff.f32B2 = FRAC32(0.913635972986238 / 2.0);
sFilterParam.sFltCoeff.f32A1 FRAC32 (-1.745585863109291 / -2.0);
sFilterParam.sFltCoeff.f32A2 FRAC32(0.827271945972476 / -2.0);

GDFLIB FilterIIR2Init F16 (&sFilterParam) ;

f16InX = FRAC16(0.1);

/* periodically called function */
void Isr (void)
{
fl6Result = GDFLIB FilterIIR2 F16(f16InX, &sFilterParam);

Algorithms in detail

Floating-point version:
#include "gdflib.h"
static float t fltResult;
static float t fltInX;
static GDFLIB_FILTER IIR2 T FLT sFilterParam;
void Isr (void) ;
void main (void)

{
sFilterParam.sFltCoeff.f1tBO = 0.913635972986238f;

sFilterParam.sFltCoeff.f1tBl = -1.745585863109291f;
sFilterParam.sFltCoeff.f1tB2 = 0.913635972986238f;
sFilterParam.sFltCoeff.f1tAl = -1.745585863109291¢f;

sFilterParam.sFltCoeff.f1tA2 = 0.827271945972476%;
GDFLIB FilterIIR2Init FLT (&sFilterParam);
fltInX = 0.1F;

/* periodically called function */

void Isr (void)

{
fltResult = GDFLIB FilterIIR2 FLT (f1tInX, &sFilterParam);

2.4 GDFLIB_FilterMA

The GDFLIB_FilterMA function calculates a recursive form of a moving average filter. For a proper use, it is recommended that

the algorithm is initialized by the GDFLIB_FilterMAInit function, before using the GDFLIB_FilterMA function.

The filter calculation consists of the following equations:

acc(k) = acc(k — 1)+ x(k)
Figure 37.
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k
=250
Figure 38.
acc(k) «— acc(k) — (k)
Figure 39.
where:

» x(k) is the actual value of the input signal

» acc(k) is the internal filter accumulator

* y(k) is the actual filter output

* N, is the number of points in the filter window

The size of the filter window (number of filtered points) must be defined before calling this function, and must be equal to or greater
than 1.

The function returns the filtered value of the input at step k, and stores the difference between the filter accumulator and the output
at step k into the filter accumulator.

2.4.1 Available versions
This function is available in the following versions:

» Fractional output - the output is the fractional portion of the result; the result is within the range <-1 ; 1). The parameters use
the accumulator types.

* Floating-point output - the output is the floating-point result within the type's full range.

The available versions of the GDFLIB_FilterMAInit function are shown in the following table:

Table 8. Function versions

Function name Input Parameters Result Description
type type
GDFLIB_FilterMAInit_F1 |frac16_t | GDFLIB_FILTER_MA_T_A32* |void Input argument is a 16-bit fractional value
6 that represents the initial value of the filter

at the current step. The input is within the
range <-1; 1). The parameters' structure is
pointed to by a pointer.

GDFLIB_FilterMAInit_FL |float_t GDFLIB_FILTER_MA_T_FLT* | void Input argument is a 32-bit single precision
T floating-point value that represents the
initial value of the filter at the current
step. The input is within the full range.
The parameters' structure is pointed to by
a pointer.

The available versions of the GDFLIB_FilterMA function are shown in the following table:
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Function name

Input type Result type Description

Value

Parameter

GDFLIB_FilterMA_F1 | frac16_t
6

GDFLIB_FILTER_MA_T_A32 | frac16_t Input argument is a 16-bit fractional value of the
* input signal to be filtered within the range <-1 ;
1). The parameters' structure is pointed to by a
pointer. The function returns a 16-bit fractional
value within the range <-1; 1).

GDFLIB_FilterMA_FL | float_t
T

GDFLIB_FILTER_MA_T_FLT | float_t Input argument is a 32-bit single precision

* floating-point value of the input signal to be
filtered within the full range. The parameters'
structure is pointed to by a pointer. The function
returns a 32-bit single precision floating-point
value within the full range.

2.4.2 GDFLIB_FILTER_MA_T_A32

Variable name Input Description
type
a32Acc acc32_t | Filter accumulator. The parameter is a 32-bit accumulator type within the range <-65536.0 ;
65536.0). Controlled by the algorithm.
u16Sh uint16_t | Number of samples for averaging filtered points (size of the window) defined as a number of

shifts:
np — 2u165h
ul6Sh=log,np

The parameter is a 16-bit unsigned integer type within the range <0 ; 15>. Set by the user.

2.4.3 GDFLIB_FILTER_MA_T_FLT

Variable name Input Description
type
fltAcc float_t Filter accumulator. Controlled by the algorithm.
fltLambda float_t Number of samples for averaging filtered points (size of the window) defined as an inverted

value:

fltLambda = 75

The parameter is a 32-bit single precision floating-point type within the range (0 ; 1.0>. Set
by the user.

2.4.4 Declaration

The available GDFLIB_FilterMAInit functions have the following declarations:

void GDFLIB FilterMAInit F16(fracl6é t £16InitVal, GDFLIB FILTER MA T A32 *psParam)
void GDFLIB FilterMATnit FLT (float t fltInitVal, GDFLIB FILTER MA T FLT *psParam)
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The available GDFLIB_FilterMA functions have the following declarations:
fracl6_t GDFLIB_FilterMA F16(fracl6_t f16InX, GDFLIB FILTER MA T A32 *psParam)

float t GDFLIB FilterMA FLT(float t f1ltInX, GDFLIB FILTER MA T FLT *psParam)

2.4.5 Function use
The use of GDFLIB_FilterMAInit and GDFLIB_FilterMA functions is shown in the following examples:

Algorithms in detail

Fixed-point version:
#include "gdflib.h"
static fraclé t fl6Result;
static fracl6_t fl6Initval, fl6InX;
static GDFLIB FILTER MA T A32 sFilterParam;
void Isr(void) ;
void main (void)
{

fl16Initval = FRAC16(0.0); /* f1l6Initval = 0.0 */

/* Filter window = 2 ~ 2 = 4 points */
sFilterParam.ul6Sh = 2;

GDFLIB FilterMAInit F16(fl6InitVal, &sFilterParam);
f16InX = FRAC16(0.8);
/* periodically called function */

void Isr (void)

{
fl6Result = GDFLIB FilterMA F16(f16InX, &sFilterParam);

Floating-point version:
#include "gdflib.h"
static float t fltResult;
static float t fltInitVal, fltInX;
static GDFLIB_FILTER MA T FLT sFilterParam;
void Isr (void) ;
void main (void)
{

fltInitval = 0.0F; /* f16Initval = 0.0 */

/* Filter window = 4 points-> fltLambda = 1/4 */
sFilterParam.fltLambda = 0.25F;

GDFLIB FilterMAInit FLT(fltInitVal, &sFilterParam);
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f1tInX = 0.8F;
}

/* periodically called function */
void Isr (void)
{
fltResult = GDFLIB FilterMA FLT(fltInX, &sFilterParam);

2.5 GDFLIB_FilterlIR4

This function calculates the fourth-order direct-form 1 IIR filter.

For a proper use, it is recommended to initialize the algorithm by the GDFLIB_FilterlIR4Init function, before using the
GDFLIB_FilterlIR4 function. The GDFLIB_FilterlIR4Init function initializes the buffer and coefficients of the fourth-order IIR filter.

The GDFLIB_FilterlIR4 function calculates the fourth-order infinite impulse response (lIR) filter. The IIR filters are also called
recursive filters, because both the input and the previously calculated output values are used for calculation. This form of feedback
enables the transfer of energy from the output to the input, which leads to an infinitely long impulse response (lIR). A general form
of the IIR filter (expressed as a transfer function in the Z-domain) is described as follows:

H(z) = B@) _ botbiz byz 2+ . +byz N
@ Az) ~ Trag Hayz 2+.tayz N

Figure 40.

where N denotes the filter order. The fourth-order IIR filter in the Z-domain is expressed as follows:

HE)- B@) _ by+biz 1+ byz 2+ bz 3+ bz
Az)  1+azltaz2+az3+a,z4

Figure 41.

which is transformed into a time-domain difference equation as follows:

(k) = box(k)+ bk — 1)+ byx(k — 2)+ byx(k — 3)+ byx(k — 4)- ayy(k — 1)- ayp(k — 2)- asy(k — 3)- agy(k — 4)
Figure 42.

The filter difference equation is implemented directly in the digital signal controller, as given in Equation 3; this equation represents
a direct-form 1 fourth-order IIR filter, as shown in Figure 43.
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Figure 43. Direct-form 1 fourth-order IIR filter

The coefficients of the filter shown in Figure 3-1 can be designed to meet the requirements for the fourth-order low-pass filter (LPF),
high-pass filter (HPF), band-pass filter (BPF), or band-stop filter (BSF). The coefficient quantization error can be ignored in the

case of a fourth-order filter due to a finite precision arithmetic. A higher-order LPF or HPF can be obtained by connecting a number
of fourth-order filters in series. The number of connections gives the order of the resulting filter.

Define the filter coefficients before calling this function. As some coefficients can be greater than 1 (and lesser than 8), the
coefficients are scaled down (divided) by 8.0 for the fractional version of the algorithm. For a faster calculation, the A coefficients
are sign-inverted. The function returns the filtered value of the input in step k, and stores the input and output values in the step
k into the filter buffer.

2.5.1 Available versions

This function is available in the following versions:
» Fractional output - the output is the fractional portion of the result; the result is within the range <-1; 1).
 Floating-point output - the output is the floating-point result within the type's full range.

The available versions of the GDFLIB_FilterlIR4Init function are shown in the following table:

Table 10. Init function versions

Function name Parameters Result Description
type
GDFLIB_FilterlIR4Init_F16 | GDFLIB_FILTER_IIR4_T_F32* |void Filter initialization (reset) function. The parameters'

structure is pointed to by a pointer.

GDFLIB_FilterlIR4Init_FLT | GDFLIB_FILTER_IIR4_T_FLT* |void Filter initialization (reset) function. The parameters'
structure is pointed to by a pointer.

The available versions of the GDFLIB_FilterlIR4 function are shown in the following table:
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Table 11. Function versions

Function name Input Parameters Result Description
type type

GDFLIB_FilterllR4_F16 |frac16_t | GDFLIB_FILTER_IIR4_T_F32* |frac16_t |Input argumentis a 16-bit fractional value
of the input signal to be filtered within the
range <-1; 1). The parameters' structure
is pointed to by a pointer. The function
returns a 16-bit fractional value within the
range <-1; 1).

GDFLIB_FilterllR4_FLT | float_t GDFLIB_FILTER_IIR4_T_FLT* |float_t Input argument is a 32-bit single precision
floating-point value of the input signal
within the full range. The parameters'
structure is pointed to by a pointer. The
function returns a 32-bit single precision
floating-point value within the full range.

2.5.2 GDFLIB_FILTER_IIR4_T_F32

Variable name Input type Description
sFltCoeff GDFLIB_FILTER_IIR4_COEFF_T_F32* Substructure containing filter coefficients.
f32FItBfrY[4] frac32_t Internal buffer of y-history. Controlled by the algorithm.
f16FItBfrX[4] frac16_t Internal buffer of x-history. Controlled by the algorithm.

2.5.3 GDFLIB_FILTER_IIR4_COEFF_T_F32

Variable name Type Description
f32B0 frac32_t | BO coefficient of the 1IR4 filter. Set by the user, and must be divided by 8.
f32B1 frac32_t | B1 coefficient of the 1IR4 filter. Set by the user, and must be divided by 8.
f32B2 frac32_t | B2 coefficient of the 1IR4 filter. Set by the user, and must be divided by 8.
f32B3 frac32_t | B3 coefficient of the 1IR4 filter. Set by the user, and must be divided by 8.
f32B4 frac32_t | B4 coefficient of the 1IR4 filter. Set by the user, and must be divided by 8.
f32A1 frac32_t | A1 (sign-inverted) coefficient of the IIR4 filter. Set by the user, and must be divided by -8

(negative eight).

f32A2 frac32_t | A2 (sign-inverted) coefficient of the 1IR4 filter. Set by the user, and must be divided by -8
(negative eight).

f32A3 frac32_t | A3 (sign-inverted) coefficient of the 1IR4 filter. Set by the user, and must be divided by -8
(negative eight).

f32A4 frac32_t | A4 (sign-inverted) coefficient of the 1IR4 filter. Set by the user, and must be divided by -8
(negative eight).
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Variable name

Input type

Description

sFltCoeff GDFLIB_FILTER_IIR4_COEFF_T_FLT* Substructure containing filter coefficients.
fIitFItBfrY[4] float_t Internal buffer of y-history. Controlled by the algorithm.
fItFItBfrX[4] float_t Internal buffer of x-history. Controlled by the algorithm.

2.5.5 GDFLIB_FILTER_IIR4_COEFF_T_FLT

Variable name Type Description
fltBO float_t BO coefficient of the 1IR4 filter. Set by the user.
fltB1 float_t B1 coefficient of the IIR4 filter. Set by the user.
fltB2 float_t B2 coefficient of the IIR4 filter. Set by the user.
fltB3 float_t B3 coefficient of the IIR4 filter. Set by the user.
fltB4 float_t B4 coefficient of the 1IR4 filter. Set by the user.
fltA1 float_t A1 (sign-inverted) coefficient of the IIR4 filter. Set by the user.
fltA2 float_t A2 (sign-inverted) coefficient of the [IR4 filter. Set by the user.
fItA3 float_t A3 (sign-inverted) coefficient of the I[IR4 filter. Set by the user.
fltA4 float_t A4 (sign-inverted) coefficient of the IIR4 filter. Set by the user.

2.5.6 Declaration

The available GDFLIB_FilterlIR4Init functions have the following declarations:

void GDFLIB FilterIIR4Init F16(GDFLIB FILTER IIR4 T F32 *psParam)
void GDFLIB FilterIIR4Init FLT (GDFLIB FILTER IIR4 T FLT *psParam)

The available GDFLIB_FilterlIR4 functions have the following declarations:

fracl6é_t GDFLIB FilterIIR4 Fl16(fraclé t f16InX, GDFLIB FILTER IIR4 T F32 *psParam)
float t GDFLIB FilterIIR4 FLT (float t f1ltInX, GDFLIB FILTER ITR4 T FLT *psParam)

2.5.7 Calculation of filter coefficients

There are plenty of methods for the coefficients calculation. The following example shows the use of Matlab to set up a band-pass
filter with the 10000 Hz sampling frequency, 1000 Hz pass frequency, and 250 Hz bandwidth. The maximum passband ripple is

3 dB, and the attenuation is 20 dB.

[

% sampling frequency 10000 Hz, band pass
Ts = 1 / 10000

% center pass frequency 2000 Hz
Fc = 2000

% attenuation 20 dB
Rs = 20
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% bandwidth 250 Hz

Fbw = 250
% max. passband ripple 3 dB
Rp = 3

% checking order of the filter
buttord(2 * Ts * [Fc - Fbw /2 Fc + Fbw / 2], 2 * Ts *
4, the filter is achievable with the 4th order

n = [Fc - Fbw Fc + Fbw],

% n = i.e.
% getting the filter coefficients
[b, a] = butter(n / 2, 2 * Ts * [Fc - Fbw /2 Fc + Fbw / 2])

the coefs are:

o0 o

b0 = 0.005542717210281, bl = 0, b2 = -0.011085434420561, b3 = 0, b4 =
0.005542717210281
% a0 = 1.0000, al = -1.171272075750262, a2 = 2.122554479822350, a3 =

-1.047780658093187,
0.800802646665706

oo

a4 =

Rp,

Algorithms in detail

Rs)

The filter response is shown in Figure 44.

Magnitude (dB) and Phass Responses

Magnitude (¢B8)

28718

2.2329
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25 3
Frequency (kHz)

Figure 43. Filter response

2.5.8 Function use

The use of the GDFLIB_FilterlIR4Init and GDFLIB_FilterlIR4 functions is shown in the following examples. The filter uses the

above-calculated coefficients:

Fixed-point version:

#include "gdflib.h"
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static fracl6é t fl6Result;
static fraclé6 t f16InX;
static GDFLIB FILTER IIR4 T F32 sFilterParam;

void Isr(void) ;

void main (void)

{

/* periodically called function */

sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.

sFltCoeff.
sFltCoeff.
sFltCoeff.
sFltCoeff.
sFltCoeff.
sF1ltCoeff.
sFltCoeff.
sFltCoeff.
sFltCoeff.

£32B0
£32B1
£32B2
£32B3
£32B4
£32A1
£32A2
£32A3
£32A4

FRAC32 (0.005542717210281 / 8.0);
FRAC32 (0.0 / 8.0);

FRAC32 (-0.011085434420561 / 8.0);
FRAC32 (0.0 / 8.0);

FRAC32 (0.005542717210281 / 8.0);
FRAC32 (-1.171272075750262 / -8.0);
FRAC32(2.122554479822350 / -8.0);
FRAC32 (-1.047780658093187 / -8.0);
FRAC32 (0.800802646665706 / -8.0);

GDFLIB FilterIIR4Init F16 (&sFilterParam);

f16InX = FRA

void Isr (void)

{

fl6Result

Cl6(0.1);

= GDFLIB FilterIIR4 F16(f16InX,

&sFilterParam) ;

Algorithms in detail

Floating-point version:

#include "gdflib.h"

static float t fltResult;
static float_t fltInX;
static GDFLIB FILTER IIR4 T FLT sFilterParam;

void Isr(void) ;

void main (void)

{

/* periodically called function */

sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.
sFilterParam.

sF1ltCoeff
sFltCoeff
sFltCoeff
sFltCoeff
sFltCoeff
sF1ltCoeff
sFltCoeff
sFltCoeff
sFltCoeff

.£1tBO
.f1tB1

.f1tB2 =

.f1tB3
.f1tB4
.f1tAl
.f1tA2
.f1tA3
.f1tA4

0.005542717210281F;

0.0F;

-0.011085434420561F;

0.0F;

0.005542717210281F;
-1.171272075750262F;
2.122554479822350F;
-1.047780658093187F;
0.800802646665706F;

GDFLIB FilterIIR4Init FLT (&sFilterParam);

fltInX = 0.1

void Isr (void)

F;
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fltResult = GDFLIB FilterIIR4 FLT (f1tInX, &sFilterParam);

2.6 GDFLIB_FilterMA

The GDFLIB_FilterMA function calculates a recursive form of a moving average filter. For a proper use, it is recommended that
the algorithm is initialized by the GDFLIB_FilterMAInit function, before using the GDFLIB_FilterMA function.

The filter calculation consists of the following equations:

acc(k) = acc(k — 1)+ x(k)

Figure 44.
acc(k
=248
Figure 45.
acc(k) «— acc(k) — (k)
Figure 46.
where:

» x(k) is the actual value of the input signal

» acc(k) is the internal filter accumulator

* y(k) is the actual filter output

* N, is the number of points in the filter window

The size of the filter window (number of filtered points) must be defined before calling this function, and must be equal to or greater
than 1.

The function returns the filtered value of the input at step k, and stores the difference between the filter accumulator and the output
at step k into the filter accumulator.

2.6.1 Available versions

This function is available in the following versions:

» Fractional output - the output is the fractional portion of the result; the result is within the range <-1 ; 1). The parameters use
the accumulator types.

* Floating-point output - the output is the floating-point result within the type's full range.

The available versions of the GDFLIB_FilterMAInit function are shown in the following table:

Table 12. Function versions

Function name Input Parameters Result Description
type type
GDFLIB_FilterMAInit_F1 |frac16_t | GDFLIB_FILTER_MA_T_A32* |void Input argument is a 16-bit fractional value
6 that represents the initial value of the filter
at the current step. The input is within the

Table continues on the next page...
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Function name

Input
type

Parameters

Result Description
type

range <-1; 1). The parameters' structure is
pointed to by a pointer.

T

GDFLIB_FilterMAInit_FL |float_t

GDFLIB_FILTER_MA_T_FLT* |void

Input argument is a 32-bit single precision
floating-point value that represents the
initial value of the filter at the current
step. The input is within the full range.
The parameters' structure is pointed to by
a pointer.

The available versions of the GDFLIB_FilterMA function are shown in the following table:

Table 13. Function versions

Function name

Input type

Value

Parameter

Result type

Description

6

GDFLIB_FilterMA_F1 | frac16_t

GDFLIB_FILTER_MA_T_A32

frac16_t

Input argument is a 16-bit fractional value of the
input signal to be filtered within the range <-1;
1). The parameters' structure is pointed to by a
pointer. The function returns a 16-bit fractional
value within the range <-1; 1).

T

GDFLIB_FilterMA_FL | float_t

*

GDFLIB_FILTER_MA_T_FLT

float_t

Input argument is a 32-bit single precision
floating-point value of the input signal to be
filtered within the full range. The parameters'
structure is pointed to by a pointer. The function
returns a 32-bit single precision floating-point
value within the full range.

2.6.2 GDFLIB_FILTER_MA_T_A32

shifts:

Variable name Input Description
type
a32Acc acc32_t | Filter accumulator. The parameter is a 32-bit accumulator type within the range <-65536.0 ;
65536.0). Controlled by the algorithm.
u16Sh uint16_t | Number of samples for averaging filtered points (size of the window) defined as a number of

np=2416h

ul6Sh=log,np

The parameter is a 16-bit unsigned integer type within the range <0 ; 15>. Set by the user.
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2.6.3 GDFLIB_FILTER_MA_T_FLT
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Variable name Input Description
type
fltAcc float_t Filter accumulator. Controlled by the algorithm.

fltLambda
value:

fltLambda= 75

by the user.

float_t Number of samples for averaging filtered points (size of the window) defined as an inverted

The parameter is a 32-bit single precision floating-point type within the range (0 ; 1.0>. Set

2.6.4 Declaration

The available GDFLIB_FilterMAInit functions have the following declarations:

void GDFLIB FilterMAInit F16(fracl6 t f16InitVal, GDFLIB FILTER MA T A32 *psParam)
void GDFLIB FilterMAInit FLT (float t fltInitVal, GDFLIB FILTER MA T FLT *psParam)

The available GDFLIB_FilterMA functions have the following declarations:

fracl6 t GDFLIB FilterMA Fl6(fraclé t fl16InX, GDFLIB FILTER MA T A32 *psParam)
float t GDFLIBiFilterMAiFLT(floatit fltInX, GDFLIB FILTER MA T FLT *psParam)

2.6.5 Function use
The use of GDFLIB_FilterMAInit and GDFLIB_FilterMA functions is shown in the following examples:

Fixed-point version:
#include "gdflib.h"
static fracl6é t fl6Result;
static fracl6_t fl6Initval, fl6InX;
static GDFLIB_FILTER MA T A32 sFilterParam;
void Isr (void) ;
void main (void)
{

fl6Initval = FRAC16(0.0); /* fl6Initval = 0.0 */

/* Filter window = 2 ~ 2 = 4 points */
sFilterParam.ul6Sh = 2;

GDFLIB FilterMAInit F16 (fl6InitVal, &sFilterParam);
f16InX = FRAC16(0.8);
/* periodically called function */

void Isr (void)

{
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fl6Result = GDFLIB FilterMA F16(f16InX, &sFilterParam);
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Floating-point version:
#include "gdflib.h"
static float t fltResult;
static float t fltInitVal, fltInX;
static GDFLIB_FILTER MA T FLT sFilterParam;
void Isr (void) ;
void main (void)
{

fltInitval = 0.0F; /* f16InitVal = 0.0 */

/* Filter window = 4 points-> fltLambda = 1/4 */
sFilterParam.fltLambda = 0.25F;

GDFLIB FilterMAInit FLT(fltInitVal, &sFilterParam);
fl1tInX = 0.8F;
/* periodically called function */

void Isr (void)

{
fltResult = GDFLIB FilterMA FLT (fl1tInX, &sFilterParam);
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Appendix A
Library types

A.1 bool_t

The bool_t type is a logical 16-bit type. It is able to store the boolean variables with two states: TRUE (1) or FALSE (0). Its definition

is as follows:
typedef unsigned short bool t;

The following figure shows the way in which the data is stored by this type:

Table 14. Data storage

15 14 13 12 11 10 9 8 7 6 5 0
Value Unused Logi
cal
TRUE O loflo|o|o|oOo|O|]O]O|O]|oO 1
0 0 0
FALSE 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0

To store a logical value as bool_t, use the FALSE or TRUE macros.

A.2 uint8_t

The uint8_t type is an unsigned 8-bit integer type. It is able to store the variables within the range <0 ; 255>. Its definition is

as follows:
typedef unsigned char uint8_t;

The following figure shows the way in which the data is stored by this type:

Table 15. Data storage

Value Integer

255 1 1 1 1 1

Table continues on the next page...

GDFLIB User's Guide, Rev. 5, 01 November 2021

User Guide

50/ 61



NXP Semiconductors

Library types
Table 15. Data storage (continued)
11 0 0 0 1 1
0
124 0 1 1 1 0
7
159 1 0 0 1 1
9
A.3 uint16_t

The uint16_t type is an unsigned 16-bit integer type. It is able to store the variables within the range <0 ; 65535>. Its definition is

as follows:

typedef unsigned short uintlé6 t;

The following figure shows the way in which the data is stored by this type:

Table 16. Data storage

15 14 13 12 1" 10 7 0
Value Integer

65535 1 1 1 1 1 1 1 1
F

5 0 0 0 0 0 0 0 1
0

15518 0 0 1 1 1 1 1 0
3

40768 1 0 0 1 1 1 0 0
9
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A4 uint32_t

Library types

The uint32_t type is an unsigned 32-bit integer type. Itis able to store the variables within the range <0 ; 4294967295>. Its definition

is as follows:

typedef unsigned long uint32 t;

The following figure shows the way in which the data is stored by this type:

Table 17. Data storage

31 24 23 16 15 7 0
Value Integer
4294967295 F F F F
2147483648 8 0 0 0
55977296 0 3 2 0
3451051828 C D D 4
A.5 int8_t

The int8_t type is a signed 8-bit integer type. It is able to store the variables within the range <-128 ; 127>. Its definition is as follows:

typedef char int8 t;

The following figure shows the way in which the data is stored by this type:

Table 18. Data storage

Table continues on the next page...
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Value Sign Integer

127 0 1 1 1 1
7

-128 1 0 0 0 0
8

60 0 0 1 1 0
3
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Table 18. Data storage (continued)

-97 1 0 0 1 1 1 1 1

A.6 int16_t

The int16_t type is a signed 16-bit integer type. It is able to store the variables within the range <-32768 ; 32767>. Its definition is
as follows:

typedef short intl6 t;

The following figure shows the way in which the data is stored by this type:

Table 19. Data storage

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
Value Sign Integer
32767 0 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
7 F F F
-32768 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
8 0 0 0
15518 0 0 1 1 1 1 0 0 1 0 0 1 1 1 1 0
3 Cc 9 E
-24768 1 0 0 1 1 1 1 1 0 1 0 0 0 0 0 0
9 F 4 0
A.7 int32_t

The int32_t type is a signed 32-bit integer type. It is able to store the variables within the range <-2147483648 ; 2147483647>. Its
definition is as follows:

typedef long int32 t;

The following figure shows the way in which the data is stored by this type:

Table 20. Data storage

Table continues on the next page...
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Table 20. Data storage (continued)
31 24 23 16 15 8 7 0
Value S Integer
2147483647 7 F F F F F F F
-2147483648 8 0 0 0 0 0 0 0
55977296 0 3 5 6 2 5 5 0
-843915468 C D B 2 D F 3 4
A.8 frac8_t

The frac8_t type is a signed 8-bit fractional type. It is able to store the variables within the range <-1 ; 1). Its definition is as follows:
typedef char frac8 t;

The following figure shows the way in which the data is stored by this type:

Table 21. Data storage

7 6 5 4 3 2 1 0
Value Sign Fractional
0.99219 0 1 1 1 1 1 1 1
7 F
-1.0 1 0 0 0 0 0 0 0
8 0
0.46875 0 0 1 1 1 1 0 0
3 C
-0.75781 1 0 0 1 1 1 1 1
9 F

To store a real number as frac8_t, use the FRAC8 macro.
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A.9 frac16_t

The frac16_t type is a signed 16-bit fractional type. It is able to store the variables within the range <-1 ; 1). Its definition is
as follows:

typedef short fraclé6 t;

The following figure shows the way in which the data is stored by this type:

Table 22. Data storage

%5 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
Value Sign Fractional
0.99997 0 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
7 F F F
-1.0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
8 0 0 0
0.47357 0 0 1 1 1 1 0 0 1 0 0 1 1 1 1 0
3 Cc 9 E
-0.75586 1 0 0 1 1 1 1 1 0 1 0 0 0 0 0 0
9 F 4 0

To store a real number as frac16_t, use the FRAC16 macro.

A.10 frac32_t

The frac32_t type is a signed 32-bit fractional type. It is able to store the variables within the range <-1; 1). Its definition is
as follows:

typedef long frac32 t;

The following figure shows the way in which the data is stored by this type:

Table 23. Data storage

31 24 23 16 15 8 7 0

Value S Fractional

0.9999999995

~
M

F F F F F F

Table continues on the next page...
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Library types
Table 23. Data storage (continued)
-1.0 8 0 0 0 0 0 0 0
0.02606645970 0 3 5 6 2 5 5 0
-0.3929787632 C D B 2 D F 3 4

To store a real number as frac32_t, use the FRAC32 macro.

A.11 acc16_t

The acc16_t type is a signed 16-bit fractional type. It is able to store the variables within the range <-256 ; 256). Its definition is
as follows:

typedef short accl6 t;

The following figure shows the way in which the data is stored by this type:

Table 24. Data storage

15 14 13 12 1" 10 9 8 7 6 5 4 3 2 1 0

Value Sign Integer Fractional

255.9921875 0 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1

7 F F F

-256.0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
8 0 0 0

1.0 0 0 0 0 0 0 0 0 1 0 0 0 0 0 0 0
0 0 8 0

-1.0 1 1 1 1 1 1 1 1 1 0 0 0 0 0 0 0
F F 8 0

13.7890625 0 0 0 0 0 1 1 0 1 1 1 0 0 1 0 1

8971875 | 1 | 1 o |1 |0|0|1|1]o0]O0o|1|]O0o|]O0O|1]|0]0O

GDFLIB User's Guide, Rev. 5, 01 November 2021
User Guide 56 / 61




NXP Semiconductors

Library types

To store a real number as acc16_t, use the ACC16 macro.

A.12 acc32_t

The acc32_t type is a signed 32-bit accumulator type. It is able to store the variables within the range <-65536 ; 65536). Its
definition is as follows:

typedef long acc32 t;

The following figure shows the way in which the data is stored by this type:

Table 25. Data storage

31 24 23 16 15 8 7 0

Value S Integer Fractional
65535.999969 7 F F F F F F F
-65536.0 8 0 0 0 0 0 0 0
1.0 0 0 0 0 8 0 0 0
-1.0 F F F F 8 0 0 0
23.789734 0 0 0 B E 5 1 6
-1171.306793 F D B 6 5 8 B c

To store a real number as acc32_t, use the ACC32 macro.

A.13 FALSE
The FALSE macro serves to write a correct value standing for the logical FALSE value of the bool_t type. Its definition is as follows:

#define FALSE ((bool t)0)

#include "mlib.h"

static bool t bval;

void main (void)
{

bVal = FALSE; /* bVal = FALSE */
}
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A.14 TRUE

The TRUE macro serves to write a correct value standing for the logical TRUE value of the bool_t type. Its definition is as follows:

#define TRUE ((bool t)1)

#include "mlib.h"
static bool t bval;
void main (void)

{
bval = TRUE; /* bval = TRUE */

A.15 FRACS8

The FRAC8 macro serves to convert a real number to the frac8_t type. Its definition is as follows:

#define FRAC8 (x) ((frac8 t) ((x) < 0.9921875 ? ((x) >= -1 ? (x)*0x80 : 0x80) : O0x7F))

The input is multiplied by 128 (=27). The output is limited to the range <0x80 ; 0x7F>, which corresponds to <-1.0 ; 1.0-27>.

#include "mlib.h"
static frac8_t f8val;
void main (void)

{
f8val = FRAC8(0.187); /* f8Val = 0.187 */

A.16 FRAC16

The FRAC16 macro serves to convert a real number to the frac16_t type. Its definition is as follows:
#define FRAC16 (x) ((fracl6 t) ((x) < 0.999969482421875 2 ((x) >= -1 2 (x)*0x8000 : 0x8000) : Ox7FFF))

The input is multiplied by 32768 (=215). The output is limited to the range <0x8000 ; 0x7FFF>, which corresponds to
<-1.0; 1.0-21%>,

#include "mlib.h"
static fracle6_t flé6vVal;
void main (void)

{
fl6val = FRAC16(0.736); /* fleval = 0.736 */
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A.17 FRAC32
The FRAC32 macro serves to convert a real number to the frac32_t type. Its definition is as follows:
#define FRAC32 (x) ((frac32 t) ((x) < 1 2 ((x) >= -1 ? (x)*0x80000000 : 0x80000000) : Ox7FFFFFEF))

The inputis multiplied by 2147483648 (=231). The output is limited to the range <0x80000000 ; 0x7FFFFFFF>, which corresponds
to <-1.0; 1.0-2731>.

#include "mlib.h"
static frac32 t f32Val;
void main (void)

{
£32val = FRAC32(-0.1735667) ; /* £32val = -0.1735667 */

A.18 ACC16

The ACC16 macro serves to convert a real number to the acc16_t type. Its definition is as follows:
#define ACCL6(x) ((accl6_t) ((x) < 255.9921875 2 ((x) >= -256 2 (x)*0x80 : 0x8000) : Ox7FFF))

The input is multiplied by 128 (=27). The output is limited to the range <0x8000 ; 0x7FFF> that corresponds to
<-256.0 ; 255.9921875>.

#include "mlib.h"
static accl6_t aléval;
void main (void)

{
aléval = ACC16(19.45627) ; /* alé6val = 19.45627 */

A.19 ACC32

The ACC32 macro serves to convert a real number to the acc32_t type. Its definition is as follows:

#define ACC32 (x) ((acc32 t) ((x) < 65535.999969482421875 ? ((x) >= -65536 ? (x)*0x8000 : 0x80000000)
0x7FFFFFFF))

The input is multiplied by 32768 (=219). The output is limited to the range <0x80000000 ; 0x7FFFFFFF>, which corresponds to
<-65536.0 ; 65536.0-21%>,

#include "mlib.h"
static acc32_t a32val;

void main (void)
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a32Val = ACC32(-13.654437); /* a32val = -13.654437 */
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