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1 Purpose

This lab document will familiarize you with TWR-K20D50M board and development tools.
You will learn the full features of the TWR-K20D50M demos that are pre-programmed onto your Tower

module. You will learn how to access the source code using development tools IAR 6.3 or the
CodeWarrior 10.2

2 Getting known the board

Main components of the TWR-K20D50M are shown in following picture.

Buzzer Enable

General Purpose LLLLCLLLCECEOUAAUARRERO CEOARELERRARD RS |l] | SW1 (Resat)
Tower Plug-In , L rpE T S s—
_ Tk AT T Touch TWRPI
Microphone ; ik i S el KT Socket
Potentiomater — Enable Options 2
Power/OSJTAG g e (505, W oo fo N s - L -LED Green
Mini-AB USB /o - and BLue
Connector
LEDYTouch
swa2 Buttons
SWa
OSJTAG
K20 MicroUSB Connector

Connector T 1':.
Device Enable

JME0 BDM Options 1

IM60 Bootloader ——riitiihll ek REEREET AT Vil
Enable Option Selector
Board Power

Selector

3 Download and Install Software and Tools

Get the installation software and documentation under “Jump Start Your Design” at
www.freescale.com/TWR-K20D50M

Install the P&E Micro Kinetis Tower Toolkit to install the OSJTAG and USB-to-Serial drivers.
pemicro osbdm osjtag tower toolkit.exe

Note: Please follow instructions on section 12 before using of CW or IAR tools.

TWR-K20D50M Quick Start Demo Lab Guide Page 3 of 23


http://www.freescale.com/TWR-K20D50M
http://www.pemicro.com/downloads/download_file.cfm?download_id=332

h o
g |

freescale

semiconductor

4 Configure Hardware

1) Make sure jumpers are set in default position as shown in following picture, for more details see
TWR-K20D50M Jumper options

Jp7
K EE-[’}H

X o,
T ) 1 -
e &5

Tl S ol

!!Jrll!!, ﬂl-rn-_u -u-- |

FEY, Sl

Sl e e T T

2) Connect one end of the USB cable to the PC and the other end to the Power/OSJTAG mini-B
connector on the TWR-K20D50M module. Allow the PC to automatically configure the USB
drivers if needed.

3) Allow the PC to automatically configure the OSJTAG drivers used for debugging and the serial-to-
USB feature.
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5 Run the Demos

TWRK20D50M Demo software
This code is pre-programmed in your TWRK20D50M, and shows some of the features of the K20 family
and the TWRK20D50M board. Following table show how different modules are used in this application

Table 1 K20 Modules used on TWRK20 Demo software

Module Function Details
ADC Reads 2 signals 12 bits mode
Potentiometer Hardware triggered
Microphone
PDB Creates a sampling frequency of 8 kHz for the ADC Continous mode
converter at 8 Khz
Triggers ADCO
DMA Store microphone readings in a double buffer of Interrupt when 128 samples are
128 samples each sampled and perform
calculation of FFT, and filters.
DSP Calculates FFT of 128 samples and magnitude of Uses CMSIS integrated library in
each harmonic IAR 6.3
12C Reads accelerometer, acceleration in each axes x, y, | K20 calculates tilt angle and fall
and z detection based on axes
acceleration.
PIT CHO Generates a 1 msec periodic interrupt
CH1 Generates a 125 msec periodic interrupt
GPIO 4 LED, 2 Push button
HSCMP Reads signal for IR receiver, and output is DAC6 used as HSCMP minus
connected to UARTO receiver input, IR receiver connected to
HSCMP plus input,
MCG+0SC | Oscillator of 8MHz crystal, MCG creates a 50 MHz
signal from 8MHz crystal with the PLL
CMT Create a 40KHz carrier frequency, and 600 Baud
modulation signal for the IR transmitter.
UARTO Receives signal from HSCMP(IR receiver) 600,8,n,1 Inverted reception
TSI Configured to read 2 Electrodes
RTC A real time clock (seconds only) based on 32Khz
Crystal
JTAG Interface of debugging and programming of the
parts.
Programmed through the OSITAG
UART1 User communication interface 38400,8,n,1
FTMO Generate buzzer frequency

TWR-K20D50M Quick Start Demo Lab Guide
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5.1 Buzzer Demo

Press reset button, the board will sound 3 tones.

Note: Different tests use the buzzer as feedback; you can disable the buzzer by
removing jumper J1 (BUZZER).

5.2 Switch Demo

Press SW3, a tone is generated and red led glows
Press SW2, a tone is generated.

5.3 Touch Demo

Touch Electrode 2, a tone is generated and orange LED glows.
Touch Electrode 3, a tone is generated and yellow LED glows.

5.4 Accelerometer Demo
Tilt the board slowly back and forth to hear different tones depending on tilt angle.

5.5 Microphone Demo

Whistle a tone for 1 or 2 seconds, the board will respond with a high tone.
Clap or snap near the microphone, the board will respond with a low tone

5.6 Terminal Demo

Open the P&E Terminal Utility by clicking on Start Menu->Programs->P&E OSBDM OSJTAG Virtual Serial

Toolkit->Utilities->Terminal Utility.
Make sure USB COM is selected with 115200 baud, and click on the “Open Serial Port” button.

. Terminal Window application v2.05

Fart P%E Homepage
Baud : R
_ Open Sernial Port

FPar

micro

Terminal Window: Clear indow |
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Press reset button.
The terminals will display a RESET message and prompt:

TWRK20D50M Demo Software Rev 1.4

In the terminal program, there will be a shell prompt after you hit the Enter key. Type “help” to see the list

of commands.

5.6.1 Display command

Most of the commands included in this demo can be displayed with command “disp” and a number,
as shown below.

K20_Demo >disp N

Table 2 List of available options for “disp” command

Command display Description
disp 0 Cancel display > Abort current display and
prompt for new command
disp 1 rtc Rtc nnn Shows RTC second counter
disp 2 Buttons B nn Show buttons/electrodes that
are pressed
disp 3 leds LEDs nn Test 4 leds
disp 4 Accelerometer xy=[ 14]<-517, xz=[ 49]<-220, Show [magnitude] and <angle in
test yz =[ 48]<-149 degrees*10
Disp 5 IR test IRport: Tx= 2, Rx= 0 Echoes the transmitted IR
Disp 6 ADC test ADC POT = 1425
Disp 7 FFT test fft[ 0]18824,[ 1] 0,[ 2] 31,[ 3]
0,[4] 31,[5] o,[6] O,([7] O,
[8] O,
Disp 8 DMA status Status DMA 416, O

See following section for more details:

Note: some display modes are overwriting the terminal screen, when change to other
display mode, just type the new command, even if it is not properly showed the
command will be performed.

TWR-K20D50M Quick Start Demo Lab Guide
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5.6.2 RTC Demo

Type command: K20_Demo >disp 1
Terminal will display seconds since last reset, and seconds elapsed since VBAT has been powered.

RTC 953 ; elapsed time with Vbat 1955

5.6.3 ADC Demo (Potentiometer)
Type command:  K20_Demo >disp 6

Terminal will display the value of the ADC connected to the potentiometer.
ADC POT = 1425

5.6.4 LED Demo

Type command: K20 _Demo >disp 3
Terminal will display a counter and the 4 leds will be turning on/off according to the counter.
LEDs n

5.6.5 Tilt detection / Accelerometer Demo

Buzzer beeps at different tones depending on how tilt is the board, and terminal display the angle and

o"_ 7

magnitude respect with gravity “g
xy=[ 3]< 0, xz=[65]< 0, yz=[65]< O,
where:

[magnitude] relative magnitude
Angle in degrees*10 from -90.0 to 90.0 degrees

5.6.6 Infra Red port Demo (IR demo)

Terminal will display a counter and every time the counter increase, the number is transmitted by the IR
port, if the IR signal is reflected the receiver will echo the same value. In case there is not reception the
value displayed in reception is zero or the latest value received.

Note: you can use a piece of white paper to reflect the IR signal.

Jumper configuration

Jumper configuration for IR demo.
J9 ON (default OFF)

TWR-K20D50M Quick Start Demo Lab Guide Page 8 of 23
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J7 ON (default OFF)
J4 OFF(default ON)

Note: remember to re-place jumpers at default configuration once this demo is
completed.

Type command: K20 _Demo >disp 5
IR port: Tx=002, Rx=000; IR signalis not being received,

IR port: Tx=005, Rx=005; IR signal being received.

5.6.7 FFT

Microphone is sampled at 8000Hz, every 128 samples a FFT is performed, the result of the FFT is used
for tone detection, first harmonics of FFT are shown with following command

Type command: K20 _Demo >disp 7
fft[1] o,[2] O,[3] 0,[4] O,[5] O[6] 0,[7] O,[8] O,

where:

XX[n]

[n] number of harmonic.

XX magnitude of harmonic n.

Note: FFT is based on CMSIS library integrated in IAR embedded workbench,
because of that this demo is only available with 1AR.

6 Directory Structure

The directory structure for the TWRK20D50M demo code and other bare metal examples has three
main folders—build, src and util. The build folder contains all development toolchain specific files. All
of the source code files are in the src directory. The util folder includes compiler patches referenced in
this document.

The source tree is broken up as follows:

e src\common\ -Common utilities such as compiler startup are provided in this directory

e src\cpu\ - CPU specific initialization and header files here

e src\drivers\ - Drivers for some of the various peripherals are provided here.

e src\platforms\ - Each supported platform has a header file that defines board specific
information, such as the input clock frequency used for that board.

e src\projects\ - This directory holds all the individual example project source code

e src\semihosting)\ - Utilities to handle native compiler support for printf and scanf

TWR-K20D50M Quick Start Demo Lab Guide Page 9 of 23
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7 Toolchain Support

Currently the IAR 6.30 and CW10.2 tool chains are supported.

7.1 IAR Embedded Workbench

IAR workspace, project, linker, and support files are provided in kinetis-sc\build\iar. Each example has
its own directory and within that directory is a workspace file (.eww) that will load the supported
projects (usually one project for each supported hardware platform). Each project contains several
configuration options that can be selected using a drop menu. The configuration support different link
targets for different Kinetis memory configurations (e.g. RAM_16KB or FLASH_128KB_PFLASH).

7.2 CodeWarrior 10.2

CodeWarrior 10.2 project files can be found in the kinetis-sc\build\cw folder. Again, each example has
its own directory.

8 Other Examples

There are many example projects that highlight the operation of different modules. The "hello_world"
demo is the simplest example, and this project is the baseline used for developing other examples. The
hello_world project will perform basic initialization for the board and then display the device
configuration information on the terminal (default baud rate is 115200).

Each example includes a readme.txt file in the workspace or project directory that gives a description
of what the project does and describes any configuration needed to use it.

9 Update OSJTAG

The TWR-K20D50M includes the OSITAG circuit. By default all of the demo projects are setup to use
OSJTAG to download and debug code. The OSJTAG circuit is also used as the primary serial
communication port.

Open Source JTAG (also known as OSBDM on ColdFire tower boards) allows a user to program, debug,
and get serial data from Kinetis devices via a USB cable. The firmware runs on a Freescale MCFS08JM60
on the underside of the Kinetis tower board. To ensure compatibility between the drivers, firmware,
and terminal window, the latest versions of each need to be installed.

First download and install both of the latest P&E Firmware Updates and Recovery and OSBDM Virtual
Serial Toolkit programs which can be found at http://www.pemicro.com/osbdm

TWR-K20D50M Quick Start Demo Lab Guide Page 10 of 23
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Make sure your tower board is plugged in, and run the P&E Firmware Updater Utility to use the
OSJTAG boot loader to upgrade to the latest OSJTAG version.

Under “Select Hardware Type” make sure OSBDM/OSITAG is selected. It should automatically detect
your board settings and fill out the rest of the fields automatically.

= Multilink/Osbdm Firmware Update and Architecture Selection Utility - Version 1.07 E@@

Mew werzionz of PEE's software products automatically update the firrmware of the different hardware
=1 | interfaces az neceszan. This application allows updating/configuration of the hardware for uze with
=1 | older applizations which do not have thiz capability, [Cloperight 200171, PLE Microcomputer Systems,

I

mﬁ@m hikbp A A, DEMIcTO, Com

LT T G TG ETC T R I SBDM /05 TAG - Embedded debug circuitiy in Freezcale Tower boards

Freezcale embed: an open source debug proceszor in many of it's Tower cards and
Demonstration boardz. PEE has taken a leading role, along with the open zource
community, in maintaining and updating the firmware of this hardware, Thiz utility alloves
updating of the firmware of these boards.

The Mulkilink. Univerzal iz a much higher speed, mare fully featured, interface dezsigned to
wiork, either with the tower cards or the user's ovwn target hardware,

|STEIE (I T R R

|nformation ; Click thizs link for more information on thiz hardware

2. Select Device : |Embedded Kinetis 05SBDM/05TAG Device [Firmware Yerzion 30.21] j

Refrezh lizt of devices |

3. Select Architecture to Suppaort : |Kinetis ﬂ

4. Firmware File Selection :

(e Automatic
osbdmenz_arm_3021

(" Chooze Firrmware Update File or 5-Record Select
Unzelected

|Jpdate Firmware

Click on “Update Firmware” to update the firmware. It will prompt you to disconnect the USB cord
from your computer, and then short the JM60 boot loader jumper header. It is J34. Then re-connect
the board to your computer.

The firmware will then be updated on your board. When it is finished, it will prompt you again to
disconnect the USB cable, remove the jumper, and then re-connect the board again. OSITAG is now
updated.

TWR-K20D50M Quick Start Demo Lab Guide Page 11 of 23
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10 Configure Hardware

The hello world example can be run using a TWR-K20D50M stand-alone. No other tower
boards/components are required for this example.

1) Note that the default jumper settings are in section TWR-K20D50M Jumper options. If you want
to change back to the default settings after you are done running the demo.

2) Connect a mini-AB USB cable between the TWR board and the USB port on your computer

3) Allow the PC to automatically configure the OSITAG drivers used for debugging and the serial-
to-USB feature.

11 Launch the Terminal

1) Open the P&E Terminal Utility by clicking on Start Menu->Programs->P&E Kinetis Tower Toolkit-
>Utilities->Terminal Utility

2) Make sure USB COM is selected with 115200 baud, and click on the “Open Serial Port” button

. Terminal Window application v2.05

E =4 - -
Elpen Serial Port
micro

Terminal Window:

Clear Window |

12 Development Software and Programming the Board

The following instructions describe how to build and flash the hello world demo using CodeWarrior
MCU 10.2 or IAR 6.30.

12.1 CodeWarrior for Microcontrollers v10.2

1) Follow the directions in Section 9 to update the OSJITAG firmware and drivers.
2) Install CodeWarrior for Microcontrollers 10.2.

3) Make sure you have CodeWarrior for Microcontrollers 10.2 or higher
4) Open CW10.2. At the welcome screen, set the workspace to the "kinetis_50MHz_sc" folder
location. These projects use workspace relative paths, so in order for the project to find all files

correctly the workspace must be set to the kinetis_50MHz_sc folder (the one that contains the
build and src directories).

TWR-K20D50M Quick Start Demo Lab Guide Page 12 of 23
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5) If you already have CW10 open, you can change the workspace by going to File->Switch
Workspace

6) The first time you open CW10, you will be taken to the Welcome screen. Click on “Go To
Workbench” in the lower left hand side.

7) The workbench view will open up. To ensure all the windows are properly set, go to Window->
Reset Perspective

b window  Help

Mew Window

-

Open Perspective
Shiows Yiew »

Customize Perspective. .,
Save Perspective As..,
Resel Perspective. ..

il Doveogckbivg

8) Click on File->Import in the menu bar. In the dialog box that comes up, select “Existing Projects

into Workspace” under the General folder. Then click Next
Select an import source;

kype filker bewxk

== General
[E archive File
1 Existing Projects into Workspace
[, File System
L Preferences
H = OO+

9) On the next screen, select the “Select root directory:” option, and click on Browse
10)Navigate to the ..\ kinetis_50MHz_sc\build\cw\hello_world directory and hit OK.
11)Select the projects to import. Then select Finish.

TWR-K20D50M Quick Start Demo Lab Guide Page 13 of 23
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Import Projects
Select a directory to search for existing Eclipse projects., / .

(%) Select root directaory: | C:\Documents and Settings | | Browse. .. |

() select archive file: | |

Projects:

hello_world (C:\Documents and Settings\b06362 Select Al

Desslect Al

i

Refresh

< |

|1

|:| Copy projects into workspace

12)Select the link configuration that you would like to build.

CilR Gl . MK20DX 128_INTERNAL_RAM

m FLASH_OS5.  MK20DX128_INTERMAL_FLASH
(=] FLASH_OSITRG pemicra TFE
m FLASH_Segger.launch 17 KB
[z Project_Settings
|14] RAM_OSITAG.launch 13 KB

13)Build the project by clicking on the Hammer icon in the toolbar 8

14)Click Run->Debug Configurations... in the menu bar, and select the debug configuration
appropriate for the project, build configuration, and hardware connection you are using. For
example, if you are building the hello_world project to run from the internal RAM and using

TWR-K20D50M Quick Start Demo Lab Guide Page 14 of 23
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OSJTAG as your debugger, then you would select the FLASH_OSJTAG configuration. Then hit

the debug button in the bottom of the window

= Debug

N 1 [[E) Main
|G

El CodeWarrior Attach . T
E CodeWarrior Connect Ul apphfa ik
=-[£] CadeWarrior Download Project: | hello_world .
Application: | MK20DX 128_INTERNAL_FLASHk20_hello_world.afx lSearch Prn_]ect...l [ Browse.., ] l Variables. .. ]

[E] RaM_0STTAG
E RAM_Segger
# Launch Group Remote system
System: | b= k20_hello_world_MK200X 126_INTERNAL_FLASH_OSITAG {0) v | Edit.. ] [ Mew...
Filter matched 8 of 8 items
Q) [ Debug ] [ Close ]

Configurations

Create, manage, and run configurations
Download an application to a target, then debug or run the application.

== =,
|— ‘=.:> - e
X B Mame: | FLASH_OSJTAG
9= Arguments | %3 Debugger | % Source | B Environment | =} Common | g Trace and Profile

[T] FLASH_Seoger

15)|

16

f this is the first time you’ve used CW10.2 with your board, you may get a dialog box asking to
update the OSITAG firmware. Unplug your board, put a jumper on J34 (JM60 BOOT), and plug
the board back in. Hit “OK” on the dialog box, and the board OSJTAG firmware will update.

When it is done, unplug the board, remove the jumper on J34, plug the board back in and hit
“OK” again on the dialog box. If you do not have a spare jumper, you can temporarily use the

one on J7.
)The code will then be downloaded to the board and the debugger started. This may take a
several moments. You may also see the following Warning message:

CodeWarrior Alert

@ Secure Warning
The current download operation attempts to modify the Flash Control Field (FCF). Therefare, the target processor may become secured irreversibly,
This is often caused by an incorrect Linker Command File that does not reserve the FCF address range From 0x400 to Ox40F, Do you want ko abork?

Choose "fes' to abort, avaoiding an unwanted secure of the target or Mo’ ko continue downloading {OMLY IF vou really intend ta modify the FCF),

‘Cancel' aborts the operation as well,

[ es H Mo H Cancel ]

This is a check introduced with a CodeWarrior compiler patch. Hit No to continue flashing the

part, as the sample code is configured to ensure the part remains unsecured.
17)Once the code is done flashing, the code will pause at the start of the main() function.

18)Hit the run icon to continue the program execution. ¥
19)On the terminal you should see the hello world message.

Page 15 of 23
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12.2 IAR Embedded Workbench for ARM 6.30

1) Follow the directions in Section 9 to update the OSJTAG firmware and drivers.
2) Install IAR for ARM v6.30 or higher.
3) Open the workspace at ..\kinetis-sc\build\iar\hello_world\hello_world.eww
4) Configure flash loader
a. Unzip utils\iar_flash_p0_8kb_ram.zip
b. Place all of the files in this zip (except this readme file) in your IAR Systems\Embedded
Workbench.6.0_x\arm\config\flashloader\Freescale folder
c. Open your IAR workspace file and select a flash configuration for the project (you might
have to create one if you don't have one already)
d. Inthe project options select Debugger->Download

Options for node "hello_world_tower"

Categony: Facton Settings ]

General Opkions
CJC++ Compiler
Assembler
Cukput Comverter Setup | Download | Images || Extra Options | Plugins
Custom Build
Build Actions
Linkzr Yerify download
Cebugger

Sirulakor
Angel Use flash loader(s)
GDE Server Override default .board file

IAR ROM-manitor $hconfighilashloadersFreescaleFlashi 20w board E
J-Linkf1-Trace

TI Stellaris
Macraigor

PE micrao

RDI

ITaG e

ST-LIMEK
Third-Party Driver
TI =DS100

[ &ttach to program

[]5uppress download

(] l [ Cancel

e. Check the "Use flash loader(s)" box

f. Check the "Override default .board file box"

g. Provide the path to the FlashK20Xxxx.board file. Should be:
STOOLKIT_DIRS\config\flashloader\Freescale\FlashK20Xxxx.board
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5) The project for the board is selected (hello_world_tower)

| hello_warld_toweer

6) Select the link configuration that you want to build.

# hello_world - IAR Embedded Wor

File Edit WView Project Tools Window

D=zET
x
R _1EKE v
RAM_TEKE
us]:]
Lpiz

7) Compile the project by clicking the Make icon

“Make”).

(or right clicking on the project and select

8) After compilation completes, download the code to the board and start the debugger by

&

pressing the “Download and Debug” button

9) The code will download, and the debugger screen will come up and pause at the first

instruction. Hit the “Go” button to start running.

=, 2 & L8 D5
- EMSW0 e

=

cortex_ b
| [—

20)On the terminal you should see the hello world message.

13 Creating New Projects

The kinetis-sc\build\iar\make_new_project.exe or kinetis-sc\build\cw\make_new_cw_project.exe files
can be used to clone the hello_world project for the appropriate toolchain. The script will prompt you
for a name to use for the new project, and then create copies of all needed files and folders.

Note: Kkinetis_50MHz_sc\build\cw\make_new_cw_project.exe doesn’t clone the
src\hello_world folder. This must be manually created. The kinetis-
sc\build\iar\make_new_project.exe doesn’t need to create any additional folder.
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14 OSJTAG

Open Source JTAG (also known as OSBDM on ColdFire tower boards) allows a user to program, debug,
and get serial data from Kinetis devices via a USB cable. The firmware runs on a Freescale MCFS08JM60
on the underside of the Kinetis tower board.

The latest firmware and drivers can be found at http://pemicro.com/osbdm. See the Installation and
Operation document on the P&E website for details on updating the firmware and drivers. If you are
having trouble connecting, try updating to the latest drivers, virtual serial toolkit, and firmware located
on that website.

When the tower board is plugged in, it should enumerate as a composite device, with one driver for
debugging, and the other as a serial port. If you go to the Device Manager you should see the
following:

Fooh DVDYCD-ROM drives
+|-fid@ Human Interface Devices
+-=) IDE ATASATAPL cantrollers
--E& Jungo
(B8 PEMicro USE Serial Part (i1} )
BE& 136 mMulkilink 2.0
BE& WinDriver
e Kevboards
€3 LibUSE-Win32 Devices
i Cpen Source BOM - Debug Port
) Mice and ather painting devices

:’9 Moderms

@ Manitors

F

F

F

F

If you only see it enumerate as the Open Source BDM Debug Port, then your computer may
automatically picking up an outdated driver. To fix this, right click on the OSBDM driver and select
“Uninstall”. Then unplug and re-plug in the board, and it should enumerate correctly.

T

& LibUSE-\Win32 Devices
E%P Cpen Source BOM - Debug Por

IIpdake Driver...

+|-| ) Mice and ather painting devices Disabl

+ L Modemns |5.a ©

E .‘é Moritars IIninskall

—-E&8 Metwork adapters Sran Fre berdare channes

If there are still problems with enumerating correctly, you can also manually select the drivers.
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Found New Hardware Wizard
Welcome to the Found New
Hardware Wizard

Thiz wizard helpz you install software for:

Open Source BOK - Debug Part

\\;l If your hardware came with an installation CD
=2 or Hoppy disk, inzert it now.

What do you want the wizard o da?

() Install the software automatically [Fecommended)
< (o) dnstall from a list or specific location [Advancedf

Click Mest to continue,

e —
‘. Cancel

Found Mew Hardware Wizard

Please choose your zearch and installation options.

() Search for the best driver in these locations.
Ize the check bores below ta limit ar expand the default search, which includes local
pathz and removable media. The best diver found will be installed.

@Ecﬂ't gearch. | will chooge the diiver tniﬂsial_l.i:)

Choose this option to zelect the device driver from a list. Windows does not guarantee that
the driver you chooze will be the best match for vour hardware,

Mest > Cancel

< Back
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Found Mew Har dware Wizard

Select the device driver you want to install for thiz hardware.

Select the manufacturer and model of yvour hardware device and then click Mest. [F pou
G%b have a dizk that containg the driver you want o ingtall, click Have Disk.

[#]:5how compatible hardware

P odel
Open Source BOM - Debug Port

— |

& Thiz driver iz not digitally signed! )

Tell e why diver signing iz imporkant

[ < Back ” MNest » ][ Cancel ]

Install From Disk

|nzert the manufacturer's installation dizk, and then
L= make zure that the correct dive iz selected below.

Copy manufacturer's files from:

e

|m Q [ Erowse. . ] )

—

e For the Open Source BDM — Debug Port, use the driver at:
C:\pemicro\kinetis_tower_toolkit\Drivers\osbdm\OSJTAG_Debug_Interface_libusb.inf

e For the PEMicro USB Serial Port (i1), use the driver at:
C:\pemicro\kinetis_tower_toolkit\Drivers\osbdm\OSJTAG_Serial_Interface_windriver_version.inf
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15

15 TWR-K20D50M Jumper options

The following is a list of all the jumper options. The default installed jumper settings are shown in bold.

Note: Default Configuration,

Board powered by OSIJITAG USB, RTC powered by PWR_MCU

Jumper Jumper Signal Jumper Option
designator
V_BRD 125 V_BRD DEF: 1-2 VBRD to MCU_PWR
123 VDDA_HDR DEF: 1-2 VDDA to MCU_PWR
VBAT 135 VBATD Enable VBAT DEF: 1-2
136 VBATD Enable MCU_PWR DEF: 1-2

PS5V_TRG_USB | J24 P5V_TRG_USB DEF: open Disconnect target power of
JTAG connector

JM60 134 JM60 BOOTLOAD EN open OSJTAG mode

Bootloader 1-2  JM60 bootloader mode

VREG IN 130 VREG IN SELECTOR DEF: 1-2 Regulator powered by OSITAG

SELECTOR USB

5-6 K20 USB power the K20
Regulator

8-6 TWR-USB power up the K20
Regulator

BOARD 129 BOARD POWER SELECTION | DEF: 3-5 P3.3V_REG powers

POWER VBRD(MCU_PWR)

SELECTION 7-5 1.8V powers
VBRD(MCU & Interface circuit input
power)

1-2 K20 3.3 Regulator Output
powers VBRD(MCU_PWR)
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Table 3 Connectors and Pin Usage

Module Jumper name Options Signal
Designator
usB 126 K20 USN ENA DEF: 1-2 PTCO_EBI_ADG6
132 K20 USB FLGA DEF: 1-2 PTC8_EBI_AD7/SSI0_CLK
IRDA J9 IRDAJ open PTD7_CMT_IRO
17 CMPO_INO open PTC7_EBI_AD8/CMPO_IN1
Microphone J16 Microphone Enable DEF: 1-2 ADCO_DP3
Potentiometer | J15 Potentiometer Enable DEF: 1-2 ADCO_DM3
Buzzer J1 Buzzer Enable DEF: 1-2 PTC4
Accelerometer | J19 SDA Accelerometer DEF: 1-2 PTB3_12CO_SDA/ADCO_SE1
Enable 3/TSI0_CHS8
J20 SCL Accelerometer Enable | DEF: 1-2 PTB2_12C0O_SCL/ADCO_SE12
/TSIO_CH7
J18 ACCELEROMETER INT1 DEF: OPEN PTBO/ADCO_SE8/TSIO_CHO
J17 ACCELEROMETER INT2 DEF: OPEN PTB1/ADCO_SE9/TSIO_CH6
GPIO Header | J2-1 SAIO_RX_FS PTC10_EBI_AD5
/SSI0_RX_FS
12-2 SAIO_TX_FS PTB19/SSI0_TX
_FS/TSIO_CH12
J2-3 SAIO_RXDO PTCS
12-4 SAIO_TXDO PTC1/UART_RT
S/FTMO_CHO/T
SI0_CH14
J12-5 SAIO_RXD1 PTC11_LLWU_S
SI0_RXD1
J2-6 SAIO_TXD1 PTCO/SSIO_TXD
/TSI0O_CH13
12-7 SAIO_RX_BCLK PTC6
J2-8 SAIO_TX_BCLK PTB18/SSI0_TX
_BCLK/TSIO_CH
11
J2-9 SAI0O_MCLK PTC8_EBI_AD7/
SSI0_CLK
J2-10 GND GND
LEDs J13 LED orange Enable DEF: 1-2 PTC10
J11 LED Yellow Enable DEF: 1-2 PTC9
14 LED Green Enable DEF: 1-2 PTC7
J6 LED Blue DEF: 1-2 PTC8

TWR-K20D50M Quick Start Demo Lab Guide
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Module Jumper name Options Signal
Designator
PTA12 - 128 PTA12 1 MCU_PWR This header can be used to
Header 2 PTA12 power up an external
3 GND circuit/sensor
Push Buttons SW2 Pushbuttonl PTC1 PTC1/UART_RTS/FTMO_CH
0/TSIO_CH14
SW3 PushbuttonO PTC2 PTC2/UART_CTS/FTMO_CH
1/TSIO_CH15
TSI Electrodes | Elecl Electrodel TSI0_CHO PTBO/ADCO_SE8/TSIO_CHO
Elec2 Electrode2 TSIO_CH6 PTB1/ADCO_SE9/TSIO_CH6
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