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CodeWarrior™ Development Studio
for ColdFire® Architectures 
Linux® Application Edition Version 2.5 
Quick Start for Windows® Operating System

This document shows how to install the included CodeWarrior 
development software on a Windows host computer, use the CodeWarrior 
tools to create an application, and then download and debug the 
application on a target ColdFire system.

NOTE In this procedure, we assume the ColdFire target system you 
are using is already connected to your Local Area Network 
(LAN) through an Ethernet connection, and has an embedded 
Linux operating system up and running with the CodeWarrior 
Target Resident Kernel Linux binary file, AppTRK, installed.

In this section, you install and register CodeWarrior development tools.

1. Install CodeWarrior software.

a. Insert CodeWarrior Development Studio for ColdFire CD into the host 
computer CD-ROM drive — the welcome screen appears (If Auto Install 
is disabled, run program launch.exe in root directory of CD.).

b. Click Launch the Installer — the install wizard opens.

SYSTEM REQUIREMENTS

Hardware PC with 1.4 GHz Intel® Pentium® III compatible 
processor, 512 MB RAM (1 GB recommended), 
CD-ROM drive, serial port, and Ethernet port

Operating System Microsoft® Windows 2000, Windows XP, or 
Windows Vista™ Operating Systems

Disk Space 2 GB, plus space for projects and source code

Section A: Installing Software
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Install Wizard — Welcome Page

c. Click Next — the License Agreement page appears.

d. Select the I accept the terms in the license agreement option button.

Installer — License Agreement Page

e. Click Next — the Product Welcome Notes page appears.
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Installer — Product Welcome Notes Page

f. Read the information in the Product Welcome Notes page.

g. Click Next — the Destination Folder page appears.

Installer — Destination Folder Page

h. Specify alternate location, if desired.

i. Click Next — the Setup Type page appears.
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Installer — Setup Type Page

j. Select the Complete option button.

k. Click Next — the File Associations page appears.

l. Click Next — the Select GCC Toolchains page appears.

m. Check the GNU/Linux Toolchain checkbox.

n. Check the uClinux Toolchain checkbox.

Installer — Select GCC Toolchains Page

o. Click Next — the Select Default GCC Toolchain page appears.
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Installer — Select Default GCC Toolchain Page

p. Select default toolchain.

NOTE The toolchain you choose depends upon your board. See the 
following table to determine which toolchain to use as default.

q. Click Next — the Ready to Install the Program page appears.

r. Click Install — the installation process begins.

During the installation process, a warning message appears containing 
important information concerning installation locations for the GCC 
toolchains.

s. Click OK — the installation process continues.

Table 1  Target Boards with Associated Toolchains

Board Toolchain Board Toolchain

MCF5272 µCLinux MCF5475 GNU/Linux

MCF5282 µCLinux MCF5484 GNU/Linux

MCF5253 µCLinux MCF5485 GNU/Linux

MCF54455 GNU/Linux MCF5208 µCLinux

MCF5474 GNU/Linux MCF5329 µCLinux

MCF52277 uCLinux MCF5373 uCLinux

MCF54451 GNU/Linux
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During the installation process, the Sourcery G++ Lite for ColdFire GNU/
Linux Wizard opens.

2. Install Sourcery G++ toolchains.

Sourcery G++ Lite for ColdFire GNU/Linux Wizard

a. Read the information and click Next — the License Agreement screen 
appears.

b. Select the I accept the terms of the license agreement option button.

License Agreement Screen

c. Click Next — the Important Information screen appears.
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Important Information Screen

d. Read the information and click Next — the Choose Install Set screen 
appears.

Choose Install Set Screen

e. Choose the install set and click Next — the Choose Install Folder 
screen appears.
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Choose Install Folder Screen

f. Accept the default location, navigate to the folder of your choice, or enter 
a folder name into which to install the software.

NOTE If installing Sourcery G++ for both GNU/Linux and µCLinux, 
specify unique folders for installation. (Default location may be 
the same for both GNU/Linux and µCLinux.) 

g. Click Next.

h. Accept the defaults and click Next until the Pre-Installation Summary 
screen appears.

i. Review your installation choices.

j. Click Previous to change any selections.

k. When satisfied with the installation selections, click Install — the 
Sourcery G++ Lite for ColdFire GNU/Linux installs on your system.

l. Repeat the process for Sourcery G++ Lite for ColdFire uCLinux.

m. When both are installed, the CodeWarrior Development Studio 
installation final screen prompts you to check for updates.

n. Check the Yes, check for updates checkbox and click Finish — the 
CodeWarrior Updater opens.
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3. Check for updates.

NOTE If the updater already has an internet connection settings, you 
may proceed directly to sub-step f.

a. Click Settings — the CodeWarrior Updater Settings page appears.

b. Click Settings — the Connections page of the Internet Properties 
dialog box appears.

c. Modify settings, as appropriate, to successfully connect to the internet.

d. Click OK — the Internet Properties dialog box disappears.

e. Select update period from the Update Check Schedule list menu.

f. Click OK — the Internet Properties dialog box disappears.

g. In the updater screen, click Next.

h. If necessary, enter username and password.

i. If updates are available, follow on-screen instructions to download 
updates to your computer.

j. Click Finish — installation completes.

NOTE For licensing and activation of your CodeWarrior Development 
Studio for ColdFire Architectures Linux Application Edition, 
refer to the CodeWarrior Development Suite Quick Start. Save 
the license file, license.dat, to the installation root folder. 
The default is C:\Program 
Files\Freescale\CodeWarrior for ColdFire Linux 
v2.5

In this section, you connect a target ColdFire Linux board to the host 
computer and prepare the board for debugging with the CodeWarrior IDE.

1. Make sure that power is not connected to the board, and that the 
power switch setting is OFF.

2. Configure IDE preference settings.

a. Start CodeWarrior IDE and select Edit > Preferences — the IDE 
Preferences Panel appears.

b. Select Remote Connections.

Section B: Configuring the Target Board
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c. Add new remote connection definitions or modify parameters on existing 
definitions.

d. Refer to the target board documentation to find serial port parameters 
needed to communicate with the board in question.

For example, appropriate settings might be:

– Linux host serial port device /dev/ttyS0

– 115200 baud
– 8 data bits
– 1 stop bit

– no parity
– no hardware flow control

e. Click Apply to save the settings.

f. Click OK.

3. Connect target board serial cable, Ethernet cable, and power cable.

a. Connect the RS-232 serial cable to the target board RS-232 port and the 
Linux host computer serial port.

b. Connect the standard Ethernet cable to the target board Ethernet port 
and the Local Area Network (LAN) hub, switch, or port.

c. Connect power supply to the target board power connector.

d. Plug the target board power supply into the surge-protected power strip.

e. Connect the surge-protected strip to the AC power outlet.

f. Turn on the surge-protected power strip.

NOTE Refer to the documentation that came with your Board Support 
Package (BSP) for details about how to properly boot Linux on 
your target board.

4. Configure target board network interface.

a. In the terminal window, at login prompt, enter username root — system 
logs you in as root user.

b. Enter command (where IPAddress is an available unique static IP 
address on your network, and Mask is the appropriate mask for your 
subnet):

ifconfig eth0 IPAddress netmask Mask

System configures network parameters with the specified IP address and 
network mask.
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NOTE If you do not know an available unique static IP address on 
your network, contact your network administrator to obtain one.

c. Exit terminal emulator.

5. Test target board network interface configuration.

a. In the terminal window, enter command (where IPAddress is the IP 
address you assigned the target board network interface): 

ping IPAddress

Use ping command to show ping reply messages.

b. Press Control-C on keyboard — ping program stops.

6. Start AppTRK on target board.

a. In the terminal window, enter command (where IPAddress is the IP 
address of the target board network interface):

telnet IPAddress

Telnet client connects to the telnet daemon on the target board.

b. If necessary, log in as root user — shell prompt appears in the terminal 
window.

c. At shell prompt, enter: 

AppTrk.elf :1000

AppTRK begins listening for the CodeWarrior debugger connections.

NOTE In this command, :1000 indicates the number of the Linux host 
network port to which AppTRK listens for the CodeWarrior 
debugger connections. 

The target system is now ready for debugging with the CodeWarrior 
software.

In this section, you create a new CodeWarrior application project, build 
the project, transfer the executable binary file to the target board, then 
debug the project with the CodeWarrior IDE.

Section C: Creating, Building, and Running a Project
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1. Create a new CodeWarrior project.

a. Select Start > Programs > Freescale CodeWarrior > CodeWarrior for 
ColdFire Linux v2.5 > CodeWarrior IDE from the Windows task bar — 
IDE starts; the CodeWarrior main window appears.

b. From the CodeWarrior menu bar, select File > New — the New dialog 
box appears.

c. From the wizard list, select Linux Stationery Wizard.

d. In the Project name text box, enter: HelloWorld.mcp.

e. If desired, click Set to set alternate project location.

New Dialog Box

f. Click OK — the ColdFire New Project wizard begins; the GCC 
Toolchains page appears.

Wizard — GCC Toolchains Page

g. Select the appropriate predefined GCC toolchain or select Custom to 
manually enter the location of a toolchain.

h. Click Next — the Application and Language page appears.
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NOTE If you select Custom in GCC Toolchains page, Custom 
Toolchain Location page appears. 

i. From the Applications list, select Application.

j. From the Language list, select C&CPP.

Wizard — Application & Language Page

k. Click Next — the Download Location page appears.

l. In text box, enter full path to directory in target file system to which you 
have write access (for example: /tmp).

Wizard — Download Location Page

m. Click Next — the Core Select page appears.

n. From the list, select core of target board.
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Wizard — Core Select Page

o. Click Next — the Remote Connection page appears.

p. From list, select ColdFire CodeWarriorTRK TCP/IP.

q. In the Hostname text box, enter IP address of target board and 
CodeWarriorTRK listening port number on target board, in this form:

IPAddress:PortNum

Wizard — Connection Page

r. Click Finish — IDE creates the new project; the project window appears.

Project Window

2. From the CodeWarrior menu bar, select Project > Make — 
CodeWarrior IDE compiles project.
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NOTE The CodeWarrior IDE creates the output binary executable file 
locally, on the Linux host computer, in CWProjectDir/Bin/.

3. Start CodeWarrior debug session.

a. From the CodeWarrior menu bar, select Project > Debug — the 
debugger stack crawl window appears; the debugger starts program, then 
halts the program execution at the program entry point.

Debugger Stack Crawl Window

NOTE The stack crawl window title bar displays the Thread ID (TID) 
and the Process ID (PID) of the current thread and process.

b. At the left side of the window, click the breakpoint column next to the 
cout << “Welcome !” source code line — a red dot appears in the 
breakpoint column.

c. Select Project > Run — the debugger executes program and halts 
execution at the specified breakpoint. 

d. Select Debug > Step Over — the debugger advances Program Counter 
(PC) to the next line of the source code; PC indicator (blue arrow) moves 
to the next line in the stack crawl window; the second CodeWarrior TRK 
Console window appears displaying “Welcome !” message.

e. Select Debug > Step Over again — new CodeWarrior TRK Console 
window appears; “Welcome !” message appears in the new CodeWarrior 
TRK Console window.

f. Select Debug > Kill — the debugger stops program execution; the 
debugger window disappears.
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Congratulations!
You just used CodeWarrior software to create, build, and run 

a simple program for your target ColdFire Linux board.
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