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CodeWarrior™ Development Studio

for ColdFire® Architectures
Linux® Platform Edition 2.5
Quick Start for Linux® Operating Systems

SYSTEM REQUIREMENTS

Hardware PC with 1.4 GHz Intel® Pentium® 11l compatible
processor
512 MB RAM (1 GB recommended)
CD-ROM drive, serial port, and Ethernet port

Operating System Red Hat® Linux version 9.0,
Red Hat Enterprise Linux version 3

Red Hat Enterprise Linux version 4
Red Hat Enterprise Linux version 5

Disk Space 1.6 GB, plus space for projects and source code

This document shows how to install the included CodeWarrior
development software on a Linux host computer, use the CodeWarrior
tools to create an application, and then download and debug the
application on a target ColdFire system.

NOTE In this procedure, we assume the ColdFire target system you
are using is already connected to your Local Area Network
(LAN) through an Ethernet connection, and has an embedded
Linux operating system up and running with the CodeWarrior
Target Resident Kernel Linux binary file, AppTRK, installed.



Section A: Installing and Registering Software

In this section, you install and register CodeWarrior development tools.

1. Install CodeWarrior software.

a.
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Insert CodeWarrior Development Studio for ColdFire Architectures, Linux
Edition CD into the Linux host computer CD-ROM drive.

On the Linux host computer, open a new terminal window — shell session
starts.

In the terminal window, log in as root or super user.
Mount CD-ROM media on the Linux file system.
Change working directory to CD-ROM mount directory.

As root or super user, enter command: . /setuplinux.bin — install
wizard starts; the welcome page appears.

Starting the Installer

__pubslinux.am.freescale.net:/tmp/b17009/disk

Initializing InztallShield Mizard........
Launching InstallShield Wizard........




Install Wizard — Welcome Page

-, Welcome to the InstallShield Wizard for
" freescale | CodeWarrior Development Studio for ColdFire
wmemde | Architectures, Linux Platform Edition Version
2.5

The InstallShield Wizard will install CodeWarrior Cewvelopment Studio for
CaldFire Architectures, Linux Platform Edition Yersion 2.5 on your computer.
To continue, choose Mext.

CodeWarrior Development Studio for CaldFire Architectures,

Linux Platform Edition Wersion 2.5

Freescale

http: / fewer freescale.com
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Click Next — the License page appears.
Select the | accept the terms of the license agreement option button.

Installer — License Page

Development Studio for ColdFire Architectures

Please read the following license agreement carefully.

-
-

- - IMPORTAMNT. Eead the following Freescale Software License Agreement -

- f’eeﬁﬁ?ﬂiﬁ ("Agreement’y completely. =

FREESCALE SOFTWARE LICEMNZE ACREEMENT

This is a legal agreement between you (either as an individual ar as
an authorized representative of your emplover) and Freescale
Semiconductar, Inc. ('Freescale"). It concerns your rights {0 use

this file and any accompanying written materials gthe "Software").
This Agreement does not concern your rights for software that has
its own separate license agreement. A list of these license agreements
is available at www. freescale.com/codewarrior/LicenseMaotice and is
included with this software as a readme file. In consiceration far
Freescale allowing you to access the Software, you are agreeing to be
bound by the terms of this Agreement. If wou do not agree to all of

@ | accept the terms of the license agreement

2 | o nat accept the terms of the license agreement.

Click Next — next page appears.

Follow wizard instructions, accepting default settings until the Install
Location page appears.

Specify alternate location; for example:

/usr/local/Freescale/
CodeWarrior_ColdFire_Linux_2.5



Installer — Install Location Page

Development Studio for ColdFire Arc|

- Click Mext to install "Code'Warrior Development Studio for ColdFire
< g Architectures, Linux Flatform Edition Yersion 2.5" to this directory, or click
> freesca’e‘ Browse to install to a different directory.
semicanductor
Directary Mame:
\]usr}In[a\]FreEs[aIE]CndeWamur_Cu\dFlre_Lmux_Z 5 \

Browse

I.  Click Next — the GCC Toolchains page appears.

m. Check the 4.3-43 GNU/Linux Toolchain checkbox.

n. Check the 4.3-45 uClinux Toolchain checkbox.
Installer — GCC Toolchains Page

ior Development Studio for ColdFire Architectures Linux Platform Ed

Select which GCC Toolchain(s) you wish to use with the CodeWarrior tools.

" freescale
Bermconductor

4.3-43 GMU/Linux Toolchain
4.3-45 uClinux Toolchain
[[] Other GCC Tonlchains (select in the next dialog)

0. Click Next — the Default Toolchain page appears.

p. Select the Use the 4.3-45 uClinux Toolchain as the default option
button.



Installer — Default Toolchain Page

_Codew.

T “ou selected to use multiple SCC Toolchains, Setup needs to know which
- - u will use as the default toolchain
" freescale’| | ™
rericondoctor

Select which GCC Toolset you wish 1o use as the default,
() Use the 4 3-43 GNUfLinux Toolchain as the default
® Use the 4.3-45 uClinux Toolchain as the default.

g. Click Next — the Summary page appears.
r.  Continue following install wizard directions until the installation is finished.
s. Click Finish — the install wizard exits.

NOTE For licensing and activation of your CodeWarrior Development
Studio for ColdFire Architectures, refer to the CodeWarrior
Development Suite Quick Start. Save the license file,
license.dat to the installation root folder, the default is
/usr/local/Freescale.

Section B: Configuring the Target Board

In this section, you connect a target ColdFire Linux board to the host
computer and prepare the board for debugging with the CodeWarrior IDE.

1. Configure terminal emulation.

a. On the Linux host computer, open the terminal window.

b. Refer to the target board documentation to learn serial port parameters
needed to communicate with the board in question.

c. As root or super user, enter command minicom -s to configure
minicom program with the appropriate parameters for the Linux host
computer serial port and the target board.

For example, appropriate settings might be:
— Linux host serial port device /dev/ttyS0
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— 115200 baud

— 8 data bits

— 1 stop bit

— no parity

— no hardware flow control

2. Connect target board serial cable, Ethernet cable, and power cable.

a.
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Connect the RS-232 serial cable to the target board RS-232 port and the
Linux host computer serial port.

Connect the standard Ethernet cable to the target board Ethernet port
and the Local Area Network (LAN) hub, switch, or port.

Connect power supply to the target board power connector.
Plug the target board power supply into the surge-protected power strip.
Connect the surge-protected strip to the AC power outlet.

Turn on the surge-protected power strip — target board boots; boot
messages appear in the terminal window; when system is ready, prompt
appears in the terminal window.

3. Boot Linux.

NOTE Refer to the documentation that came with your Board Support

Package (BSP) for details about how to properly boot Linux on
your target board.

4. Configure target board network interface.

a.

NOTE

C.

In the terminal window, at login prompt, enter username root — system
logs you in as root user.

Enter command (where /PAddress is an available unique static IP
address on your network, and Mask is the appropriate mask for your
subnet):

ifconfig eth0 IPAddress netmask Mask

System configures network parameters with the specified IP address and
network mask.

If you do not know an available unique static IP address on
your network, contact your network administrator to obtain one.

Exit terminal emulator.



5. Test target board network interface configuration.

a. In the terminal window, enter command (where /PAddress is the IP
address you assigned the target board network interface):

ping IPAddress
Use ping command to show ping reply messages.
b. Press Control-C on keyboard — ping program stops.

6. Start AppTRK on target board.

a. In the terminal window, enter command (where /PAddress is the IP
address of the target board network interface):

telnet IPAddress
Telnet client connects to the telnet daemon on the target board.

b. If necessary, log in as root user — shell prompt appears in the terminal
window.

c. At shell prompt, enter:
AppTrk.elf :1000
AppTRK begins listening for the CodeWarrior debugger connections.

NOTE In this command, : 1000 indicates the number of the Linux host
network port to which AppTRK listens for the CodeWarrior
debugger connections.

The target system is now ready for debugging with the CodeWarrior
software.

Section C: Creating, Building, and Running a Project

In this section, you create a new CodeWarrior application project, build
the project, transfer the executable binary file to the target board, and then
debug the project with the CodeWarrior IDE.

1. Create a new CodeWarrior project.

Open the terminal window.

b. Change the working directory to this directory (where cwInstallDiris
the directory in which you installed the CodeWarrior software).

CWInstallDir/CodeWarriorIDE/

c. Enter command: . /cwide — the CodeWarrior IDE starts; the
CodeWarrior menu bar appears.
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CodeWarrior Menu Bar

CodeWarrior

d. From the CodeWarrior menu bar, select File > New — the New dialog
box appears.
New Dialog Box
[x]

[ empty Progect
" Excternal Build Wizard

" Linu Stationery wizsrd

Froject name

[Hettaworld mop

Location

/hame/usr | /Projects/Helloworld/| Set..

[ #dd to project

[

¥
()
e. From the wizard list, select Linux Stationery Wizard.
In the Project name text box, enter: HelloWorld.mcp.
g. If desired, click Set to set alternate project location.
h. Click OK — IDE starts Linux Stationery Wizard; the wizard dialog box

appears.
Wizard — Cross Tool Page

Linux Stationery Wizard

[ = o e

i. Select GCC version corresponding to the BSP used.
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j.  Click Next — the Output Type and Language page appears.
Wizard — Output Type and Language Page

Linux Stationery Wizard

Selecl the Output & L type used in this stationery

Pppiication _____________Jife
Shared Library cacPp
StaticLibrary CPP

Loadable Module

Back| Mext| isist| Cancel

k. From the Output Type list (left), select Application.
I.  From the Language list (right), select C&CPP.
m. Click Next — the Download Location page appears.

n. Inthe text box, enter the full path to the directory on the target file system
to which you have write access (for example: /tmp).

Wizard — Download Location Page

; Linux Stationery Wizard
Select download location on Linux target

The user should have write permissions

in this targel directory:

[

Back| Mext| isist| Cancel

o. Click Next — the Core Selection page appears.



t.

Wizard — Core Selection Page

Linux Stationery Wizard

Back| Hoxt| fosst| Concol|

From list, select core of target board.
Click Next — the Connection page appears.
From list, select ColdFire CodeWarriorTRK TCP/IP.

In the Hostname text box, enter IP address of target board and
CodeWarriorTRK listening port number on target board, in this form:

IPAddress: PortNum
Wizard — Connection Page

Linux Stationery Wizard

Back] tet| Fish| Cancel]

Click Finish — IDE creates new project; the project window appears.
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Project Window

File Edit  Search Project  Debug  Tools  Window Help |

(=]

|'B cB.cpp_app_debug

Files \ / Link Order\ / Targets

%[ File | Code | Data [4[uE
= ¢ [, source a 0+ « @A
¢ [ maincpp o 0+ « @
L3 Mee [} 0« « @
£
2 files o o

2. From the CodeWarrior menu bar, select Project > Make —
CodeWarrior IDE compiles project.

NOTE The CodeWarrior IDE creates the output binary executable file
locally, on the Linux host computer, in CWProjectDir/bin/.

3. Start CodeWarrior debug session.

a. From the CodeWarrior menu bar, select Project > Debug — the
debugger stack crawl window appears; debugger starts program, then
halts program execution at the program entry point.

Debugger Stack Crawl Window

cw_dbg.elf (<tid: 0> <lwpid: 788> Stopped)
File Edit  Search Project  Debug Data  Linux Info  Tools  Window

Help
Stack 3] & Variables: Live | Value | Loation [4]|
0x40184608 {0x40184508) Ky arge 1 OxBFFFFESC [
main I argv OxEFFFFEA OxBFFFFESO
| start {0xB000062ZE) k 1075318808  OxBFFFFETC
040178676 (0x40178676)
b main
i £
~
IESaur’ce: Fhorne Studer Helloorld/ main.cpp. ]|
A
extern "G"
{
int fn_in_c_file(woid);
¥
—[bint main(int args, char *+argu)
int k;
E k= fn_in_c_file();
= cout < "Welcome | << “nt;
= cout << "Value returned from C function=" << k << "wn";
£
£ [ Line 32 Col || Source M1 I -
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NOTE The stack crawl window title bar displays the Thread ID (TID)
and the Process ID (PID) of the current thread and process.

b. At the left side of the window, click the breakpoint column next to the
cout << “Welcome !” source code line — a red dot appears in the
breakpoint column.

c. Select Project > Run — the debugger executes the program and halts
the execution at the specified breakpoint.

d. Select Debug > Step Over — the debugger advances Program Counter
(PC) to the next line of the source code; PC indicator (blue arrow) moves
to the next line in the stack crawl window; the second CodeWarrior TRK
Console window appears displaying the “Welcome !” message.

e. Select Debug > Step Over again — new CodeWarrior TRK Console
window appears; “Welcome!” message appears in the new CodeWarrior
TRK Console window.

f. Select Debug > Kill — the debugger stops program execution; the
debugger window disappears.

Congratulations!

You just used CodeWarrior software to create, build, and run
a simple program for your target ColdFire Linux board.
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Semiconductor does not convey any license under its patent rights nor the rights of others.
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intended to support or sustain life, or for any other application in which the failure of the
Freescale Semiconductor product could create a situation where personal injury or death may
occur. Should Buyer purchase or use Freescale Semiconductor products for any such
unintended or unauthorized application, Buyer shall indemnify and hold Freescale
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How to Contact Us

Corporate Freescale Semiconductor, Inc.
Headquarters 6501 William Cannon Drive West
Austin, Texas 78735
U.S.A.
World Wide Web http://www. freescale.com/codewarrior
Technical Support http://www. freescale.com/support

Revised: 3 March 2009
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