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CodeWarrior™ Development Studio
for ColdFire® Architectures 
Linux® Application Edition Version 2.4 
Quick Start for Windows® Operating System

This document shows how to install the included CodeWarrior 
development software on a Windows host computer, use the CodeWarrior 
tools to create an application, and then download and debug the 
application on a target ColdFire system.

NOTE In this procedure, we assume the ColdFire target system you 
are using is already connected to your Local Area Network 
(LAN) through an Ethernet connection, and has an embedded 
Linux operating system up and running with the CodeWarrior 
Target Resident Kernel Linux binary file, AppTRK, installed.

In this section, you install and register CodeWarrior development tools.

1. Install CodeWarrior software

a. Insert CodeWarrior Development Studio for ColdFire CD into 
host computer CD-ROM drive — welcome screen appears (If 
Auto Install is disabled, run program launch.exe in root 
directory of CD.)

b. Click Launch the Installer — install wizard opens

SYSTEM REQUIREMENTS

Hardware PC with 1.4 GHz Intel® Pentium® III compatible 
processor, 512 MB RAM (1 GB recommended), 
CD-ROM drive, serial port, and Ethernet port

Operating System Microsoft® Windows® 2000, Windows® XP, or 
Windows Vista™ Operating Systems

Disk Space 2 GB, plus space for projects and source code

Section A: Installing Software
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Install Wizard — Welcome Page

c. Click Next — License Information page appears

Installer — License Information Page

d. Click Next — License Agreement page appears

Installer — License Agreement Page

e. Select I accept the terms in the license agreement option 
button
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f. Click Next — Product Welcome Notes page appears

Installer — Product Welcome Notes Page

g. Read the information in the Product Welcome Notes page

h. Click Next — Destination Folder page appears

Installer — Destination Folder Page

i. Specify alternate location, if desired
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j. Click Next — Setup Type page appears

Installer — Setup Type Page

k. Select Complete option button

l. Click Next — File Associations page appears

m. Click Next — Select GCC Toolchains page appears

Installer — Select GCC Toolchains Page

n. Check GNU/Linux Toolchain checkbox

o. Check uClinux Toolchain checkbox
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p. Click Next — Select Default GCC Toolchain page appears

Installer — Select Default GCC Toolchain Page

q. Select default toolchain

NOTE The toolchain you choose depends upon your board. See the 
following table to determine which toolchain to use as default.

r. Click Next — Ready to Install the Program page appears

s. Click Install — The installation process begins

During the installation process, a warning message appears 
containing important information concerning installation locations 
for GCC toolchains.

t. Click OK — The installation process continues

During the installation process, the Sourcery G++ Lite for 
ColdFire GNU/Linux Wizard opens

Table 1  Target Boards with Associated Toolchains

Board Toolchain Board Toolchain

MCF5272 µCLinux MCF5475 GNU/Linux

MCF5282 µCLinux MCF5484 GNU/Linux

MCF5253 µCLinux MCF5485 GNU/Linux

MCF54455 GNU/Linux MCF5208 µCLinux

MCF5474 GNU/Linux MCF5329 µCLinux
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2. Install Sourcery G++ toolchains 

Sourcery G++ Lite for ColdFire GNU/Linux Wizard

a. Read the information and click Next — License Agreement 
screen appears

License Agreement Screen

b. Select I accept the terms of the license agreement option 
button
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c. Click Next — Important Information screen appears

Important Information Screen

d. Read the information and click Next — Choose Install Set 
screen appears

Choose Install Set Screen
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e. Choose the install set and click Next — the Choose Install 
Folder screen appears

Choose Install Folder Screen

f. Accept the default location, navigate to the folder of your choice, 
or enter a folder name into which to install the software

NOTE If installing Sourcery G++ for both GNU/Linux and µCLinux, 
specify unique folders for installation. (Default location may be 
the same for both GNU/Linux and µCLinux.) 

g. Click Next

h. Accept the defaults and click Next until the Pre-Installation 
Summary screen appears

i. Review your installation choices

j. Click Previous to change any selections

k. When satisfied with the installation selections, click Install — 
Sourcery G++ Lite for ColdFire GNU/Linux installs on your 
system

l. Repeat the process for Sourcery G++ Lite for ColdFire 
uCLinux 

m. When both are installed, the CodeWarrior Development Studio 
installation final screen prompts you to check for updates 

n. Check the Yes, check for updates button and click Finish — 
CodeWarrior Updater opens



9

3. Check for updates

NOTE If the updater already has internet connection settings, you 
may proceed directly to sub-step f.

a. Click Settings button — CodeWarrior Updater Settings page 
appears

b. Click Settings button — Connections page of Internet 
Properties dialog box appears

c. Modify settings, as appropriate, to successfully connect to 
internet

d. Click OK button — Internet Properties dialog box disappears

e. Select update period from Update Check Schedule list menu

f. Click OK button — Internet Properties dialog box disappears

g. In updater screen, click Next button

h. If necessary, enter username and password

i. If updates are available, follow on-screen instructions to 
download updates to your computer

j. Click updater Finish button — installation completes

NOTE Free versions of the CodeWarrior tools include a permanent 
but feature-limited license. You do not need to register these 
tools to obtain a license. 

You can obtain an evaluation license (full featured but time-
limited) from the CodeWarrior Licensing and Registration web 
page at the Freescale website. Go to http://
freescale.com/cwregister and click the Request 
Evaluation License link.

To obtain a permanent license for your product you need an 
entitlement ID (registration code), as detailed in this section.

Section B: Registering Software
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1. In web browser, enter location:

http://freescale.com/cwregister

CodeWarrior registration web page appears

Licensing and Registration Web Page

2. Click on Registration and Activation to register and activate your 
product — Registration and Activation page appears.

Registration and Activation page



11

3. Click on Register and Activate your CodeWarrior Product.

NOTE If you are not registered with Freescale, click on Register Now 
and follow all on-screen instructions to register. After you have 
successfully registered, a Welcome page appears with a link to 
CodeWarrior Licensing. Click on this link and the 
CodeWarrior Technology page appears. Click on Click here 
to register a product or support. The Licensing Activation 
System page appears.

NOTE If you are an existing member with Freescale and not already 
logged in to our site, click on the Log-In link, click Log in, and 
the Licensing Activation System page appears.

NOTE If you are an existing member with Freescale and already 
logged in to our site, the Licensing Activation System page 
appears.

License Activation System page
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4. Enter the Registration Code/Entitlement Code to register your 
software. 

NOTE To register your product you need an Entitlement ID. If you do 
not have this code and believe you are entitled to a permanent 
license, go to: www.freescale.com/support and open a 
Service Request using Category: Technical Request and 
Topic: License Issues.

5. Continue to follow instructions until the license file is presented 

6. Download the license file, license.dat, to the installation root 
folder, the default is C:\Program Files\Freescale\CW for 
ColdFire Linux V2.4 — you are now ready to use the 
CodeWarrior tools

In this section, you connect a target ColdFire Linux board to the host 
computer and prepare the board for debugging with the CodeWarrior IDE.

1. Make sure that power is not connected to the board, and that the 
power switch setting is OFF

2. Configure IDE preference settings

a. Start CodeWarrior IDE and select Edit > Preferences — IDE 
Preferences Panel appears

b. Select Remote Connections

c. Add new remote connection definitions or modify parameters on 
existing definitions

d. Refer to target board documentation to find serial port parameters 
needed to communicate with the board in question

For example, appropriate settings might be:

– Linux host serial port device /dev/ttyS0
– 115200 baud
– 8 data bits

– 1 stop bit
– no parity
– no hardware flow control

Section C: Configuring the Target Board
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e. Click Apply to save the settings.

f. Click OK

3. Connect target board serial cable, Ethernet cable, and power 
cable

a. Connect RS-232 serial cable to target board RS-232 port and 
Linux host computer serial port

b. Connect standard Ethernet cable to target board Ethernet port 
and Local Area Network (LAN) hub, switch, or port

c. Connect power supply to target board power connector

d. Plug target board power supply into surge-protected power strip

e. Connect surge-protected strip to AC power outlet

f. Turn on surge-protected power strip

NOTE Refer to the documentation that came with your Board Support 
Package (BSP) for details about how to properly boot Linux on 
your target board.

4. Configure target board network interface

a. In terminal window, at login prompt, enter username root — 
system logs you in as root user

b. Enter command (where IPAddress is an available unique static IP 
address on your network, and Mask is the appropriate mask for 
your subnet):

ifconfig eth0 IPAddress netmask Mask

System configures network parameters with specified IP address 
and network mask

NOTE If you do not know an available unique static IP address on 
your network, contact your network administrator to obtain one.

c. Exit terminal emulator
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5. Test target board network interface configuration

a. In terminal window, enter command (where IPAddress is the IP 
address you assigned the target board network interface): 

ping IPAddress

Ping command shows ping reply messages 

b. Press Control-C on keyboard — ping program stops

6. Start AppTRK on target board

a. In terminal window, enter command (where IPAddress is the IP 
address of the target board network interface):

telnet IPAddress

Telnet client connects to telnet daemon on target board

b. If necessary, log in as root user — shell prompt appears in 
terminal window

c. At shell prompt, enter: 

AppTrk.elf :1000

AppTRK begins listening for CodeWarrior debugger connections

NOTE In this command, :1000 indicates the number of the Linux host 
network port to which AppTRK listens for CodeWarrior 
debugger connections. 

The target system is now ready for debugging with the CodeWarrior 
software.

In this section, you create a new CodeWarrior application project, build 
the project, transfer the executable binary file to the target board, then 
debug the project with the CodeWarrior IDE.

1. Create new CodeWarrior project

a. Select Start > Programs > Freescale CodeWarrior > 
CodeWarrior for ColdFire Linux v2.4 > CodeWarrior IDE from 
Windows task bar — IDE starts; CodeWarrior main window 
appears

Section D: Creating, Building, and Running a Project
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b. From CodeWarrior menu bar, select File > New — New window 
appears

New Window

c. From wizard list, select Linux Stationery Wizard

d. In Project name text box, enter: HelloWorld.mcp

e. If desired, click Set button to set alternate project location

f. Click OK — IDE starts Linux Stationery Wizard; wizard dialog box 
appears

Wizard — GCC Toolchains Window

g. Select the appropriate predefined GCC toolchain or “Custom” to 
manually enter the location of a toolchain
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h. Click Next — Application and Language window appears

Wizard — Application and Language Window

i. From Applications list, select Application

j. From Language list, select C&CPP

k. Click Next — Download Location window appears

Wizard — Download Location Window

l. In text box, enter full path to directory in target file system to 
which you have write access (for example: /tmp)
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m. Click Next — Core Selection window appears

Wizard — Core Selection Window

n. From list, select core of target board

o. Click Next — Connection window appears

Wizard — Connection Window

p. From list, select ColdFire CodeWarriorTRK TCP/IP

q. In Hostname text box, enter IP address of target board and 
CodeWarriorTRK listening port number on target board, in this 
form:

IPAddress:PortNum
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r. Click Finish — IDE creates new project; project window appears

Project Window

2. From CodeWarrior menu bar, select Project > Make — 
CodeWarrior IDE compiles project

NOTE The CodeWarrior IDE creates the output binary executable file 
locally, on the Linux host computer, in CWProjectDir/Bin/.

3. Start CodeWarrior debug session

a. From CodeWarrior menu bar, select Project > Debug — 
debugger stack crawl window appears; debugger starts program, 
then halts program execution at program entry point

Debugger Stack Crawl Window

NOTE The stack crawl window title bar displays the Thread ID (TID) 
and the Process ID (PID) of the current thread and process.
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b. At left side of window, click breakpoint column next to cout << 
“Welcome !” source code line — Red dot appears in breakpoint 
column

c. Select Project > Run — debugger executes program and halts 
execution at specified breakpoint 

d. Select Debug > Step Over — debugger advances Program 
Counter (PC) to next line of source code; PC indicator (blue 
arrow) moves to next line in stack crawl window; second 
CodeWarrior TRK Console window appears displaying 
“Welcome !” message

e. Select Debug > Step Over again — new CodeWarrior TRK 
Console window appears; “Welcome !” message appears in new 
CodeWarrior TRK Console window

f. Select Debug > Kill — debugger stops program execution; 
debugger window disappears 

Congratulations!
You just used CodeWarrior software to create, build, and run 

a simple program for your target ColdFire Linux board.
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How to Contact Us

Corporate 
Headquarters

Freescale Semiconductor, Inc.
7700 West Parmer Lane
Austin, TX 78729
U.S.A.

World Wide Web http://www.freescale.com/codewarrior

Technical Support http://www.freescale.com/support
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