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Installing Service Pack Updater Archive
for CodeWarrior Tools (Windows)

Quick Start

This Quick Start explains how to install service pack updater archive for 
your CodeWarrior software running on the Windows platform.

Support for new devices and/or updates can be added to the CodeWarrior 
Development Studio for Microcontrollers v10.x directly from the Internet 
(Online mode) or from a downloaded archive (Offline mode).

This document describes both the Offline and Online modes of updating 
CodeWarrior MCU v10.x and a troubleshooting update. These 
instructions will show you how to manipulate that list to ensure that you 
can focus on the right URL for the CodeWarrior tools update.

The topics covered in this document are:

• Updating Online: Lists the steps required to complete the update 
when you are connected to the Internet.

• Troubleshooting Updates:  Lists the troubleshooting updates.

SYSTEM REQUIREMENTS

Hardware Windows® OS: PC with 1 GHz Intel® Pentium® 
compatible processor
2GB of RAM
CD-ROM drive
Enabled USB port
Depending on host-target connection: Parallel
Port, 9-pin Serial Port, or USB Port

Operating System Microsoft® Windows XP 32-bit and 64-bit 
(Professional Edition),
Microsoft Windows Vista® 32-bit and 64-bit (Home 
Premium Edition and Business Edition), or
Microsoft Windows 7 32-bit and 64-bit (Home 
Premium Edition and Professional Edition)

Disk Space 20GB (When installing full product or updates for 
all architectures) 
1GB on Windows system disk
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• Updating Offline: Lists the steps required to complete the update 
when you are not connected to the Internet. 

NOTE To ensure successful installation of service packs, updates, 
and patches select Restart in the File menu to perform a 
CodeWarrior restart. This will ensure all processes (e.g. 
debugger shell) are closed. CodeWarrior should NOT be used 
during the installation process.

If your computer is connected to the Internet, you can install the service 
pack directly from the software site where the service pack is available.

To perform online updates perform these steps:

Step A: Select the Install New software menu command

Step B: Select the URL where you want to find the new software

Step C: Select which CodeWarrior updates to install

Step D: Install Selected Updates and Patches

Step A: Select the Install New software menu command

1. Open the CodeWarrior IDE.

NOTE If your CodeWarrior software is running on Windows 7, start 
the IDE using the Run as Admin option.

2. Select Window > Close All Perspectives from the CodeWarrior IDE 
menu bar.

Section A: Updating Online
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Close All Perspectives
 

3. Select Help > Install New Software from the CodeWarrior IDE menu 
bar.

Install New Software
 

The Install dialog box appears.

NOTE Do not use the Check for Updates command. The Install New 
Software option is more comprehensive as it locates new 
service packs that are considered new software and are not the 
usual product updates.

Step B: Select the URL where you want to find the new software

From the Work with drop-down list, select the software site where the 
service pack you wish to install is available.



4

This list is populated by the Available Software Sites preferences 
window. Only those sites that are enabled in that Preferences window are 
listed.

NOTE In the following image the CodeWarrior tools update site 
selected has been named "MCU Update" which is a user-
friendly name set up by the user.

Install
 

Eclipse maintains a list of update sites (URLs) to which it refers when 
looking for new software. If the Freescale site does not appear you need 
to manage this list. The following step is devoted entirely to the details of 
managing the list of update sites. 

Quick one-time solution: The URL for the Freescale CodeWarrior MCU 
10.x tools is already populated in the Work with drop-down list and you 
can access it by clicking the down arrow.

The URL is: http://freescale.com/lgfiles/updates/Eclipse/MCU10_3/
com.freescale.mcu.updatesite.

http://freescale.com/lgfiles/updates/Eclipse/MCU10_3/com.freescale.mcu.updatesite
http://freescale.com/lgfiles/updates/Eclipse/MCU10_3/com.freescale.mcu.updatesite
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Editing an existing item 

If you want to edit a software site already available in the Work with drop-
down list in the Available Software Sites preferences, perform these steps: 

1. Click the Available Software Sites link to open the preferences 
window that enables you to manage the list of URLs.

The Available Software sites preferences window appears.

Available Software Sites
 

In this window you can add, edit, remove, enable, and disable a 
location. A location is a URL where the Eclipse environment looks for 
new software (an update, patch or plug-in tool).

2. Click the Edit button.

The Edit Site dialog box appears.

3. In the Edit Site dialog box, change the name and location as required. 

4. Click OK to add site to the available software sites list.

5. Click Reload to test the change you made. If the software site is 
successfully added, a dialog box prompts that the site is available.

The following screen shot shows a successful test with the edited URL 
containing a slash at the end.
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Reload Connection
 

6. Click OK to close the Reload dialog box.

7. Click OK to close and exit the Preferences window.

Adding a new item

If the required software site is not available in the Work with drop-down 
list, add the web site to the list of the available software sites. 

1. Click the Available Software Sites link to open the preferences 
window that enables you to manage the list of URLs.

The Available Software sites preferences window appears. 

In this window you can add, edit, remove, enable, and disable a 
location. A location is a URL where the Eclipse environment looks for 
new software (an update, patch or plug-in tool).
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Available Software Sites
 

2. Click Add.

The Add Site dialog box appears.

3. In the Name text box, specify the name of the software site you want 
to add, such as MCU Update.

4. In the Location text box, specify the web site address. For example, 

http://freescale.com/lgfiles/updates/Eclipse/MCU10_3/
com.freescale.mcu.updatesite.

Add Site
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Step C: Select which CodeWarrior updates to install

There are options in this window to ensure that only that site is explored. 
This is important to avoid errors when updating. 

In the following screenshot the options are set up appropriately.

Set Options
 

1. Ensure to clear the Contact all update sites during install to find 
required software checkbox. You do not want to survey the entire 
universe of sites. You just want the CodeWarrior update site.

2. Check the Show only the latest versions of software available and 
Hide items that are already installed checkboxes. This limits the 
items displayed to those of interest.

With the options set as noted, the list of items presented are the most 
current versions of updates available that are not installed on your 
computer. From that list, select those that are of interest to you.

Step D: Install Selected Updates and Patches



9

1. Click Next in the Install dialog box.

The Install Details window appears listing some information about 
the items you selected. 

2. Click Next to confirm the items to be installed.

3. Accept (or reject) the license agreement. If you reject the license 
agreement the install process will be cancelled. 

4. Click Finish.

Progress dialog boxes will appear, unless always run such processes 
in the background is selected.

A security warning on unsigned content appears. 

5. Click OK to continue. 

NOTE During the installation a security warning of unsigned content 
appears. Click OK to continue. In case you do not select OK 
the installation will cancel.

Security Warning

6. You will be asked to restart the CodeWarrior tools. Click Yes.

.

If you encounter a problem with an update you will see a dialog box like 
this:

Section B: Troubleshooting Updates
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Problem Occurred
 

This usually happens if the URL to the CodeWarrior update site is wrong 
(missing the slash for example), or if you are looking at non-CodeWarrior 
sites. 

If you encounter this dialog box:

1. Select Window > Preferences from the CodeWarrior IDE menu bar.

2. Select Available Software Sites link.

The Available Software Sites dialog box appears.

3. Ensure that there is a corresponding location for the MCU 10.x tools 
in the Location list.

4. The location path has a slash at the end.

If there is no URL at all, add it. If there is no slash, edit the location to 
add the final slash. See Editing an existing item for instructions.

NOTE Although it should not be necessary, as an additional 
protection against looking in the wrong place, you can also 
disable all other locations than the CodeWarrior update 
location.

5. Ensure you have cleared the Contact all update sites checkbox in 
the Install New Software dialog box.

The CodeWarrior for Microcontrollers v10.x updates and patches are 
available for direct download from the Freescale WEB. The online update 
mode is recommended since the updater system can determine what is 

Section C: Updating Offline



11

already installed on your computer and automatically filter out older 
versions and updates/patches you already have. 

For computers that do not have direct access to the WEB, updates can be 
installed manually from an archive.

However, there are times when doing things manually still works best. In 
recognition of that, here's how to do it manually. 

To complete the update using the Offline mode, perform these steps.

Step A: Download a patch or update file

Step B: Select the Install New Software menu command

Step C: Open the archive and select software

Step D: Install Selected Updates and Patches

Step A: Download a patch or update file

1. Go to http://www.freescale.com/codewarrior and look for a download 
link. That will lead you to updates and patches for various versions of 
the CodeWarrior tools. 

For CW MCU v10.x Updates and Patches WEB page the URL is:

http://www.freescale.com/webapp/sps/site/
overview.jsp?code=CW_UPDATES_MCU_10_3.

2. Identify the update(s) and patch(es) you need. Save them to your 
computer. Note the saved locations since you will need this 
information for the installation process. The update(s) and patch(es) 
are *.zip file(s).

Step B: Select the Install New Software menu command

1. Open the CodeWarrior IDE.

NOTE If your CodeWarrior software is running on Windows 7, start 
the IDE using the Run as Admin option.

2. Select Window > Close All Perspectives from the CodeWarrior IDE 
menu bar.

http://www.freescale.com/webapp/sps/site/overview.jsp?code=CW_UPDATES_MCU_10_3.
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Close All Perspectives
 

3. Select Help > Install New Software from the CodeWarrior IDE menu 
bar.

Install New Software
 

The Install dialog box with the Available Software page appears.

Step C: Open the archive and select software

1. Click Add in the Install dialog box.

The Add Site dialog box appears.
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Add Site
 

2. Click the Archive button because you are looking for a file archive.

The Repository Archive dialog box appears.

3. Navigate to the file you downloaded and saved in Step 1&2.

The name will appear in the Work with field, and the information about 
the update or patch will appear in the Install window, as shown below.
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Install
 

4. Ensure to clear the Contact all update sites during install to find 
required software checkbox. You do not want to survey the entire 
universe of sites. You just want the CodeWarrior update site. 

5. Check the Show only the latest versions of software available and 
Hide items that are already installed checkboxes. This limits the 
items displayed to those of interest.

With the options set as noted, the list of items presented are the most 
current versions of updates available that are not installed on your 
computer. From that list, select those that are of interest to you.

Step D: Install Selected Updates and Patches

1. Click Next in the Install dialog box.

The Install Details window appears listing some information about 
the items you selected. 

2. Click Next to confirm the items to be installed.

3. Accept (or reject) the license agreement. If you reject the license 
agreement the install process will be cancelled. 
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4. Click Finish.

Progress dialogs will appear, unless always run processes in the 
background is selected. 

5. You will be prompted to select the trusted certificate. 

NOTE During the installation a security warning of unsigned content 
appears. Click OK to continue. In case you do not select OK 
the installation will cancel.

Trusted Certificates

6. You will be asked to restart the CodeWarrior tools. Click Yes.

Congratulations!
You have successfully installed Service Pack for your 

CodeWarrior software!
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How to Contact Us

Corporate 
Headquarters

Freescale Semiconductor, Inc.
6501 William Cannon Drive West
Austin, Texas 78735
U.S.A.

World Wide Web http://www.freescale.com/codewarrior

Technical Support http://www.freescale.com/support

Revised: March 29, 2013

http://www.freescale.com/codewarrior
http://www.freescale.com/support
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