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1 Overview

The Freescale MMA955xL Xtrinsic family devices are
high-precision, intelligent accel erometers built on the
Freescale ColdFire v1 platform.

The MMA955xL family’s microcontroller coreis
programmable and configurable with the Eclipse based
CodeWarrior for Microcontrollers Development Studio
software. CodeWarrior’s highly visual and automated
Integrated Design Environment (IDE), accelerates the
development of custom algorithms and features for
complex embedded applications.

This application note provides step-by-step instructions
to install the MM A 9550 Service Pack for CodeWarrior
v10.1. Thisservice pack supportsall MMA955xL family
devices. System requirements are specified and
instructions are given for locating, downloading and
installing the patch, and creating a blank MMA9550
project to verify successful installation.

For more information about the Eclipse IDE, read the
Eclipse documentation at:

http://www.eclipse.org/documentation/
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CodeWarrior IDE Requirements

2 CodeWarrior IDE Requirements

All CodeWarrior IDE products, Basic Suite, Standard Suite and Professional Suite, support MM A 955xL
devices. Users can aso develop their applications on the free download version of CodeWarrior, Special
Suite, subject to 1KB C++ code maximum limitation.

The MMA955xL service pack is compatible with CodeWarrior v10.1 and later. Please refer to
http://www.freescal e.com/codewarrior for system requirements using CodeWarrior IDE.

3 Service Pack Version Naming

The MMA955xL Service Pack naming convention illustrates that this service pack supports CodeWarrior
v10.1, and is built for of the MMA955xL family of devices as shown below:

Example: com.freescalemcul0_1.mma9550.win.vl 0 1.zip

4 Installation

The installation procedure below isto install the MMA9550 Service Pack. Users need to make sure that
CodeWarrior v10.1 is aready installed.

4.1 Online Mode Installation

Online mode installation is available using the integrated software installation tool instructions provided
in CodeWarrior. Access to areliable internet connection is required.

Steps for Online Installation:
1. Open CodeWarrior MCU IDE and go to Menu > Help > Install New Software.

® €IC+~+ - CodeWarrior Development Studio

File Edit Refactor Mavigate Search Project Run  Profiler Pracessor Expert  Window | Help

%) Welcome 52

Dynamic Help

Choose Help

CodeWarrior

Development St <o

Ky A CrrbShift+L
Tips and Tricks. ..
Chest Sheets...

Chack for Update:

Choose What's New Product Release Notes
Install New Software

CXAIMpPIE FIojects '\f Web Resources Service Packs, Updates

Figure 1. Begin online installation using the CodeWarrior integrated tool

Note: Installation dialogs may display differently depending on the CodeWarrior version being updated.
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Installation

2. When the Available Software Sites Install dialog is displayed, choose “--All Available Sites--" in
the “Work with” pulldown menu.

3. From the Available Software dialog, select the checkboxes labeled “CW MCU v10.1 Update”,
“MCU”, “MCU v10.1 Service Pack for MMA9550” and al other preferred items. Leave default

settings for boxes asiis.
4. Click Next.

AT The service pack

Avaiebie Saftwa location is identified
Check the Rems that you wish to instal, - I
Mprkwh |0 Avatibl Stes Select the checkboxes labeled
Find more softy
“CW MCU v10.1 Update”, “MCU”
ey Vorskn and “MCU v10.1 Service Pack
B\."- CW MU v10.1 Update PRI ”
8% mw i for MMA9550.
4 MCU v10.1 Compler Update (ColdFire, Kinetis, Qorr 1.0.2 |
D'S MCU v10.1 Service Pack for MC13233C 1.0.3
W MCU v10.1 Service Pack for MCPFS1F128 0. .
A 0101 Seviw ook for evieED 102 Leave default settings
e for boxes as is
|| 21 stow ondy the latest versions of avalable software e erms that are skready nstaled |
[ Group ems by category What is aisac installed? C||Ck NEXt

[Fcontact ol updste stes durng install to find requred software

Figure 2. Available Software dialog

5. CodeWarrior identifies and displays the related data packages that need to be installed, including
the MMA9550 service pack.

6. Click Next.

S CO"fI'™ the updates

Install Details | ]
/&, our original request has been modified. See the details. =]
= 5 )Ee

T

1.0.1 wull_1 beekit.win.s. ..
1.0.2 com.freescale. moul0_1 mma9ss50.wi...
L CaldFire Database 101 com freescale.meu.coldfiredb Featur.. .

Click Next

Size: Unknown
Details
ColdFire Tools DataBase

<sk ) nees

Figure 3. Install Details dialog

7. IntheReview Licensesdialog, read through the Freescale licensing agreements. If you agreeto the
terms, click to select “I accept the terms of the license agreement.”
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Installation

8. Click Finishto begin the service pack installation.

2 Install [ [

Review Licenses

Licenses musk be reviewed and accepted before the software can be installed, —]
4 ) =

License text:

FREESCALE SOFTW/ARE LICENSE AGREEMENT
This is a |=gal agreement between you (sither as

adieser | Review the license text and click
Socerns your righs b use his il are “laccept the terms of the license agreement”

By accompanying written materials (the "Softwa,

This Agresment

does ok concern your rights for

software that has its own separate lcense agresment, A list
of these license agresments is avallable ot

v, Freescale. comjcodewarrior fLicensetiatice and s

this software as a readme file, In

consideration for Fresscals allowing you to ~

wou are agreeing o be bound by the

terms of this Agreement, If you dr —u Of the terms . ..
of this Agreement, do not act

install the Software, If yr Juur rmind laker, stop using Click Finish
the Software and det- _yies of the

Software I your  _ssion o control. Any copies of the Software

that you he ueady distributed,

(1 aceept the terms of the license agreementt

O do nat accept the terms of the license agresment

()

[ <Back | wen [ Enish | [ cancet |

Figure 4. Review Licenses dialog

9. Duringinstallation, the security warning message shown below may pop up. Click OK to continue
installation.

Click OK

i ) Operation in progress. ..

[ ] ] T] ] ] [TTT |

Downloading com. freescale.mculd_1.mma%550.win, sp_roak

2 Security Warning
[ &lways run in background

Warning: You are installing software that contain . isigned content, The
B3 Install ! authenticity or validity of this software cannot b established. Do you want ko
(I T continue with the installation?

Downloading com. freescalz.n

OF, J [ Cancel ] [ Detalls =3 J

[Run in Background l [ Cancel ] [ << Details ]

Figure 5. Security Warning dialog

10. At the Software Updates dialog, click Yesto restart CodeWarrior.
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2 Software Updates | X Click Yes

¥ou will need to restart Codewwarrior Development Studia for the chan~_ wo

»._‘/ take effect, Would you like ko restart now?

L oves || mo |

Figure 6. Software Updates restart dialog

4.2 Offline Mode Installation

Offline mode installation may be used if access to the Internet is limited or you prefer to download the
patch for later installation.

The MMA 9550 service pack can be found and downloaded from the Freescale website:
http://www.freescal e.com/webapp/sps/site/overview.jsp?code=CW_UPDATES MCU_10 1.
Steps for Offline Installation:

1. Download the CW MCU v10.1 MMA9550 Service Pack, Windows or Linux, to your local drive
and note the location where the file is saved.

2. Open CodeWarrior Development Studio and choose Help > Install New Software.
Note: Installation dialogs may display differently depending on the CodeWarrior version being updated.

& €IC++ - CodeWarrior Development Studio

File Edit Refactor Mavigate Search Project Run  Profilsr Processor Expert  Window | Help

(%) welcome £2 @) Welcome

(Z) Help Contents

@ search
Dynamic Help

Choose Help

CodeWarrior

Development St 0

Key Assist. .. Chrl+Shift+L
Tips and Tricks..
Cheat Shests..,

Check for Updates

Choose What's New Product Release Notes
Install New Software
example Frojects “\{:,-” Web Resources Service Packs, Updates
< > -

Figure 7. Begin offline installation using CodeWarrior integrated tool and local file

3. When thelnstall dialog is displayed, choose Add.
4. When the Add Site dialog is displayed, select the Archive button.
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5. Browseto the location on your local drive where you saved “MCU 10.1 MMA9550 Service Pack
for Windows.”
6. Select it and click Open. The filelocation will be displayed in the Add Site dialog.

7. Click OK.

Avalubie Sofsen - | Choose Add

Snlect 3 5 o eriber b Rk of 4 ke,

‘et wieh " | TERERTIEN v g,

e Stes’ rufmeances.

Select Archive to
e [ T browse to the
“B [ T saved location

|

Select the MMA9550
service pack
and click Open

to extract the .zip file

My Documends

o -
— S
" Click OK when
Fin g o e, e v 101 o prompted to confirm
e Thowe Lew ‘ the service pack

Figure 8. Repository archive dialog

8. From the Available Software dialog, select the checkboxes labeled “CW MCU v10.1 Update”,
“MCU”, “MCU v10.1 Service Pack for MMA9550” and al other preferred items. Leave default

settings for boxes asiis.
9. Click Next.

AT The service pack

Aualiobie Sl tvarn location is identified
Chech the Rems that you wish to instal.
ket |22 fuslabl Shee- unmon  Select the checkboxes labeled
“CW MCU v10.1 Update”, “MCU”
Name Yersion and “MCU v10.1 Service Pack
B <6+ CW MCU v10.1 Update s ”
8% mw A for MMA9550.
D3 %% MCU v10.1 Compler Update (ColdFire, Kinetis, Qorr 1.0.2 I
D%+ MCU v10.1 Service Pack for MC13233C 1.0.3
e i Leave default settings
B for boxes as is
[ Show only the Iatest versions of avadable software [itide iermes that are skeady installed I
[ Growp items by eategory What i aiready instaled? Click Next
[Fcontact ol updste stes durng install to find requred software

Figure 9. Available Software dialog

10. Wait for the Updater to open the archive and display the Install Details dialog.
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Installation

11. CodeWarrior identifies and displays the related data packages that need to be installed, including
the MMA9550 service pack.

12. Click Next.

S CO"fI'™ the updates

Install Details

/i, our original request has been modified. See the details. \’_D —_J

Name version | Id

Featur

Update eescale mcul0_t beskitwin.s...
B L MU v10.1 Service Pack for MMASSS0 com. freescale. moul_L mmagsst.wi...

(% CaldFive Database 1001 com Fresscale. mou. coldfiredb Featur .

Click Next

Size: Unknown
Details

ColdFire Tools DataBase

More.

Figure 10. Install Details dialog

13. Inthe Review Licensesdial og, read through the Freescal e licensing agreements. If you agreeto the
terms, click to select “| accept the terms of the license agreement.”

14. Click Finish.

2 Install J
Review Licenses
Licenses must be reviewed and accepted before the software can be installed. \i) =

License kext:

FREESCALE SOFTWARE LICENSE AGREEMEMT
This is a legal agreement betwesn you (sither as

O s o oty veppesaeatnee of o Review the license text and click

employer) and Freescale Semiconductor, Inc, {"Fi .
ot vour ight to s th il and “laccept the terms of the license agreement”

any accompanying written materials (the "Softwar

This Agreement

does not concern your rights For

software that has its own separate license agresment. A list
of these license agreemerts is available at

sy, Freescale, com/codewarrior Licensehiotice and is

this software a5 a readme file. In

consideration For Freescale sllowing you to »

you are agresing to be bound by the

terms of this Agresment. IF you dr - of the terms . ..

of this Agreement, do nat acti

install the Software, If y- Juur mind later, stop using C I IC k Finis h
the Software and del- _pies of the

Software inyour  _esan or cortrol. Any copies of the Software
that youha  _ready distributed,

(&1 accept the terms of the license agreement!

(1 do not accept the terms of the license agreement

@ [ <cBock | we [_Ersh | [ cancel

Figure 11. Review Licenses dialog

15. During installation, the security warning message shown below may pop up. Click OK to continue
installation.
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Verification of the Installation

Click OK

Operation in progress...
1)

(in [ [ [ [ [ i)

Downloading com.freescale.mculd_1.mma%S50,win.sp_roat

2 Security Warning
[ abways run in background

‘“Warning: You are installng software that containe . signed content, The
' authenticity or walidity of this software cannot b established. Do vou want ta
continue with the installation?

—————————————————

Downloading com.freescale.n

OF, ] [ Cancel ] [ Dietails =3 ]

[.Run in Background_” Cancel H << Details ]

Figure 12. Security Warning dialog

16. At the Software Updates dialog, click Yesto restart CodeWarrior.

' Software Updates X Click Yes

y Wou will need ta restart CodeWWarrior Development Studio for the changes tr

\Q{v’ take effect. Would you like to restart now?

Figure 13. Software Updates restart dialog

5 Verification of the Installation

After completing the installation steps, we recommend customers verify the success of their installation
by following these steps:

1. When prompted by the Workspace L auncher, browse to select or create aworkspace directory and
click OK.
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Verification of the Installation

# Workspace Launcher

Browse to select
Select a workspace
Codewartior Development Studic stores your projects in 2 Folder called 3 workepace. or create a
Choose a workspace folder bo use for this session,
workspace
directory

workspace: || E I

Select Workspace Directory

Select the workspace directory to use,

Click OK

# (23 Start Menu ~

(2 Templates
I

@ 3 workspace — |

I ol Click OK

Select @ workspace
CodeWarmor our projects in & fokder caled a workspace,
o

Folder: | workspace

[ make vew Foider | [ ok W[ cancel

Worbspace: | UrFrmecaielpmassss| o |

[0 th s the chnfimin et st sk g

=)

Figure 14. Workspace Launcher dialog

2. From the main menu, choose File > New > Bareboard Project.

odeWarrior Devalopme dio B
Edit Refactor Mavigate Search Project Run Profler 200 Processor Expert Window Help

SR 3 Linue/uclinux Applicstion Project

CjC++ ‘
Open Path... ChrheShift+A [
[ Praject...
&% Source Folder 528 =0
(% Folder w

6] source il " outine is nat-
[ Header File e

o
% Fllefron

G s From the main menu
~aw.  Choose File >New > Bareboard Project

Conrvert Ling Delimitsrs To 3 =t
= el B-[3-
Switch 'Workspace Lo
Restart
xg Impart...
£ Export,., " L]

Fropertiss Alb+Enter

Figure 15. Begin a new Bareboard Project

3. Typeinthe project name “Verification_of sp MMA9550.”
Check the “Use default location” box.
5. Click Next.

>
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Verification of the Installation

Type in the project name
. “Verification_of_sp_MMA9550”

2 CIC+ + - CodeWarrior Development Studio
.0 F-Ei-E-
Q- &> 5

=) =0z ~"1 =0

“Use default

Check the
location” box

-
[ Coetrarion Froees %%
Create an MCU bareboard Proje-
| [Er[@r[@c=~ ™ =0
| Analysis - b33513-12.fsl.fr :
=oi t Click Next

File Name
Choose the location For the new pro®

=
-0

Project name: | Verftation_ofsp_MMAS5S3D
Use default location

Next >

Figure 16. New Bareboard Project dialog

[

- (2]

6. From the directory, choose Sensors > ColdFire vl > MCF51IMMA Family > MMA9550

7. Click Finish.

++ - CodeWarrior Development Studio
=5 i’i Y

ci- Choose Sensors > ColdFire V1 > MCF51MMA Family > MMA9550

_
Click Finish

(= MCFS1MMA Family
MAsSS0

1

MASSS0

]

| [ Fnish ][ cancel

[ <Back [ Next>
Figure 17. New Bareboard Project directory of devices

3

8. Now that anew project is created, confirm that C/C++ is the default perspective. From the main
menu, choose Window > Open Perspective. If C/C++ perspectiveis not listed in the menu, choose

Other.

Installation of the MMA955xL CodeWarrior Service Pack, Rev. 0
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Verification of the Installation

£ €fC++ - CodeWarrior Development Studio

File Edit Refactor Mavigste Search Project Run Profiler  ©7700 0 Processor Expet o
[T B iwe L F--R e Erey ! I
KR-B- i H-0-Q- & 1
L] v o - [ 5 Debug

Show View ¥ | £0 Team Synchronizing

EZ) Codewsirrior Projects 53 =g\~

Susberspective i
Reset Perspective...
Close Perspective
Close Al Per a5

-
(2= MMASSE0_Internal_Flash

(= Project_Headers = .ﬁ.

[# (= Project_Settings | £ &

(= Sources . -b33513-12.Fsl. Freescale.net: b33

2 8-

Choose Window > Open Perspective > Other

=
v

nf! Iwerification_of_sp_MMASS51

Figure 18. Determine the default perspective

9. Select C/C++ (default) from the Open Perspective dialog and click OK.

% Dpen Perspective

Select C/C++ (default)
[Py
[5Resource

£ Team Synchronizing 5 [FE e+ |

i EEI,“%‘ ;%'1 =0 Click OK

]
File Name |an outline is nor
=) 1= Verification_of_sp_MMa3! available,
& @ Includes
& & Lb

(= MMAZSS0_Internal_A ‘
(= Project_Headers — = =
@ T[Bcxx 2 =8|
| [ Project_Settings 4
# [ Sources b33513-12.Fsl. freescale.net:h33!

GufpH| et B-Ch~

[Cshow all

me

[Verification_nf_sp_MMAGSS1

Figure 19. Open Perspective dialog

If the MMA9550 service pack installation has been successful, your verification project named
“Verification_of_sp MMA9550” should be created and listed asanew project in the CodeWarrior Projects
navigation menu.
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Verification of the Installation

B ¢iC++ - CodeWarrior Development Studio

File Edt Refactor Mawigate Search Project Run Profiler SUCCESSfUl insta”ation:

s Boiwme g FH- B et
& F ton Ver|f|cgtlon_of_sp_MM.A9550 _should
- bein the CodeWarrior Project
[[& Codewarrior Projects &3 . nav|gat|0n menu
55|18, d £ 8|
File: Mame An outline is nok
—
Er[@r[Bcx\2 Td
Analysis - b33513-12 fsl freescale.net: b33
Wbl |t B-rer

Figure 20. Confirming a successful installation

For more information on how to create projects and program MMA955xL family devices, aswell as
evaluation software downloads, board support packages, videos, developer training and community
forums, go to http://www.freescale.com/cwmculO.

51 Commonly Asked Questions
Q1: What happensif | reinstall the service pack?

A1l: The support filesfor this device under CodeWarrior directory will be overwritten. If your installation
comes from the same service pack, the files will remain the same. Reinstalling the service pack will not
corrupt your project files.

Q2: | have an error message saying “ duplicated location” when | try to reinstall the service pack. What do
| do?

A2: Thisisbecausetheinstallation tool logsall softwareinstallations. If you started reinstalling the service
pack accidentally, cancel theinstallation. If the previousinstallation was corrupted, the easiest solution is
to install the service pack from another location.

Q3: Do | need to install the service pack every timel useit?

A3: No, the service pack installation is required only once per CodeWarrior devel opment environment. |f
you reinstall CodeWarrior, you will need to reinstall the service pack.

Q4: 1f | get the error message “missing dependency” during installation and can’'t proceed, what do | do?

A4: Go back to section 4.1 step 3 for online installation, or section 4.2 step 8 for offline installation, and
repeat the installation steps.
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